Solved

451 4.4.0 Primary target IP address responded with: "421 4.4.2 Connection dropped due to SocketError."

Posted on 2011-09-23
6
7,696 Views
Last Modified: 2012-05-12
I am deploying a Exchange 2010 installation into a 2003 environment with hopes of transferring mailboxes to the new 2010 server. However, I'm having some current issues with testing to get the environment at least coexistent so I can properly move over.

The Exchange 2010 server is using a 2010 Edge Transport as well.

On Wednesday we pointed the MX records at the Edge server and it seemed that mail flow between the 2003 and 2010 servers was good, and flow to and from the Internet was good as well. Then comes this morning where a lot of mail (655 messages now) destined for the 2003 legacy boxes (at this point it was 95% of the organization) were being stuffed in a queue on the 2010 box called SmtpRelayToTiRg. Also no messages between the 2003 server and 2010 server were flowing.

The error message in the title of this thread is the error being displayed on a lot of the messages in that queue.

I followed instructions from here which fixed the 2003 to 2010 flow, but not the 2010 to 2003 flow.
http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/8a15576d-ff5e-43bb-a92a-5dffef547465/

I am now able to send mail from 2003 to 2010. I cannot send mail from 2010 to 2003. Mail flows to and from the Internet to the 2003 boxes. And I can only send mail destined for the Internet from the 2010 boxes. That also caused messages on the 2003 server's queue to be sent to the 2010 mailboxes successfully.

I also am getting this error a few times in the Event log on the 2010 box from MSExchangeTransport:

MSExchangeTransport Event 5020
The topology doesn't contain a route to Exchange 2000 Server or Exchange Server 2003 2003-EXCHANGE.contosophx.contoso.org in Routing Group CN=First Routing Group,CN=Routing Groups,CN=First Administrative Group,CN=Administrative Groups,CN=Contoso Company,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=contosophx,DC=contoso,DC=org in routing tables with the timestamp 9/23/2011 8:42:51 AM.

MSExchangeTransport Event 5006
Cannot find route to Mailbox Server CN=2003-EXCHANGE,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=Contoso Company,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=contosophx,DC=contoso,DC=org for store CN=MailboxStore,CN=Second Storage Group,CN=InformationStore,CN=2003-EXCHANGE,CN=Servers,CN=First Administrative Group,CN=Administrative Groups,CN=Contoso Company,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=contosophx,DC=contoso,DC=org in routing tables with timestamp 9/23/2011 8:42:51 AM. Recipients will not be routed to this store.

At this moment, we've rolled back the MX/A records to the original 2003 server, and moved some of the mailboxes back to the 2003 server as well (only test boxes remain on the 2010 server).



I'm more than happy to provide any information or answer any questions. I apologize I may not get back to any questions for the next few hours.
0
Comment
Question by:justin-jurgens
  • 4
  • 2
6 Comments
 
LVL 7

Expert Comment

by:jesaja
ID: 36586142
did you check the RoutingGroupConnector


run the

Mail Flow Troubleshooter in Exchange Troubleshooting Assistant (ExTRA)
0
 

Author Comment

by:justin-jurgens
ID: 36588590
What am I needing to check on the RGC's? I have deleted them and recreated them already based on that link I put in my post. One for 2003 to 2010, and one for 2010 to 2003.

I have run the ExTRA.

Ran "Expected messages from senders are delayed or not received by some recipients"
Port 25, 587 and ping successful. I get the following message when trying to send from ExMFA-MailAcceptTest@Fabrikam.com to a 2003 mailbox:
Error submitting mail. Mail submission failed: Error message: The SMTP host was not specified..

Ran "Messages are backing up in one or more queues on a server" it comes up with the following errors
Area: SMTP Queue Status
--'Remote delivery' queue (2010-EXCHANGE\47) is backing up
--'Remote delivery' queue (2010-EXCHANGE\47) is in retry.
The 'Remote delivery' queue (2010-EXCHANGE\47) on server 2010-EXCHANGE is in retry status. Number of message(s) in the queue: 657. Last error information: 451 4.4.0 Primary target IP address responded with: "421 4.4.2 Connection dropped due to SocketError." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts.
0
 
LVL 7

Assisted Solution

by:jesaja
jesaja earned 200 total points
ID: 36590832
doesn't sound good
if the routing group connectors exist the mail should be transmitted to the Ex2003
from exchange 2010 you can resolve the Ex2003 FQDN and the ex2003 is listed when runnning get-exchangeserver

here are some links that might help solving the problem

http://technet.microsoft.com/en-us/library/bb218799%28EXCHG.80%29.aspx
http://technet.microsoft.com/en-us/library/bb232193.aspx#Older


http://geekswithblogs.net/cajunmcse/archive/2010/04/05/exchange-2010-exchange-2003-mail-flow-issue.aspx
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 

Accepted Solution

by:
justin-jurgens earned 0 total points
ID: 36897320
Turns out our VIPRE Email Security server was blocking comm between the two servers. We rebinded the SMTP sinks and email started flowing again.
0
 

Author Closing Comment

by:justin-jurgens
ID: 36923045
Giving you 200 pts for being the only person to help out, thanks for that =)
0
 

Author Comment

by:justin-jurgens
ID: 36897344
Solved the issue ourselves, after further research into error messages we took a "shoot-in-the-dark" with the VIPRE and turned it off then restarted the SMTP sinks. Mail flowed once again.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Utilizing an array to gracefully append to a list of EmailAddresses
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

947 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now