Solved

Login Issue

Posted on 2011-09-23
17
412 Views
Last Modified: 2013-12-07
This issue is very strange.  If I follow a link to experts-exchange from my email, it appears as though I'm not logged-in.  When I go directly to experts-exchange (not by following a link from email), it looks normal.  

In the attached screenshot, the page on the right is the one I'd followed from email (center bottom); the one on the left is a new window I'd opened with the entire URL pasted in from the other.  I reloaded both pages, and they both continue to behave the same (one's logged-in, one isn't).


EE-logged-in-but-not.jpeg
0
Comment
Question by:crazedsanity
  • 10
  • 4
  • 2
17 Comments
 
LVL 108

Expert Comment

by:Ray Paseur
Comment Utility
Wonder if this has anything to do with cookies?  Have you tried printing the cookies and looking at them?
0
 
LVL 4

Expert Comment

by:jschristian44
Comment Utility
This is completely normal.  They do not tie your login info with your email message for security purposes.  If you want to read the answers from the link clicked in your email, you have to log out on the other page, and login on the new page.  That is the only way and I have been doing it forever.  They do this, so if someone else gets your email, they cant read all your personal information, answers, etc.  It is this way for almost every good website that is high on security like experts exchange obviously is.  Don't change anything, you just need to login on the page everytime when you click it from your e-mail.  Good luck!
0
 
LVL 108

Expert Comment

by:Ray Paseur
Comment Utility
Interesting.  I follow links in the EE email messages and it works for me 100% of the time.  I use GMail.  Here are the cookies.
EE-Cookies.png
0
 
LVL 4

Expert Comment

by:jschristian44
Comment Utility
I use Gmail as well and it has always been this way for me.  It might be if you already have a site up for EE open already, it doesn't want to log you in twice.  Try closing one session and only opening the email one.  If it still does it, then there isn't much you can do.
0
 
LVL 9

Author Comment

by:crazedsanity
Comment Utility
Thank you all for your input.  

This problem has only recently appeared: I had always been follow links from Gmail to EE and have it show that I'm logged-in.  I've been building dynamic websites like Experts Exchange for over a decade, and I've never encountered this particular problem.

The one thing that might be affecting the situation is one of the add-ons in Firefox, called "WebMail Notifier".  I had some issues with it recently where it wasn't able to login to some of my accounts, and it definitely does some "magic" as far as cookies and so forth, as it keeps me logged-in to each of my accounts if I have multiple open (though, admittedly, that may be something more with Gmail and less with WebMail Notifier).

I haven't had a lot of time to look into this yet, but I will check out all of your suggestions.  
0
 
LVL 9

Author Comment

by:crazedsanity
Comment Utility
@jschristian44: I don't understand how a login would "follow" a link.  Cookies are attached to a website based on the domain, so there's no way (that I know of) for login information to be attached to the link itself, except "sort of" if the link as a session ID in it (which would constitute a massive security hole)... maybe explain this a bit more?
0
 
LVL 108

Accepted Solution

by:
Ray Paseur earned 500 total points
Comment Utility
@crazedsanity: I had a problem with Firefox a couple of versions ago when I used dynamic data in a session array.  This smells a little like that problem. The problem went away when I upgraded to the current Firefox.  Net-net: the cookies were not always being sent properly.  I have noticed that all instances of a browser share the same cookie jar, so duplicate logins should not cause a problem.
0
 
LVL 9

Author Comment

by:crazedsanity
Comment Utility
I've done a cursory examination of my cookies pertaining to experts-exchange.com, and I didn't see anything wrong... Ray, do you know of a particular cookie that might be causing the problem if it is malformed or missing?  This seems like a timing thing, so possibly one of the cookies is missing at the time that I have to re-login.
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 
LVL 108

Expert Comment

by:Ray Paseur
Comment Utility
No, I am not sure which cookie might be the issue.  But the EE staff might be able to answer that question.

Does this problem occur when you use other computers and other browsers?
0
 
LVL 9

Author Comment

by:crazedsanity
Comment Utility
I tried to replicate on:
Windows XP x64 using Chrome 14.0.835.186
Windows XP x64 using Firefox 7.0
Windows XP x64 using Internet Explorer 8.0.6001.18702
Ubuntu 10.04.3 LTS using Chromium 12.0.742.112

All work as expected.  Other than my laptop (Ubuntu 10.04.3), I don't have a machine that still runs Firefox 6.x.  These tests have all been short-term tests, however, and I expect that something specific is causing the problem.  Perhaps a good test will be to disable the WebMail Notifier extension.

I'm not sure if that is the issue or not... once the update for FF7 becomes available on my laptop, we'll see if the issue is resolved.
0
 
LVL 9

Author Comment

by:crazedsanity
Comment Utility
FYI: The upgrade to FF7 does not appear to have changed anything.
0
 
LVL 9

Author Comment

by:crazedsanity
Comment Utility
The peculiarities I've noticed:

When opening the link from Gmail, I will show as logged in if I right-click and select "open in a new tab" or "open in a new window".  Clicking the link normally, which opens in a new tab for me, shows me as not logged-in...

I've got this site bookmarked as well.  If I single-click that over a Gmail window, it shows me as not logged-in; if I right-click and "open in a new window" or "open in a new tab" I'm logged in.  If I single-click it over ANY OTHER existing page or over a new tab, I'm still logged-in.

I don't get it.  Something magical is happening behind the scenes, and I'm starting to believe it has something to do with how Gmail works or how Firefox treats Gmail (Gmail).

Also, as far as I can tell, it only happens from ONE email account (which is where the EE notifications go); if I have another open & use the bookmark, it works fine.

Can anybody give me some ideas on how to troubleshoot the problem?  
0
 
LVL 9

Author Comment

by:crazedsanity
Comment Utility
Another peculiarity: the same problem exists with Twitter.  When I click a link from Gmail to Twitter, I'm not logged-in; if I open the link in a new tab, it works as expected.

So the problem is not unique to Experts Exchange.  Now what I need is some insight on how to track-down this problem.
0
 
LVL 9

Author Comment

by:crazedsanity
Comment Utility
UPDATE: running Firefox in safe mode (firefox -safe-mode) alleviates the problem...
0
 
LVL 9

Assisted Solution

by:crazedsanity
crazedsanity earned 0 total points
Comment Utility
I've migrated most of my email accounts (gmail-based) into an actual email program, Evolution, so that they're not being actively checked while I'm online.  I still have my main account being checked.

After having made these changes, disabled all but the primary account within the "WebMail Notifier" Firefox add-on, and unchecking the "Use multiple logon" option, the problem seems to have gone away.  Provided the problem stays fixed, I'll close this question and assign points to those that took time to help.

Any thoughts on this situation would be appreciated.
0
 
LVL 9

Author Closing Comment

by:crazedsanity
Comment Utility
The final solution to this puzzle changing the "Webmail Notifier" Firefox plugin to stop checking multiple accounts.  I have no idea why this affected non-Google sites.  Ultimately, I did not find a good way to debug the problem.
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Citrix XenApp, Internet Explorer 11 set to Enterprise Mode and using central hosted sites.xml file.
Several part series to implement Internet Explorer 11 Enterprise Mode
Learn how to match and substitute tagged data using PHP regular expressions. Demonstrated on Windows 7, but also applies to other operating systems. Demonstrated technique applies to PHP (all versions) and Firefox, but very similar techniques will w…
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now