Solved

Users do not send emails to other organization within the mode Exchange Hosting

Posted on 2011-09-23
37
890 Views
Last Modified: 2012-08-14
Friends, again I ask your help.

The users that are in different organizations within the Exchange 2010 SP1 on my hosting so do not send messages to each other, then searching I found this site:

http://www.zerohoursleep.com/2010/10/step-by-step-starting-with-exchange-2010-sp1-multi-tenant-sending-and-receiving-emails/

But that's the thing that shakes, see what the guy's site and talk about my problem:

ending Inter-Organization emails

Well this is where things are new! I started by simply sending an email between 2 users in different organizations and, instead of reaching its destination, it went directly to the unreachable queue !

21

What does it mean?
Well it means that Users in different organizations are treated as completely independent, the user will not be resolved "locally" in Active Directory and delivered it will use the send connectors just like any other alien domain.

How to solve this?
Well I am sure there are a lot of ways to do this but, since I am in a lab environment with only one server I have created a send connector for all the organizations smtp domains and set it to use the loopback IP address as smart-host connector

... So the solution he found was to create a connector to solve the problem, but it is the scenario lab, so he used the code that is below does not apply to my scenario, someone would know how I could create a plug in my scenario to solve my problem?

Thank you friends.
0
Comment
Question by:welltecnologia
  • 23
  • 13
37 Comments
 

Author Comment

by:welltecnologia
ID: 36587425
If they give visiting this site:

http://www.zerohoursleep.com/2010/10/step-by-step-starting-with-exchange-2010-sp1-multi-tenant-sending-and-receiving-emails/

And look at the text:
Sending emails Inter-Organization

It seems to me that he created a connector to send users enters Inter-Organizations

But do not understand how such a connector in powershell, I think this is the path.

I appreciate the help of you all.
0
 

Author Comment

by:welltecnologia
ID: 36592153
Hello ????
0
 

Author Comment

by:welltecnologia
ID: 36592154
Please...
0
Are your AD admin tools letting you down?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

 

Author Comment

by:welltecnologia
ID: 36711337
really, what good is this site?
the delay to answer gets to be absurd.

if the service will be paid, so you have to be more organized, especially for a person who will be customers of yours.

I am very dissatisfied with the service of you.
0
 
LVL 15

Expert Comment

by:MarkMichael
ID: 36713253
This works for me:


new-SendConnector -Name 'TestOrg' -Usage 'Internal' -AddressSpaces 'SMTP:testorg.com;1','SMTP:lab.com;1' -IsScopedConnector $false -DNSRoutingEnabled $false -SmartHosts '[127.0.0.1]' -SmartHostAuthMechanism 'None' -UseExternalDNSServersEnabled $false -SourceTransportServers 'Exchange'


This created a send connector with
Name of 'Test Org'
- Matches to domain with SMTP domain of: testorg.com
- Matches to domain with SMTP domain of: lab.com

Uses Smarthost [172.0.0.1] (loopback to the local hub transport server)
Using emails sent from 'SourceTransportServers <Your Exchange HUB Transport Server Name Goes Here>

Bare in mind, when asking questions about multi-tenant system, its a system that is not used very much, meaning people don't know a whole lot about it.
You are also paying for the privilege to ask questions to experts and not for a guaranteed answer at a set time.
0
 

Author Comment

by:welltecnologia
ID: 36713585
Yes, I understand the system well until you have created.
What is not understand the delay in responding.

Hence my disappointment. I know it may take take but, as you may have millions of questions to answer.

But take days .... It really does not worth it for those who are paying.

It was just constructive criticism, I hope you understand it this way.
0
 

Author Comment

by:welltecnologia
ID: 36713987
friend you see, a doubt.

the problem in the above example is only when the Exchange 2010 SP1 is hosting two domains.

but in my environment I have over 40 domains.

I'll have to create 40 of these connectors one by one?
0
 

Author Comment

by:welltecnologia
ID: 36716236
please..
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36716257
can you please give me more info about your setup so i can help ?

how do you send internet emails ? do you have any kind of mail relay ?
0
 

Author Comment

by:welltecnologia
ID: 36716270
I made the connector as explained above.
but the above explanation is only when the exchange has 2 domains in it.

then this connector causes the two domains to speak of but you know?

but in my case I have 40 domains on my exchange, my doubt is how to put all domains at once paired to create only one connector for all 40 domains can talk to each other.

in the example above I would have to create 40 connectors for each domain you understand?

I tried to separate the domains with commas and not worked.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36716294
you will need to create your connector something like

new-SendConnector -Name 'TestOrg' -Usage 'Internal' -AddressSpaces 'SMTP:dom1.com;1','SMTP:dom2.com;1','SMTP:dom3.com;1' -IsScopedConnector $false -DNSRoutingEnabled $false -SmartHosts '[127.0.0.1]' -SmartHostAuthMechanism 'None' -UseExternalDNSServersEnabled $false -SourceTransportServers 'Exchange'


this will solve your problem, but still my question. do you have any kind of relay you use?
0
 

Author Comment

by:welltecnologia
ID: 36716312
I do not understand your question about the relay.
I could explain more about your doubts?
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36716314
how do you send emails to the internet
0
 

Author Comment

by:welltecnologia
ID: 36716321
yes.
this is a production server.

shipping with the standard connectors that was created by the installation itself.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36716332
run get-sendconnector | fl and give me the resutls
0
 

Author Comment

by:welltecnologia
ID: 36716345
Ok, see:

[PS] C:\>Get-SendConnector | fl


AddressSpaces                : {SMTP:*;1}
AuthenticationCredential     :
Comment                      :
ConnectedDomains             : {}
ConnectionInactivityTimeOut  : 00:10:00
DNSRoutingEnabled            : True
DomainSecureEnabled          : False
Enabled                      : True
ErrorPolicies                : Default
ForceHELO                    : False
Fqdn                         :
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : SRV-EMAILS
Identity                     : To Internet
IgnoreSTARTTLS               : False
IsScopedConnector            : False
IsSmtpConnector              : True
LinkedReceiveConnector       :
MaxMessageSize               : 10 MB (10,485,760 bytes)
Name                         : To Internet
Port                         : 25
ProtocolLoggingLevel         : None
RequireOorg                  : False
RequireTLS                   : False
SmartHostAuthMechanism       : None
SmartHosts                   : {}
SmartHostsString             :
SmtpMaxMessagesPerConnection : 20
SourceIPAddress              : 0.0.0.0
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {SRV-EMAILS}
TlsAuthLevel                 :
TlsDomain                    :
UseExternalDNSServersEnabled : False
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36716366
ok so you have only one connector.


how many HUB servers you have ?
0
 

Author Comment

by:welltecnologia
ID: 36716373
only one.
Exchange 2010 SP1 in hosting mode, is with all roles installed on it.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36716383
ok then run the below, of course replace dom1.com dom2.com .... by your domains names and give it a try

new-SendConnector -Name 'TestOrg' -Usage 'Internal' -AddressSpaces 'SMTP:dom1.com;1','SMTP:dom2.com;1','SMTP:dom3.com;1' -IsScopedConnector $false -DNSRoutingEnabled $false -SmartHosts '[127.0.0.1]' -SmartHostAuthMechanism 'None' -UseExternalDNSServersEnabled $false -SourceTransportServers 'SRV-EMAILS'
0
 

Author Comment

by:welltecnologia
ID: 36719305
I understand, but as I define the size of messages?
MaxMessageSize field is unlimited.
0
 

Author Comment

by:welltecnologia
ID: 36720269
hello ?
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36720417
The default value is 10 megs, if you want to change it just add

-MaxMessageSize '100mb'
0
 

Author Comment

by:welltecnologia
ID: 36724125
But tell me, how to put this information in the code you sent me?
0
 
LVL 49

Accepted Solution

by:
Akhater earned 500 total points
ID: 36812659
new-SendConnector -Name 'TestOrg' -Usage 'Internal' -AddressSpaces 'SMTP:dom1.com;1','SMTP:dom2.com;1','SMTP:dom3.com;1' -IsScopedConnector $false -DNSRoutingEnabled $false -SmartHosts '[127.0.0.1]' -SmartHostAuthMechanism 'None' -UseExternalDNSServersEnabled $false -SourceTransportServers 'SRV-EMAILS' -MaxMessageSize '100mb'
0
 

Author Comment

by:welltecnologia
ID: 36814245
Ok, great!

But I ran this command and my 40 domains now rather speak of.
What happens now is the following:

When I set up Outlook 2010 for my clients, I use autodiscovery. So I open the control panel and go in the EMAIL to configure the profile, then just put the account name, then the email account and password, after these steps I send check the name and password and the application itself EMAIL makes all settings account automatically.

Everything works perfectly, but as you use Outlook it sometimes asks for a password, if not enter the password below where he warns appears Connected to Microsoft Exchange is well NESCESSARIA PASSWORD.

Now if I type the full email address and password of the User give it back to reconnect.

But this is not a time to ask, is intermittent.

You know how I can check what is wrong?

I believe it has something to do with this event log viewer:

Inbound authentication failed with error LogonDenied for Receive connector Default MAIL-SRV. The authentication mechanism is NTLM. The source IP address of the client tried to authenticate to Microsoft Exchange is [187.63.202.46].

Thanks for all personnel.
0
 

Author Comment

by:welltecnologia
ID: 36814260
Ok, great!

But I ran this command and my 40 domains now rather speak of.
What happens now is the following:

When I set up Outlook 2010 for my clients, I use autodiscovery. So I open the control panel and go in the EMAIL to configure the profile, then just put the account name, then the email account and password, after these steps I send check the name and password and the application itself EMAIL makes all settings account automatically.

Everything works perfectly, but as you use Outlook it sometimes asks for a password, if not enter the password below where he warns appears Connected to Microsoft Exchange is well PASSWORD REQUIRED.

Now if I type the full email address and password of the User give it back to reconnect.

But this is not a time to ask, is intermittent.

You know how I can check what is wrong?

I believe it has something to do with this event log viewer:

Inbound authentication failed with error LogonDenied for Receive connector Default MAIL-SRV. The authentication mechanism is NTLM. The source IP address of the client tried to authenticate to Microsoft Exchange is [187.63.202.46].

SOURCE: MSExchangeTransport: Task Category: SmtpReceive

Thanks for all personnel.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36814858
this is a totally different issue, i will need to ask you to close this question and open a new one for this error
0
 

Author Comment

by:welltecnologia
ID: 36814889
I understand, but see the error that is giving now, after I created this connector.

User is an organization's domain hosting exchange sends an email back with this error:


Delivery to the following recipient failed permanently:

     well@aliancanegocios.com.br

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient
domain. We recommend contacting the other email provider for further
information about the cause of this error. The error that the other server
returned was: 550 550 5.7.1 Message rejected due to content restrictions
(state 18).

The User has an email in GMail and he tries to send the email to a domain within the organizaçãod the exchange, but then Gmail returns with this error.

I deleted the connector you created and give yes, Gmail can deliver the mail.

Can you help me then this error?

There's something wrong in creating the connector.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36814927
the connector we created has nothing to do at all with this error !

recreate the connector and let me know when you do
0
 

Author Comment

by:welltecnologia
ID: 36815000
Correct.

I do not understand.
When Gmail tries to send an email to this domain which is within the Exchange organization e-mail returns to the User GMail with this error.

Tell you what, I will recreate the connector using this command:

new-SendConnector -Name 'ENVIO-INTERNO' -Usage 'Internal' -AddressSpaces 'SMTP:dominio1.com.br;1','SMTP:dominio2.com.br;1','SMTP:dominio3.com.br;1', -IsScopedConnector $false -DNSRoutingEnabled $false -SmartHosts '[127.0.0.1]' -SmartHostAuthMechanism 'None' -UseExternalDNSServersEnabled $false -SourceTransportServers 'SRV-EMAILS'-MaxMessageSize '100mb'

Send an email to well@aliancanegocios.com.br

If you have GMail would be better, for you see the error that Gmail sends it back to you.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36815022
have you recreated the connector ?
0
 

Author Comment

by:welltecnologia
ID: 36815024
[PS] C:\>Get-SendConnector | fl


AddressSpaces                : {SMTP:*;1}
AuthenticationCredential     :
Comment                      :
ConnectedDomains             : {}
ConnectionInactivityTimeOut  : 00:10:00
DNSRoutingEnabled            : True
DomainSecureEnabled          : False
Enabled                      : True
ErrorPolicies                : Default
ForceHELO                    : False
Fqdn                         :
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : SRV-EMAILS
Identity                     : To Internet
IgnoreSTARTTLS               : False
IsScopedConnector            : False
IsSmtpConnector              : True
LinkedReceiveConnector       :
MaxMessageSize               : 10 MB (10,485,760 bytes)
Name                         : To Internet
Port                         : 25
ProtocolLoggingLevel         : None
RequireOorg                  : False
RequireTLS                   : False
SmartHostAuthMechanism       : None
SmartHosts                   : {}
SmartHostsString             :
SmtpMaxMessagesPerConnection : 20
SourceIPAddress              : 0.0.0.0
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {SRV-EMAILS}
TlsAuthLevel                 :
TlsDomain                    :
UseExternalDNSServersEnabled : False

AddressSpaces                : {SMTP:dominio1.com.br;1, SMTP:dominio2.com.br;1, SMTP:dominio3;1, SMTP:dominio4.com.br;1}
AuthenticationCredential     :
Comment                      :
ConnectedDomains             : {}
ConnectionInactivityTimeOut  : 00:10:00
DNSRoutingEnabled            : False
DomainSecureEnabled          : False
Enabled                      : True
ErrorPolicies                : Default
ForceHELO                    : False
Fqdn                         :
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : SRV-EMAILS
Identity                     : ENVIO-INTERNO
IgnoreSTARTTLS               : False
IsScopedConnector            : False
IsSmtpConnector              : True
LinkedReceiveConnector       :
MaxMessageSize               : 100 MB (104,857,600 bytes)
Name                         : ENVIO-INTERNO
Port                         : 25
ProtocolLoggingLevel         : None
RequireOorg                  : False
RequireTLS                   : False
SmartHostAuthMechanism       : None
SmartHosts                   : {[127.0.0.1]}
SmartHostsString             : [127.0.0.1]
SmtpMaxMessagesPerConnection : 20
SourceIPAddress              : 0.0.0.0
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {SRV-EMAILS}
TlsAuthLevel                 :
TlsDomain                    :
UseExternalDNSServersEnabled : False



[PS] C:\>
0
 

Author Comment

by:welltecnologia
ID: 36815032
Yes, test please..
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36815052
go check your inbox of well@aliancanegocios.com.br you will see a test email there, your emails are working perfectly
0
 

Author Comment

by:welltecnologia
ID: 36815417
friend

investigating with my client, we found that blocking that makes GMail to send is that the client is sending mail to Gmail well@aliancanegocios.com.br emails and attaching to the extension. IML

but this block seems to be done by 2010 and Forefront connector not understand?

if not make sure you check Forefront blocking send, but it looks that way.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 36815442
the NDR error you are getting is from forefront and not from exchange this is a forefront issue, not related to the connector
0
 

Author Comment

by:welltecnologia
ID: 36815519
understood it, from what I noticed is blocking my server to receive this email from gmail with this type of attachment.

I believe that content filtering is causing this.

but that's okay, I think my problem was solved with your help.

really, your help is fantastic and great value.

parabens and always remain so, I recomedar you to all my friends who manage the exchange.

thank you.
0

Featured Post

Best Practices: Disaster Recovery Testing

Besides backup, any IT division should have a disaster recovery plan. You will find a few tips below relating to the development of such a plan and to what issues one should pay special attention in the course of backup planning.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
Read this checklist to learn more about the 15 things you should never include in an email signature.
Viewers will learn how to maximize accessibility options in an Excel workbook for users with accessibility issues.
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question