Solved

Cisco 1760 to sip provider

Posted on 2011-09-23
4
1,437 Views
Last Modified: 2012-08-14
How do I configure in bound calls to my Cisco 1760 running call manager express 4.0.3. I am beginner in voip... my set up.. is a Cisco 1760 ( router on a stick ) and Cisco 2950 switch. Voip phones are on a different VLAN..  but i can ping out to the internet from the voip vlan..  other vlan is for workstation traffic..  I want to use a DID number from a Sip provider... what i need is a simple config with a little explanation to give me a clue.....

Thanks
Neal Kelley
0
Comment
Question by:agutthon777
  • 2
  • 2
4 Comments
 
LVL 15

Accepted Solution

by:
greg ward earned 125 total points
ID: 36591288
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip  < only use what you need
 !
!
!
voice class codec 100
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g723r53
 codec preference 4 g729r8
 codec preference 5 g726r32
 codec preference 6 g728  < codecs is order of use



!
voice translation-rule 9
 rule 1 /.*/ /your sip number/  < tell the sip provider the number making the call is the number registered with them

voice translation-profile tosip
 translate calling 9


sip-ua
 authentication username 12345 password abcde
 retry invite 4
 retry response 3
 retry bye 2
 retry cancel 2
 retry register 5
 timers notify 1000
 timers register 1000
 registrar dns:sip.myphone.ge expires 3600
 sip-server dns:sip.myphone.ge
 

connection-reuse                                                  <
 nat symmetric role passive                                   < use if you are behind another router
 nat symmetric check-media-src                             <

make sure your phone is configured with the right number

i have omited this part :)

to check you have registered

show sip reg status

Greg
0
 

Author Comment

by:agutthon777
ID: 36714782
  i am getting the following errors ..

Sep 28 05:23:00.257: //70/000000000000/SIP/Error/sipSPIHandleAuthChallenge: 401/407 response missing Authenticate header
Sep 28 05:23:00.257: //70/000000000000/SIP/Error/ccsip_api_register_result_ind: Message Code Class 4xx Method Code 100 received for REGISTER

here is the running config...

Current configuration : 3140 bytes
!
! Last configuration change at 01:14:51 EDT Wed Sep 28 2011
! NVRAM config last updated at 00:36:33 EDT Wed Sep 28 2011
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c1760
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
clock timezone EST -5
clock summer-time EDT recurring
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool voip
   network 10.0.0.0 255.255.255.0
   default-router 10.0.0.1
   option 150 ip 10.0.0.150
!
!
ip name-server 192.168.1.254
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 sip
  registrar server
  call service stop
!
!
!
voice class codec 100
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g723r53
 codec preference 4 g729r8
 codec preference 5 g726r32
 codec preference 6 g728
!
!
!
!
!
!
!
!
voice translation-rule 9
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 192.168.1.11 255.255.255.0
 no snmp trap link-status
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip address 10.0.0.1 255.255.255.0
 no snmp trap link-status
!
ip default-gateway 192.168.1.254
ip route 0.0.0.0 0.0.0.0 192.168.1.254 permanent
!
ip http server
no ip http secure-server
ip http path flash:
!
tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
tftp-server flash:P0030702T023.sbn
!
control-plane
!
!
!
!
!
!
!
!
dial-peer voice 3401 voip
!
dial-peer voice 20 voip
 service session
 destination-pattern 0T
 session protocol sipv2
 session target dns:trunk.phonebooth.net
 dtmf-relay sip-notify
 clid network-number 7188396006
!
gateway
 timer receive-rtp 1200
!
sip-ua
 authentication username xxxxxxx password xxxxxxxxx
 nat symmetric role passive
 nat symmetric check-media-src
 retry invite 4
 retry response 3
 retry cancel 2
 retry register 5
 timers notify 1000
 timers register 1000
 registrar dns:trunk1.phonebooth.net expires 3600
 sip-server dns:trunk1.phonebooth.net
connection-reuse
!
!
telephony-service
 load 7960-7940 P0030702T023
 max-ephones 4
 max-dn 4
 ip source-address 10.0.0.1 port 2000
 auto assign 1 to 4
 max-conferences 4 gain -6
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1
 number 1111 no-reg primary
 name Neal Kelley
!
!
ephone-dn  2
 number 7188396006
 name Neal Kelley
!
!
ephone-dn  3
 number 1113 no-reg primary
 name Marol
!
!
ephone-dn  4
 number 1114 no-reg primary
!
!
ephone  1
 no multicast-moh
 mac-address 0007.0E15.D15E
 type 7941
 button  1:1
!
!
!
ephone  2
 mac-address 0007.0E57.7EE6
 type 7941
 button  1:2
!
!
!
ephone  3
 no multicast-moh
 mac-address 0007.0E6D.4DB4
 type 7941
 button  1:3
!
!
!
ephone  4
 no multicast-moh
!
!
!
line con 0
 password xxxxxx
 login
line aux 0
line vty 0 4
 password xxxxxx
 login
!
ntp authenticate
ntp clock-period 17208221
ntp server 130.207.244.240
end
0
 
LVL 15

Expert Comment

by:greg ward
ID: 36714823
session target dns:trunk.phonebooth.net

 registrar dns:trunk1.phonebooth.net expires 3600
 sip-server dns:trunk1.phonebooth.net

should the dns be different?
I have only set this  up on fxs ports so i will try and do this on my lab using a 7941.


Greg
0
 

Author Comment

by:agutthon777
ID: 36714901
i got it to register..  thanks for your help..
0

Featured Post

Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Introduction This article explores the design of a cache system that can improve the performance of a web site or web application.  The assumption is that the web site has many more “read” operations than “write” operations (this is commonly the ca…
Data center, now-a-days, is referred as the home of all the advanced technologies. In-fact, most of the businesses are now establishing their entire organizational structure around the IT capabilities.
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

792 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question