Solved

Certificate error for EVERY https site in IE9

Posted on 2011-09-23
9
902 Views
Last Modified: 2013-12-08
Hey guys, after upgrading our firm to IE9, we're getting "There is a problem with this websites security certificate" whenever users go to ANY secure website. Has anyone else ran into this? I'm wondering if there's something in GP that's causing this, that wasn't an issue with IE8. If a user is on Firefox, they don't have the issue. From what I've read, the date and time can cause this, but that's not the issue here. Any other suggestions?
0
Comment
Question by:fza11404
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
9 Comments
 
LVL 50

Expert Comment

by:jcimarron
ID: 36592834
0
 

Author Comment

by:fza11404
ID: 36712220
Well, I've checked the clock, so thats not it. Its literally EVERY https site I visit.There's just no way they would all have incorrect security certs. Again, this all started as soon as we released the IE9 update through WSUS.
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 36712384
fza11404--
1)  Try turning the Phishing filer off.
2)   Look in IE Tools|Internet Options|Advanced tab| see whether SSL 3.0 and TSL 1.0 are checked.  If not check them|ApplyOK.
0
Enroll in July's Course of the Month

July's Course of the Month is now available! Enroll to learn HTML5 and prepare for certification. It's free for Premium Members, Team Accounts, and Qualified Experts.

 

Author Comment

by:fza11404
ID: 36712427
Hmm, nope, still no luck. This is so odd.......
0
 
LVL 70

Expert Comment

by:Merete
ID: 36814274
Did you run internet explorer as an administrator?
Try using the delete all cookies and temporary internet files incase there is some temp files left over from Internet Explorer 8
------------------------------
Have you checked the smart screen fiter is on?
Go to tools
also in tools go to Content click on certificates>intermediate Certification Authorities>Advanced>
everything is ticked in here except for Client Authentation and Secure Mail.
You could lower your security to recomended?
------------------------------
Delete the offending certificate and IE 9 should recreate it.
Open Internet Explorer.
Click on Tools then  Internet Options
Click Content tab.
open  Certificates
 under the Certificates" heading  ( ALL) below this
You'll see Trusted Root  Certification Authorities then  two listing Other People Intermediate Cert Authorities and trusted Root Certificates right next to this is a couple of arrows one for left and one for scroll right
Do so and click on the right arrow to scroll right, keep clicking on it till you see Untrusted Publishers. Then click on the certificate that is causing a error message.
Next, click Remove to delete that certificate.
Apply and OK
Exit Internet Explorer and  re-open

content-arrow.jpg
untrusted.jpg
0
 

Author Comment

by:fza11404
ID: 36816518
Hmm, no, those steps still did not help. I've also noticed now that when I try to run applications off our server, I'm getting a "The publisher could not be verified" dialog box for almost all of them. I'm now pretty sure its a Group Policy problem. What do you guys think?
0
 
LVL 50

Expert Comment

by:jcimarron
ID: 36816546
0
 

Accepted Solution

by:
fza11404 earned 0 total points
ID: 36964087
In the end, we decided to blast a bunch of old unnecessary GP entries and it took care of it. Somewhere in there, we had a conflict. Unfortunately, we don't know exactly which GPO fixed it, so I cant post the fix.
0
 

Author Closing Comment

by:fza11404
ID: 37052178
Answered internally.
0

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Do you come here a lot? Are you lazy like me and don't want to go through the "trouble" of having to click your Dock's Safari icon and then having to click your Experts Exchange Favorites bookmark to get here? Well then this article is for you.
#Citrix #Internet Explorer #Enterprise Mode #IE 11 #IE 8
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…
Suggested Courses

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question