?
Solved

Unable to Autodiscover exchange server

Posted on 2011-09-23
12
Medium Priority
?
3,142 Views
Last Modified: 2013-02-26
Here is my situation, I am unable to get the Autodiscover to work on my Exchange 2010 server.  I have installed my 2003 exchnage server certificate on my 2010 server but for some unknown reason I can get this work.  I ran this command on the Exchange server:

[PS] C:\>$cred=Get-Credential some-company\ktest
[PS] C:\>Test-OutlookConnectivity -Protocol:http -Identity ktest -MailboxCredential $cred -verbose

And I get this, it is erroring out, any ideas why?  What should I be looking for?


VERBOSE: [18:07:38.327 GMT] Test-OutlookConnectivity : Active Directory session settings for 'Test-OutlookConnectivity'
 are: View Entire Forest: 'False', Default Scope: 'some-company.com', Configuration Domain Controller:
'prdc1.some-company.com', Preferred Global Catalog: 'DRDC1.some-company.com', Preferred Domain Controllers: '{
DRDC1.some-company.com }'
VERBOSE: [18:07:38.327 GMT] Test-OutlookConnectivity : Runspace context: Executing user:
some-company.com/Users/Administrator, Executing user organization: , Current organization: , RBAC-enabled: Enabled.
VERBOSE: [18:07:38.327 GMT] Test-OutlookConnectivity : Beginning processing &
VERBOSE: [18:07:38.327 GMT] Test-OutlookConnectivity : Instantiating handler with index 0 for cmdlet extension agent
"Admin Audit Log Agent".
VERBOSE: [18:07:38.327 GMT] Test-OutlookConnectivity : Current ScopeSet is: { Recipient Read Scope: {{, }}, Recipient
Write Scopes: {{, }}, Configuration Read Scope: {{, }}, Configuration Write Scope(s): {{, }, }, Exclusive Recipient
Scope(s): {}, Exclusive Configuration Scope(s): {} }
VERBOSE: [18:07:38.374 GMT] Test-OutlookConnectivity : Resolved server.  Server Name = 'EX02', Server FQDN=
'ex02.some-company.com'
VERBOSE: Target Mailbox = 'ktest'
VERBOSE: [18:07:38.374 GMT] Test-OutlookConnectivity : Resolved current organization: .
VERBOSE: [18:07:38.390 GMT] Test-OutlookConnectivity : Mailbox = 'ktest', Owner = '/o=Some Company/ou=First
Administrative Group/cn=Recipients/cn=ktest'
VERBOSE: [18:07:38.390 GMT] Test-OutlookConnectivity : SMTP address for Autodiscover request = 'ktest@some-company.com'
VERBOSE: [18:07:38.421 GMT] Test-OutlookConnectivity : When contacting
https://ex02.some-company.com/Autodiscover/Autodiscover.xml received the error The underlying connection was closed: An
unexpected error occurred on a send.
VERBOSE: [18:07:38.421 GMT] Test-OutlookConnectivity : When contacting
https://ex02.some-company.com/Autodiscover/Autodiscover.xml received the error Unable to read data from the transport
connection: An existing connection was forcibly closed by the remote host.
VERBOSE: [18:07:38.421 GMT] Test-OutlookConnectivity : When contacting
https://ex02.some-company.com/Autodiscover/Autodiscover.xml received the error An existing connection was forcibly
closed by the remote host
VERBOSE: [18:07:38.421 GMT] Test-OutlookConnectivity : <?xml version="1.0"?>
<Autodiscover xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xsi:nil="true" xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006" />

ClientAccessServer   ServiceEndpoint                               Scenario                            Result  Latency
                                                                                                                  (MS)
------------------   ---------------                               --------                            ------  -------
ex02.some-company.com                                               Autodiscover: Web service request.  Failure   -1.00
VERBOSE: [18:07:38.421 GMT] Test-OutlookConnectivity : Admin Audit Log: Entered Handler:OnComplete.
The cmdlet fails to find all the server information through pinging service providers or other topology discovery insid
e the domain. The cmdlet cannot continue. TopologyDiscoverMode = 'UseAutodiscover, UseAddressbook'.
    + CategoryInfo          : OperationStopped: (Microsoft.Excha...onnectivityTask:TestOutlookConnectivityTask) [Test-
   OutlookConnectivity], TopologyDiscoverException
    + FullyQualifiedErrorId : 228BA80D,Microsoft.Exchange.Monitoring.TestOutlookConnectivityTask

VERBOSE: [18:07:38.437 GMT] Test-OutlookConnectivity : Ending processing &
0
Comment
Question by:FundFire
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
12 Comments
 
LVL 13

Expert Comment

by:5g6tdcv4
ID: 36589128
try rebuilding virtual directories, then re-run connectivity test


Remove-AutodiscoverVirtualDirectory -Identity servername\autodiscover
Remove-WebServicesVirtualDirectory -Identity servername\EWS

New-WebServicesVirtualDirectory -WebSiteName "Default Web Site" -ExternalUrl "https://www.yourdomainname.com/webservices.aspx"
New-AutodiscoverVirtualDirectory -WebSite

You can also do it through the exchange management console
0
 

Author Comment

by:FundFire
ID: 36589385
I did that few times without any success.  By the way I do not know this make a difference or not.  our ssl is a wild card and – not self signed.
0
 

Author Comment

by:FundFire
ID: 36589391
By that I mean I test fails after I removed the Autodiscover virtual directory.
0
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

 
LVL 13

Expert Comment

by:5g6tdcv4
ID: 36589473
if you assign all services to the default exchange cert that was created when you installed exchange does it work?
0
 

Author Comment

by:FundFire
ID: 36589483
How do I do that?  Can you provide instructions?

Thanks
0
 
LVL 13

Expert Comment

by:5g6tdcv4
ID: 36589507
open exchange management console select server config, then in the right hand pane you should see the certificates. look at the certs by issuer name, and select the one issued by your server, then just assign IIS services to that certificate.
did you install your wildcard using IIS?, as you need to use either EMC or EMS
0
 

Author Comment

by:FundFire
ID: 36589761
I have 3 exchange servers
One is Hub, Mailbox
two is Client Access
three Mailbox (for public folder)

Right now only IIS is assigned to the certificate on the second server.  should I assign IMPA, POP, SMTP, UM to it to all servers?  Is that what you are recommending.
0
 
LVL 13

Expert Comment

by:5g6tdcv4
ID: 36589813
First run test-outlookwebservices > res.txt and post file here
0
 

Author Comment

by:FundFire
ID: 36589848
0
 

Expert Comment

by:desiredforsome
ID: 36713675
did you add a dns record on your dns server try a SRV record

_autodiscovery _tcp 443 goes to your mail server.
0
 

Accepted Solution

by:
FundFire earned 0 total points
ID: 36716490
I called Microsoft.  There were two things that they did to solve this issue.  One is that the tech enabled   Anonymous Authenticatoin in EWS setting under IIS.  Also in Binding in IIS he removed Autodiscover entry, he said we do not need it.
0
 

Author Closing Comment

by:FundFire
ID: 36954288
Please see the ticket.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what you should include to make the best professional email signature for your organization.
This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
In this video we show how to create a Resource Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: Navigate to the Recipients >> Resources tab.: "Recipients" is our default selection …
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question