unable to send e-mail via SMTP

Here goes and sorry if this is long, this issue is driving me nuts.

We host an accounting package for 5 municipal offices. When users payout ot vendors they want to do it electronically and send an e-mail with payment notification. The users are accessing the system via RDP and to send the e-mails SMTP needs to be used. The software vendor calls a ini file with all the settings for a user and this includes the SMTP initialization. When the user performs  the A/P function it creates individual PDF's that are the Payment notitication and then using SMTP the server is supposed to send them, this where it breaks down, the PDF's get created but never sent.

The vendor and I have confirmed that SMTP is working as I can send e-mails via telnet to my hotmail account and to other accounts as well from the Terminal Server, but the pdfs are not going. This same system works fine outside of Terminal Server as Outlook and our exchange Server is used, btw we are using Exchange 2007. What can I do to check and see if the problem is the server? I would like to eliminate it so that I can go back to the software vendor adn ask them to fix their application.
Serge MartinIT TechnicianAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Serge MartinConnect With a Mentor IT TechnicianAuthor Commented:
The issue was with the vendor script to send e-mail from our server. They corrected the script added an additonal line in the SMTP and all works now
0
 
BCipolloneCommented:
If you have already verified that SMTP is working from the Terminal Server I would contact the tech support for that 3rd party product.
0
 
.Commented:
Do you have anti spam agents installed ? I would start by running get-agentlog to see if this is blocking these messages being sent.

http://technet.microsoft.com/en-us/library/aa996044(v=exchg.80).aspx
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
jojo_ORCommented:
Is the smtp server set up to relay to your exchange server?
0
 
Serge MartinIT TechnicianAuthor Commented:
The SMTP serve is set to relay to the exchange server.
0
 
Serge MartinIT TechnicianAuthor Commented:
no antispam agents are not blocking
0
 
jojo_ORCommented:
it'll be interesting to see if the A/P app can even send emails without attachments, or if you can manually send pdf attachments using the smtp serverwithout the A/P app.
0
 
.Commented:
Make sure your connector logging is set to verbose so you can see the SMTP transcript, get the same from the smart host. Everything is or can be logged.
0
 
Serge MartinIT TechnicianAuthor Commented:
it is set to verbose, looking at this right now.
0
 
Serge MartinIT TechnicianAuthor Commented:
Vendor of software supplied answer
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.