SAMBA installation failing with libraries dependencies

Hi Experts,

I am trying to install SAMBA of Redhat 5, it failling with libraies dependencies.

Below steps i carried out:
Installed : with nodeps.
1. rpm -ivh samba-common-3.0.9-1.3E.18.x86_64.rpm --nodeps
   rpm -ivh samba-client-3.0.9-1.3E.18.x86_64.rpm --nodeps
   rpm -ivh samba-3.0.9-1.3E.18.x86_64.rpm --nodeps

2. While starting smb:
/etc/init.d/smb start
Starting SMB services: smbd: error while loading shared libraries: libldap.so.2: cannot open shared object file: No such file or directory
                                                           [FAILED]
Starting NMB services: nmbd: error while loading shared libraries: libcom_err.so.3: cannot open shared object file: No such file or directory
                                                           [FAILED]
Gettting above error. I tried my best there is no luck..... Could any please help me ?

Thansk & Regards,

SK
MaddyUNIXAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Daniel McAllisterConnect With a Mentor President, IT4SOHO, LLCCommented:
OK, I'm going to start off my attempts to help in this situation by breaking 2 of my own cardinal rules:
 1) I'm going to ask "why are you doing it this way", and
 2) I'm going to ask "why are you using such old software"

So, Part 1 Why aren't you using yum? If the only reason is because you're not licensed to use RHN anymore, then you should switch to CentOS (same OS, only it's free -- and you get no support to go with your no-fee OS!).

To switch, you're really just changing YUM, not really any of your actual packages -- just follow the steps here: HERE

And then I jump to  Part 2: Why are you running such an OLD version of Samba? The current version of Samba is 3.6 (a VERY long way from 3.0.9!). Agreed that 3.6 is probably too bleeding edge for commercial use, but the 3.5 tree is quite mature and stable. RHEL & CentOS already have (as of version 5.5) a "samba3x" set of packages that implements version 3.5.4, or you can add the SerNet repositories and get 3.5.11 [new from August 2011!], or even 3.6

To load the SerNet Repo, do the following (as root):
cd /etc/yum.repos.d
wget http://ftp.sernet.de/pub/samba/3.5/rhel/5/sernet-samba.repo
[NOTE: You can also get samba 3.6 by changing the 3.5 above to 3.6 -- they do have it!]
yum install samba3
[NOTE: This WILL conflict with any existing samba packages, so you may need to remove them first!]

One last thing on Samba... as I mentioned above, the CentOS update repositories also have Samba 3.5 packages available -- to get them, do a yum install samba3x (you don't need the SerNet repos for Samba3x). Again, it'll conflict with existing samba* packages, so uninstall them first.

OK... so I'm done breaking my own rules here... back to actually answering the question asked: Namely, where do you get the support packages (like openldap) that samba needs to install?

Answer: use the site rpmfind.net can be used...

That's all for now folks... I hope this helps!


Dan
IT4SOHO

0
 
PapertripCommented:
Those missing libraries are in the openldap and libcom_err packages.  If you hadn't used --nodeps then it would not have let you install it, is there a specific reason you used --nodeps?

Is there a reason you aren't using yum for all this?  yum will take care of all the dependencies for you.
0
 
Gerwin Jansen, EE MVETopic Advisor Commented:
You could try adding the --aid flag when installing, to automatically solve dependencies. Remove the --nodeps as well. Like this:

rpm -ivh --aid samba-3.0.9-1.3E.18.x86_64.rpm
0
Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

 
MaddyUNIXAuthor Commented:
Hi Papertrip/gerwin,
@Papertrip : Yes when i try to install the SAMBA pakage its asked for below dependencies, to over come the issue i had ued --nodeps.

YUM: We are not connected to RHN, we using YUM repositery server (without connecting to RHN) belo i tryed.

# yum install 'samba*'
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
No package samba* available.
Nothing to do

@gerwin.
Now i eraised all SAMBA packages and tried.

# rpm -ivh --aid samba-3.0.9-1.3E.18.x86_64.rpm
warning: samba-3.0.9-1.3E.18.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 025e513b
error: Failed dependencies:
        libcom_err.so.3()(64bit) is needed by samba-3.0.9-1.3E.18.x86_64
        libcrypto.so.4()(64bit) is needed by samba-3.0.9-1.3E.18.x86_64
        liblber.so.2()(64bit) is needed by samba-3.0.9-1.3E.18.x86_64
        libldap.so.2()(64bit) is needed by samba-3.0.9-1.3E.18.x86_64
        libssl.so.4()(64bit) is needed by samba-3.0.9-1.3E.18.x86_64
        samba-common = 0:3.0.9 is needed by samba-3.0.9-1.3E.18.x86_64

COULD YOU PLESE HELP ME TO SORT OUT THIS ISSUE. HOW TO SORT...THANKS IN ADVANCE.

sk

0
 
PapertripCommented:
rpm --aid is deprecated in favor of yum.  Also --aid requires the dependency packages to be on the local system.
0
 
MaddyUNIXAuthor Commented:
IT ANY POSSIBLE WAT TO FIX THE ISSUE WITHOUT USING YUM, OR WHERE I CAN GET LIB RPM'S
0
 
PapertripCommented:
Wow.
0
 
Darr247Commented:
try
# yum install samba*

instead of 'samba*'

I'm pretty sure that message from yum is telling you it couldn't find a package named "samba*" (it searched for the literal samba* because you put the single quotes around it, instead of using the * as a wildcard, which it should do without single quotes).
0
 
MaddyUNIXAuthor Commented:
Hi Experts,

I am able to install samba on Linux box. However, i need to give anonymous access to Windows users, they connect from Windows 2003 server. How to allow the windows users to connect anonymous. And from windows server MSSQL database servers will put MSSQL backup file in LINUX SAMBA share. it possible to share like this? PLS help.

SK
0
 
MaddyUNIXAuthor Commented:
Hi Modus,

Yes, heavy thanks for Mr.it4soho was give though details explanation. However, I m not followed the post :-) for different reason. and i m solved configuration items too... thanks modus for you time.

have a nice day.

Thanks,
Sk.
0
 
MaddyUNIXAuthor Commented:
Hi Dan,

Thanks a ton for your solutions. Please keep rocking..


SK
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.