Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 481
  • Last Modified:

access windows shared files

hello there,
I have centos v6 installed and I would like to acess //Home-PC/Photos
from the centos laptop.. how can I do this?

this doesn't work.
-(09:09 43 PM)-(root@alpha)-(~) $ mount -t cifs //Home-PC/Photos -o username=vivek,password=myPassword /mnt/ntserver
mount error: could not resolve address for Home-PC: Name or service not known
0
XK8ER
Asked:
XK8ER
  • 2
  • 2
  • 2
  • +1
2 Solutions
 
Dave BaldwinFixer of ProblemsCommented:
Do you have SAMBA installed already?  It is normally used for Windows file sharing.
0
 
XK8ERAuthor Commented:
yes it is..

-(09:11 37 PM)-(root@alpha)-(~) $ rpm -qa samba-client
samba-client-3.5.4-68.el6_0.2.x86_64
-(09:19 25 PM)-(root@alpha)-(~) $
0
 
Dave BaldwinFixer of ProblemsCommented:
Click on "Request Attention" and get the Samba Server Software zone added to your question.  You're more likely to get an answer there.  It is late on Friday so responses may be slow.
0
Veeam Task Manager for Hyper-V

Task Manager for Hyper-V provides critical information that allows you to monitor Hyper-V performance by displaying real-time views of CPU and memory at the individual VM-level, so you can quickly identify which VMs are using host resources.

 
ind_selvaCommented:
step 1:

edit your linux pc hosts file add your windows system name and ip address

Home-PC      x.x.x.x (your windowspc ip)

save and restart the system then try to mount.
0
 
RoyCommented:
Try using the Domain directive as well, I have seen this command failing without Domain directives.

[root@monster r00t4ut]# mount.cifs "//HOME-PC/Photos$" /mnt/server -o username=vivek password=password dom=HOME-PC
0
 
XK8ERAuthor Commented:
r00t4u, this is what I get..

ount error: could not resolve address for
0
 
RoyCommented:
Looks like that your Linux box is not able to resolve the Windows Machine's Hostname. Can you try to ping your windows machine with the hostname. somthing like this:

ping HOME-PC

and you should get positive response if not then you should add the IP Address and the Hostname "HOME-PC" to your linux host file.

vi /etc/hosts

x.x.x.x      HOME-PC

No need to restart your system it should work,, again try to ping and this time you will get positive response then try your mount command.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now