Solved

NFS share/mount trouble on SuSE enterprise 10.

Posted on 2011-09-24
9
517 Views
Last Modified: 2013-12-02
I'm having trouble creating and mounting an nfs share.  Both servers are sles 10.

The nfs server is 10.25.50.163.  It has the client in the /etc/exports file.  The nfs client is 10.25.73.52.  The listing in the exports file is "/josh     110.25.73.52(ro)"

Attempted to manually configure and also configure in the yast2 utility.  yast2 shows that it has opened a port in the firewall on the nfs server.  The client has the firewall disabled.

When attempting to mount the nfs share from the client, the following two commands have been tried-

mount 10.25.73.52:/josh /taco
mount -t nfs 10.25.73.52:/josh /taco

It hangs.  It doesn't give an error.

Please help experts.  Thanks
0
Comment
Question by:drj003
  • 7
  • 2
9 Comments
 
LVL 2

Author Comment

by:drj003
ID: 36593226
EDIT: listing in the exports file is "/josh     10.25.73.52(ro)"

0
 
LVL 2

Author Comment

by:drj003
ID: 36593358
Here is the output of rpcinfo -p from the server

 # rpcinfo -p localhost
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100024    1   udp   1024  status
    100021    1   udp   1024  nlockmgr
    100021    3   udp   1024  nlockmgr
    100021    4   udp   1024  nlockmgr
    100024    1   tcp  21923  status
    100021    1   tcp  21923  nlockmgr
    100021    3   tcp  21923  nlockmgr
    100021    4   tcp  21923  nlockmgr
    100005    1   udp    767  mountd
    100005    1   tcp    768  mountd
    100005    2   udp    767  mountd
    100005    2   tcp    768  mountd
    100005    3   udp    767  mountd
    100005    3   tcp    768  mountd

Here is the output of rcpinfo -p on the server, but specifying the client-

# rpcinfo -p 10.25.73.52
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper


when trying the rpcinfo -p command on the client, it cannot contact portmapper on server-

 # rpcinfo -p 10.25.50.163
rpcinfo: can't contact portmapper: RPC: Remote system error - Connection timed out
 #

portmapper is running on the server.


0
 
LVL 2

Author Comment

by:drj003
ID: 36593383
woops.  There was an entry in the /etc/host.deny on the server that denied everything.  I will add an entry to the etc/host.allow   I thought I had checked that.
0
 
LVL 2

Author Comment

by:drj003
ID: 36593419
That didn't work.  I still need help please.
0
Do email signature updates give you a headache?

Constantly trying to correctly format email signatures? Spending all of your time at every user’s desk to make updates? Want high-quality HTML signatures on all devices, including on mobiles and Macs? Then, let Exclaimer solve all your email signature problems today!

 
LVL 2

Author Comment

by:drj003
ID: 36595333
Please let me know if you would like any additional information.
0
 
LVL 34

Expert Comment

by:Duncan Roe
ID: 36596294
Make sure all necessary daemons are running on the both systems. It can happen that if there are no nfs entries in /etc/fstab then they don't get started automatically.
On the client: /sbin/rpc.portmap
On the server: /sbin/rpc.portmap /usr/sbin/rpc.rquotad /usr/sbin/rpc.mountd
(directory names may vary)
0
 
LVL 2

Author Comment

by:drj003
ID: 36597161
Thanks for your reply Duncan.

rpc.rquotad is not running on either the client or server.  I cannot even find it to start it.  The other services are running.  

Could rpc.rquotad be called something else on SuSE10?  Can't find it anywhere.
0
 
LVL 34

Accepted Solution

by:
Duncan Roe earned 500 total points
ID: 36598078
You may not need it. I killed it on the server and could still mount files. But then, I don't have quotas enabled - do you?
Does either machine have a firewall? Be sure ports 2049 (nfsd) and 4045 (lockd) are open.
On the server, there need to be lockd and nfsd processes running. With a modern kernel, they will be called just that. With an older kernel, they will run as rpc.nfsd and rpc.lockd
0
 
LVL 2

Author Comment

by:drj003
ID: 36601055
I looked at yast on the server, it had an allow acception for nfs.  However, when I turned the firewall completely off, it worked.  Thanks Duncan!
0

Featured Post

Free camera licenses with purchase of My Cloud NAS

Milestone Arcus software is compatible with thousands of industry-leading cameras for added flexibility. Upon installation on your My Cloud NAS, you will receive two (2) camera licenses already enabled in the software. And for a limited time, get additional camera licenses FREE.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If, like me, you have a lot of Dell servers in the estate you manage this article should save you a little time. When attempting to login to iDrac on any server I would be presented with two errors. The first reads "Do you want to run this applicati…
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
Delivering innovative fully-managed cloud services for mission-critical applications requires expertise in multiple areas plus vision and commitment. Meet a few of the people behind the quality services of Concerto.

930 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now