NFS share/mount trouble on SuSE enterprise 10.

Posted on 2011-09-24
Last Modified: 2013-12-02
I'm having trouble creating and mounting an nfs share.  Both servers are sles 10.

The nfs server is  It has the client in the /etc/exports file.  The nfs client is  The listing in the exports file is "/josh"

Attempted to manually configure and also configure in the yast2 utility.  yast2 shows that it has opened a port in the firewall on the nfs server.  The client has the firewall disabled.

When attempting to mount the nfs share from the client, the following two commands have been tried-

mount /taco
mount -t nfs /taco

It hangs.  It doesn't give an error.

Please help experts.  Thanks
Question by:drj003
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 2

Author Comment

ID: 36593226
EDIT: listing in the exports file is "/josh"


Author Comment

ID: 36593358
Here is the output of rpcinfo -p from the server

 # rpcinfo -p localhost
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    4   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    100003    4   tcp   2049  nfs
    100024    1   udp   1024  status
    100021    1   udp   1024  nlockmgr
    100021    3   udp   1024  nlockmgr
    100021    4   udp   1024  nlockmgr
    100024    1   tcp  21923  status
    100021    1   tcp  21923  nlockmgr
    100021    3   tcp  21923  nlockmgr
    100021    4   tcp  21923  nlockmgr
    100005    1   udp    767  mountd
    100005    1   tcp    768  mountd
    100005    2   udp    767  mountd
    100005    2   tcp    768  mountd
    100005    3   udp    767  mountd
    100005    3   tcp    768  mountd

Here is the output of rcpinfo -p on the server, but specifying the client-

# rpcinfo -p
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper

when trying the rpcinfo -p command on the client, it cannot contact portmapper on server-

 # rpcinfo -p
rpcinfo: can't contact portmapper: RPC: Remote system error - Connection timed out

portmapper is running on the server.


Author Comment

ID: 36593383
woops.  There was an entry in the /etc/host.deny on the server that denied everything.  I will add an entry to the etc/host.allow   I thought I had checked that.
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.


Author Comment

ID: 36593419
That didn't work.  I still need help please.

Author Comment

ID: 36595333
Please let me know if you would like any additional information.
LVL 35

Expert Comment

by:Duncan Roe
ID: 36596294
Make sure all necessary daemons are running on the both systems. It can happen that if there are no nfs entries in /etc/fstab then they don't get started automatically.
On the client: /sbin/rpc.portmap
On the server: /sbin/rpc.portmap /usr/sbin/rpc.rquotad /usr/sbin/rpc.mountd
(directory names may vary)

Author Comment

ID: 36597161
Thanks for your reply Duncan.

rpc.rquotad is not running on either the client or server.  I cannot even find it to start it.  The other services are running.  

Could rpc.rquotad be called something else on SuSE10?  Can't find it anywhere.
LVL 35

Accepted Solution

Duncan Roe earned 500 total points
ID: 36598078
You may not need it. I killed it on the server and could still mount files. But then, I don't have quotas enabled - do you?
Does either machine have a firewall? Be sure ports 2049 (nfsd) and 4045 (lockd) are open.
On the server, there need to be lockd and nfsd processes running. With a modern kernel, they will be called just that. With an older kernel, they will run as rpc.nfsd and rpc.lockd

Author Comment

ID: 36601055
I looked at yast on the server, it had an allow acception for nfs.  However, when I turned the firewall completely off, it worked.  Thanks Duncan!

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
This article was originally published on Monitis Blog, you can check it here . Today it’s fairly well known that high-performing websites and applications bring in more visitors, higher SEO, and ultimately more sales. By the same token, downtime…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Suggested Courses

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question