Solved

Slow Internet Connection when Router Connected

Posted on 2011-09-24
13
341 Views
Last Modified: 2012-05-12
I've got a small network of 7 computers with the following components:

Cable Modem:  Motorola Surfboard SB4200 (less than 3 months old)
D-Link Router (w/ wireless activated): DIR655
Netgear Prosafe 24 Port 10/100 Smart Switch FS726T

When I connect any of the computers (all running XP or Windows 7) directly to the Cable Modem, I can get a 10mb connection.

When I connect the Cable Modem to the Router (internet port), and then connect the router to the switch, and the computers to the switch, the speed is cut to 2mb.

I'm using www.speedtest.net to test speed.

I've tried another switch which is known to be good and got the same problem.  I've tried restarting the router (but non resetting it because the settings are a little complicated).  I've also tried resetting the switch and restarting the modem.  I also know that we were getting 10mb connections on all comoputers with the exact same router and switch some time ago (probably 6 months ago).  I've also called the ISP but because the speed of the modem connected directly to any computer is good, they say the problem must be something other than their service (which seems logical).

Is the router the likely suspect?  Unfortunately, I don't have another router to test that.  Any suggestions would be greatly appreciated!

thanks,
darin
0
Comment
Question by:DarinOBrien
  • 4
  • 3
  • 3
  • +3
13 Comments
 
LVL 21

Expert Comment

by:Papertrip
ID: 36593861
Another test router sure would be nice ;)

It looks like the only thing you didn't try, or mention at least, is modem -> router -> computer.  
0
 
LVL 38

Expert Comment

by:Aaron Tomosky
ID: 36593864
2 mbit both ways or just upload? Is qos turned on?
0
 

Author Comment

by:DarinOBrien
ID: 36593920
Sorry, I forgot to say that I tried modem -> router -> computer and got same problem.  

2mb is download (upload is about .2mb).  Supposed to be 10mb download/1mb upload per ISP.  

thanks,
darin
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 38

Expert Comment

by:Aaron Tomosky
ID: 36593925
How are your ping times? Ping 8.8.8.8
0
 
LVL 21

Expert Comment

by:Papertrip
ID: 36593931
Sorry, I forgot to say that I tried modem -> router -> computer and got same problem.  
If you know that the other switch you tried is good, and taking into consideration all your other test results, then the problem appears to be the router.  Can you borrow a friends?  Go buy one to test with and return it if the problem still exists?  Good thing about that suggestion is you already have your new router if it does fix the problem ;)
0
 
LVL 10

Expert Comment

by:10023
ID: 36593937
I was waiting for an answer from papertrip ?...but I would check if the switch is running half duplex or full...which according to its documentation should be the default but only if it is talking to an adaptor that is set for auto negotiation...note the adapter setting in properties...
Another thought would be a flakey uplink cable between the switch and the router??


your documentation:
Auto Negotiation
The RJ-45 ports negotiate the correct duplex mode and speed if the device at the other end of the link supports auto negotiation. If the device does not support auto negotiation, the switch only determines the speed correctly and the duplex mode defaults to half-duplex.
The gigabit port on the Gigabit module negotiates speed, duplex mode, and flow control, provided that the attached device supports auto-negotiation.
0
 
LVL 21

Expert Comment

by:Papertrip
ID: 36593946
@10023 that is what I was thinking could be potential sources of the problem, but then Darin said the problem exists with modem+router+computer.
0
 
LVL 38

Expert Comment

by:Aaron Tomosky
ID: 36593950
What if you turn off wifi on the router? I've seen interference from other wireless networks on the same or close channels take out consumer routers
0
 
LVL 17

Accepted Solution

by:
rochey2009 earned 450 total points
ID: 36594063
Hi,

Try turning off the traffic shaper.
0
 
LVL 8

Expert Comment

by:inbox788
ID: 36595728
The router is basically defective. You could try to turn off firewall/SPI and see if that helps. You can also try updating the firmware. What version do you have? If you have a rev. A1 or B1, you might be able to contact D-link and get an A3 version, but the least painful solution is just to get another router.

http://www.dd-wrt.com/wiki/index.php/Known_incompatible_devices


http://www.dslreports.com/forum/r23157768-DIR-655-Rev-B-available-in-stores-yet-
0
 

Author Comment

by:DarinOBrien
ID: 36598948
Here's what I did:

1.  I  borrowed a router and had that DID solve the problem.  However, I wasn't convinced that the modem was defective so I plugged in the old one.
2.  Next I tested ping 8.8.8.8 and got 27ms...not sure what that told me :-)?
3.  Checked for firmware update in through the router interface.  It is currently 1.21 and when I checked for update, it said "this is the latest version".
4.  I also turned off wireless.  That did not solve the problem.
5.  I next turned off "enable traffic shaping".  THAT SOLVED THE PROBLEM.

HOWEVER, I can't find where to check the duplex mode so that's something I couldn't change/check.  Can someone tell me how to find that setting on this router?

Also, what is "traffic shaping" and do I care if it's enabled or not?  Assuming that turning off traffic shaper isn't a problem or an indication of some other problem with the router, I'll award points to rochey2009.

Thanks for the help!
darin



However, then I try to see if it was a  
0
 
LVL 38

Assisted Solution

by:Aaron Tomosky
Aaron Tomosky earned 50 total points
ID: 36599793
Traffic shaping, qos, bandwidth management, are all thing that can help you get more spee out of a connection if setup correctly. They are also the main culprit of slow connections when not setup correctly. In low end consumer wifi router gear, it's usually best to just leave it off.
0
 

Author Closing Comment

by:DarinOBrien
ID: 36709785
Thanks to everyone who contributed...much appreciated!
darin
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
In this article, I am going to show you how to simulate a multi-site Lab environment on a single Hyper-V host. I use this method successfully in my own lab to simulate three fully routed global AD Sites on a Windows 10 Hyper-V host.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

825 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question