Solved

Configuring Cisco 1841 router

Posted on 2011-09-25
17
770 Views
Last Modified: 2012-05-12
I need to configure my new cisco 1841 router to replace my existing Linksys router. need help on basic configuration.
my WAN IP : 41.xxx.xx.101/30
       Gateway: 41.xxx.xx.102
       DNS: 83.xx.x.249
my LAN IP: 172.xx.xx.1
      subnet: 255.255.255.0
Also need to configure DHCP on the router.
thanks
0
Comment
Question by:Adabara2009
  • 12
  • 3
  • 2
17 Comments
 
LVL 16

Expert Comment

by:memo_tnt
Comment Utility
Hi
please a copy of your current configuration..
0
 

Author Comment

by:Adabara2009
Comment Utility
interface FastEthernet0/0  
ip address 41.xxx.xx.101 255.255.255.0
 ip nat outside  
ip virtual-reassembly
 duplex auto
 speed auto
! interface FastEthernet0/1  
ip address 172.xx.xx.1 255.255.255.0  
ip nat inside  
ip virtual-reassembly  
duplex auto  
speed auto !
 ip route 0.0.0.0 0.0.0.0 41.xxx.xx.102
access-list 10 permit 172.xx.xx.0 0.0.0.255 !  
Router(config)#ip dhcp pool baze
Router(dhcp-config)#network 172.xx.xx.0 255.255.255.0
 Router(dhcp-config)#dns-server 83.43.x.249
Router(dhcp-config)#dns-server 83.143.x.249 83.143.x.220 193.238.xx.249
Router(dhcp-config)#default-router 41.xxx.xx.102

Router(config)#ip route 0.0.0.0 0.0.0.0 41.xxx.xx.102
Router(config)#do copy run start Destination filename [startup-config]?
Building configuration...
0
 
LVL 16

Assisted Solution

by:memo_tnt
memo_tnt earned 100 total points
Comment Utility
seems good,
but you need to add the following:

ip nat inside source list 10 interface fastethernet0/0 overload
0
 

Author Comment

by:Adabara2009
Comment Utility
it is there and yet not functioning. what next
0
 

Accepted Solution

by:
jon-t earned 200 total points
Comment Utility
Hi Adabara2009: Please provide a complete copy of your latest running-config with passwords blanked out.

In your DHCP pool of "baze" the default-router is incorrect. Change it to 172.xx.xx.1as your clients need default to point to the router's LAN interface not something out over the WAN. There's not much point censoring 172.16-32 addresses btw since they are private and not world routable :)

Also what pings or other troubleshooting have you done? Please provide this output too for us.
0
 

Author Comment

by:Adabara2009
Comment Utility
*Sep 28 14:19:01.671: %SYS-5-RESTART: System restarted -- Cisco IOS Software, 1841 Software (C1841-IPBASE-M), Version 15.0(1)M2, RELEASE S OFTWARE (fc2) Technical Support: http://www.cisco.com/techsupport Copyright (c) 1986-2010 by Cisco Systems, Inc. Compiled Wed 10-Mar-10 21:53 by prod_rel_team *Sep 28 14:19:01.679: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing  a cold start
Router>en
Router#config t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#ip add 41.206.xx.101 255.255.255.0
Router(config-if)#no shut Router(config-if)#int f0/1
Router(config-if)#ip add 172.20.16.1 255.255.255.0
Router(config-if)#no shutdown Router(config-if)#exit
Router(config)# *Sep 28 14:20:11.651: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state t o up *Sep 28 14:20:12.651: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern et0/1, changed state to up
Router(config)# *Sep 28 14:20:16.691: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern et0/1, changed state to down Router(config)#
Router(config)#$ baze 41.206.xx.101 41.206.xx.252 netmask 255.255.255.0
Router(config)# *Sep 28 14:21:25.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface NVI0, chan ged state to up
Router(config)#ip nat inside source list 30 pool baze overload
Router(config)#int f0/0
Router(config-if)#ip add 41.206.xx.101 255.255.255.0
Router(config-if)#ip nat outside
Router(config-if)#int f0/1
Router(config-if)#ip add 172.20.16.1 255.255.255.0
Router(config-if)#ip nat inside
Router(config-if)#exit
Router(config)#access-list 30 permit 172.20.16.0 0.0.0.255
Router(config)#ip dhcp pool baze
Router(dhcp-config)#network 172.20.16.0 255.255.255.0
Router(dhcp-config)#dns-server 193.238.28.249 193.238.28.246
Router(dhcp-config)#default-router 172.20.16.0
Router(dhcp-config)#no default-router 172.20.16.0
Router(dhcp-config)#default-router 172.20.16.1
Router(dhcp-config)#lease 1
Router(dhcp-config)#ip route 0.0.0.0 0.0.0.0 41.206.xx.101 %Invalid next hop address (it's this router) Router(config)#ip route 0.0.0.0 0.0.0.0 41.206.xx.102 Router(config)#do copy run start Destination filename [startup-config]?
Building configuration... [OK]  
0
 

Author Comment

by:Adabara2009
Comment Utility
I have posted my latest configuration. yet it is not working.
We could ping any of the IP address, both WAN and LAN .
Waiting for response.
0
 

Expert Comment

by:jon-t
Comment Utility
Hello Adabara2009, it is a bit difficult for us to keep track of a list of commands with all your changes there. It would make it much easier if you just paste the latest output from "show running-configuration". With this we'll have something reliable to work from.
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:Adabara2009
Comment Utility
thanks all, below is as requested

 i p   d h c p   p o o l   k s l        
n e t w o r k   1 7 2 . 20 . 16 . 0   2 5 5 . 2 5 5 . 2 5 5 . 0      
 d e f a u l t - r o u t e r   1 7 2 . 20 . 16 . 1        
d n s - s e r v e r   192 .238.xx.249  193.238.xx.246  
i n t e r f a c e   F a s t E t h e r n e t 0 / 0  
i p   a d d r e s s   41.206.xx.101   2 5 5 . 2 5 5 . 2 5 5 . 0    
i p   n a t   outside    
 i p   v i r t u a l - r e a s s e m b l y    
d u p l e x   a u t o    
s p e e d   a u t o  
i n t e r f a c e   F a s t E t h e r n e t 0 / 1  
 i p   a d d r e s s   172 .  20.16 . 1    2 5 5 . 2 5 5 . 2 5 5 . 0    
 i p   n a t   inside    
i p   v i r t u a l - r e a s s e m b l y    
 d u p l e x   a u t o    
s p e e d   a u t o  
 i p   f o r w a r d - p r o t o c o l   n d  
 n o   i p   h t t p   s e r v e r  
 i p   n a t   p o o l   baze 41.206.xx.101   41.206 .xx.121  n e t m a s k   2 5 5 . 2 5 5 . 2 5 5 . 0  
 i p   n a t   i n s i d e   s o u r c e   l i s t   3 0   p o o l   baze   o v e r l o a d  
 i p   r o u t e   0 . 0 . 0 . 0   0 . 0 . 0 . 0   41.206.xx.102  
 a c c e s s - l i s t   3 0   p e r m i t   1 7 2 . 20 . 16 . 0    0 . 0 . 0 . 2 5 5  
0
 

Author Comment

by:Adabara2009
Comment Utility
Hi, sage,
Any further reason why I could not brows on the LAN?
Waiting for response.
0
 

Author Comment

by:Adabara2009
Comment Utility
It is like no one has suggestion to my challenges. May be Cisco product not supported in EE?
0
 

Expert Comment

by:jon-t
Comment Utility
For one thing, we're not paid to provide support advice here. We do it voluntarily in the hope we may be able to help others out who are having trouble.

Secondly, you're not providing the information people are asking for, which makes it difficult to help you without remote access and a good understanding of your environment.

Help us help you, and have some patience and I'm sure your query will be resolved.
0
 

Assisted Solution

by:Adabara2009
Adabara2009 earned 0 total points
Comment Utility
thanks very much jon-t. After loosing hope in get help from the Audience, I went back and reviewed the entire setup overnight, and found the problem. I have sorted out my problem. will make the working setup available later for others.
thanks
0
 

Assisted Solution

by:Adabara2009
Adabara2009 earned 0 total points
Comment Utility
Below is final configuration that works.
Thanks to all of you.

Router#sh run Building configuration...
 Current configuration : 1171 bytes ! !
Last configuration change at 11:00:47 UTC Sun Oct 2 2011

ip dhcp pool baze    network 172.20.16.0 255.255.255.0    
dns-server 193.238.xx.249 193.238.xx.246    
default-router 172.20.16.1

ip cef multilink bundle-name authenticated

interface FastEthernet0/0
ip address 41.xxx.xx.101 255.255.255.0
ip nat outside  
ip virtual-reassembly
duplex auto  speed auto !

interface FastEthernet0/1  
ip address 172.20.16.1 255.255.255.0  
ip nat inside  
ip virtual-reassembly  
duplex auto  speed auto  
ip forward-protocol nd

no ip http server

ip nat pool baze 41.xxx.xx.101 41.xxx.xx.131 netmask 255.255.255.0
ip nat inside source list 90 pool baze overload
ip route 0.0.0.0 0.0.0.0 41.xxx.xx.102
ip route 172.20.16.0 255.255.255.0 41.xxx.xx.102
access-list 90 permit 172.20.16.0 0.0.0.255  
 
0
 

Author Comment

by:Adabara2009
Comment Utility
I've requested that this question be closed as follows:

Accepted answer: 0 points for Adabara2009's comment http:/Q_27326513.html#36908735

for the following reason:

Thanks to all. We simply need patience and meticulous review of our configuration to solve most of our challenges.
0
 

Author Comment

by:Adabara2009
Comment Utility
Need to award points to contributors
0
 

Author Closing Comment

by:Adabara2009
Comment Utility
Thanks to all. We simply need patience and meticulous review of our configuration to solve most of our challenges.
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
CISCO ASA 5500 DDNS 4 54
Can't access Internet behind Cisco Router 14 38
EIGRP Summary 2 31
iPad Won't Connect 16 30
Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
Problem Description:   Couple of months ago we upgraded the ADSL line at our branch office from Home to Business line. The purpose of transforming the service to have static public IP’s. We were in need for public IP’s to publish our web resour…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now