?
Solved

Can you stop desktop icons form appearing using Unattend.xml answer file

Posted on 2011-09-25
4
Medium Priority
?
1,122 Views
Last Modified: 2012-05-12
We have created an unattend.xml file for Windows 7 32 bit.  Everything works fine, but I have one issue that just irritates me.  The answer file joins the computer to the domain and when the computer reboots it comes to the login screen for the domain.  When you login you get all the settings from the default profile and you get a bunch of icons on the desktop that weren't part of the Default Profile.  I get Network, Control Panel, LIbraries and My Documents.  It aggrivates me.  Is there a way to stop this behavior in the unattend.xml file or some other way?  I don't want to do it with a GPO because I want people to be able to add them if they like.  I just don't want them populated from the start.
0
Comment
Question by:TPBPIT
  • 2
  • 2
4 Comments
 
LVL 41

Expert Comment

by:footech
ID: 36596521
Sorry to question this right off, but are you SURE they're not part of the default profile?

Are you using local profiles or roaming profiles?
0
 

Author Comment

by:TPBPIT
ID: 36596789
We're using local profiles at this point.  And I'm pretty sure.  While building the image in Audit Mode I checked to make sure they were not turn on in the Desktop Icons settings.  I used an unattend.xml file and it copies the local admin profile to the default.  Yet, when the machine gets on the domain and a user logs in, the icons are there.  Also, there is no GPO causing this behavior.
0
 
LVL 41

Accepted Solution

by:
footech earned 2000 total points
ID: 36913295
Wish I had a better suggetion for you, but that way I would approach it is to make some other change to the admin profile (like adding some other shortcut) to make sure that the profile is being properly copied over to the default.

If you're sure that this is working properly, then I'm afraid I don't have any other suggestions for you.  Good luck.
0
 

Author Closing Comment

by:TPBPIT
ID: 36913418
I'm going to give you the points for even responding.  We actually found the solution.  We found all the registry values and created a reg key for it.  In the HKCU\software\microsoft\windows\currentcontrolset\runonce we put an entry that points at a batch file on out network.  The batch file imports that reg key and turns off the icons.  As that key is part of the default profile, any new user will get it.  While I don't like audit mode, it does help to make the default profile do what you want it to.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Assume you have an outside contractor who comes in seasonally or once a week to do some work in your office, but you only want to give him access to the programs and files he needs and keep all other documents and programs private. Can you do this o…
By default the complete memory dump option is disabled in windows . If we want to enable the complete memory dump for a diagnostic purpose, we have a solution for it. here we are using the registry method to enable this.
This Micro Tutorial will teach you how to change your appearance and customize your Windows 7 interface to your unique preference. This will be demonstrated using Windows 7 operating system.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.
Suggested Courses

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question