Solved

Moving an Operating System from a SATA drive to a SAS drive part way through migration

Posted on 2011-09-25
16
415 Views
Last Modified: 2012-05-12
I have un-intentionally installed SBS 2011 Standard in migration mode to the point of DCPROMO on a SATA drive (on IBM X3400M3).
The OS should have ended up on a SAS drive.
Is it best to complete the whole migration first then move the OS to the SAS drive or should I move the OS before doing anything else?
Note: This is a live network with SBS2003 and SBS2011 and I need to make sure I avoid disrupting workflow and avoid complicating the migration process.
I have a Storage Craft backup of the server just after the DCPROMO.
Can I use this to do the move?
I am not sure what are the do's and don’ts at this point. I.e. what would happen if I re-installed SBS 2-11 from scratch on to the correct drive?
0
Comment
Question by:stevenvel
  • 10
  • 5
16 Comments
 
LVL 18

Accepted Solution

by:
Netflo earned 200 total points
ID: 36596592
Hi,

I would focus on completing your migration first, if you attempted to format and start again, you would need to run the SBS migration tool again and it could just end up being a little messy. If anything you'll get a slight performance hit but nothing to worry about at this stage.

Assuming your SAS partition is sitting there empty and both sets of drives are on the same RAID array, I would suggest using an Acronis trial to 'pick up your OS' and move it to the SAS partition. Acronis will also give you the ability to make the new partition as 'Active' so that it boots off it too.

I'm not sure whether Storage Craft can move images, resize images and mark them as Active. Therefore I would recommend downloading and installing Acronis on your server and create the bootable CD, which you will use to perform the backup to USB/NAS and then restore from too. I've used this method numerous times before and works a charm too. Plan for a weekend when you can have some downtime as this process will take some time and patience too.

Remove the SATA drives from the server and confirm the changes on your RAID card. Restore the backup image onto your SAS drives, you're using the Universal Restore feature as its going back onto the same RAID array. Your partitions wills be resized according to how they were set out to fix on the SAS array. On the final step of the restore, ensure you SELECT 'generate new NT signature' and do NOT select 'generate new SIDs'.

Once the OS has restored successfully, power down and insert the SATA drives, create a new SATA array and proceed to boot back into your OS. The new uninitialised array will be ready for you to configure how you please.

Hope that helps.

Acronis Trial: http://www.acronis.co.uk/enterprise/download/
0
 

Author Comment

by:stevenvel
ID: 36596800
Thank you.

Out of interest, have you attempted format and fresh install?

I have 2x 300 SAS in RAID 1 and 2x 500 SAS in RAID 1 (off IBM Server RAID M5015) plus 1x SATA 2GB off motherboard.

What I tried to do after realizing install on the wrong drive:

I created a 100GB partition on the 300GB drive, shutdown the server, disconncted the  SATA drive (single drive off motherboard sata port), restored  a backup copy of OS on to the 100GB partition, rebooted server but boot failed.
I then connected SATA drive again. After some issues booting even off the original SATA I manged to get back to a working OS.
Maybe I overlooked activating the 100GB partition.
0
 
LVL 22

Expert Comment

by:chakko
ID: 36597096
If you have Server Imaging type of software available or if you can Open Windows Backup then you should be OK.

I would stop where you are at and backup the system (image type backup) and restore to the correct drive.  I would personally just try the Windows backup at this early point (no 3rd party software intalled, right?), and do the Bare Metal restore to the SAS drive.  Boot the system (disconnected from the MAIN LAN) and see if any errors pop-up.  If it looks good then connect to the LAN and continue.

Keep the SATA disk safe and seperate so that you can plug it back in and 'roll back' if you need to.

0
 

Author Comment

by:stevenvel
ID: 36597152
chakko,

I have Storage Craft IT Edition - I can run backup without installing anything - just off USB.
Just checked windows backup and it looks like I can run this - setup wizard pops up.
The destination server has been running for most part of the day.

I havn't used/tried windows back on a 2011 server.
Do I leave LAN cable connected while I backup/restore?
0
 
LVL 22

Assisted Solution

by:chakko
chakko earned 300 total points
ID: 36597185
You can backup to a local disk (USB is easy) or you should also be able to backup over the LAN.

I would connect a USB disk to keep it simple.

I would have a current storage craft backup too.  I haven't used that product so can't comment.  I have restored a system with Windows backup and it is super simple for a base install like you have (not a lot of other things installed).  If you have a USB disk I would choose that as the backup/restore lcoation.
For the Bare Metal restore you boot from your 2011 DVD and do a system repair.  it will find the backup stored on the USB disk and will restore an 'image' of the system.

If you have restored systems with StorageCraft and are confident with that then use it.  

I would disconnect the LAN cable during the bootup of the Restored system.  I would do this to just limit any communication to any other machines.  After I check event logs and general status of the server I would reconnect to the LAN if it all seems good.
0
 

Author Comment

by:stevenvel
ID: 36597277
OK I will try this after hours and see how I go.
Do I have to make any changes to the server UEFI (BIOS) after physically disconnecting the SATA drive so the RAID disk is detected as the boot device?
I think this is where things went wrong for me:
Originally I only had SAS drives on the controller and disk management was simple.
Then I decided to install a SATA drive for local backups.
When I connected the SATA drive directly to motherboard this changed the drive letters in disk management and I ended up with OS on the SATA drive.
I may need to do a crash course on UEFI I find it a bit confusing
0
 
LVL 22

Expert Comment

by:chakko
ID: 36597574
Depends on what it is you will do, but if you do a cloning type of operating then drivers could be an issue.
So you will change to a SAS / RAID (hardware RAID) setup now?  You should install the related drivers for the RAID system before you backup/clone the system.  This way the system will have the drivers 'pre-loaded' and can detect the hardware properly when you boot the system to the SAS disk.

0
 

Author Comment

by:stevenvel
ID: 36597605
Yes I will change to SAS / RAID.
Original install was carried out using IBM Server Guide CD which has the drivers.
I just checked device manager and it displays two entries for IBM ServeRAID M5015 Disk Device and one for ATA device.
I assume it is good to go?
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 22

Expert Comment

by:chakko
ID: 36597626
Seems like it should be fine on the driver side.

Always have a current full backup.  For this I would have 2 backups to be extra safe.  I would make 1 StorageCraft and 1 with Windows (choose everything including the Bare Metal Restore).
0
 

Author Comment

by:stevenvel
ID: 36597642
OK thanks again I will let you know results.
0
 

Author Comment

by:stevenvel
ID: 36720553
Using the windows backup/2011DVD/system repair option failed.
I received error:

The system image restore failed.

Windows cannot restore a system image to a computer that has different firmware.The system image was on a computer that has different firmware. The system image was created on a computer using EFI and this computer is using BIOS.
0
 

Author Comment

by:stevenvel
ID: 36720630
Using Storage Craft Shadow Protect I had greater success but I am not in the clear yet.
After overcoming complicated Sorage Craft licensing requirements (even though I have a license), I attempted restore.
On first attempt, using a feature to automaticaly create a partition of the same size as original on the destination/SAS drive, the process crashed!
I tried again and noticed the partition (System EFI) was created just before the crash.
I proceeded to format this partition and restore the 200MB EFI partition.
I then manually created the boot (C:) partition using the disk map tool in shadow protect and then restored.

After restore I shutdown, disconnected SATA drive, disconnected LAN cable and booted off drive 0 (SAS).
On initial boot I was given option to start in safe mode or normal, I selected normal.
When the server came up I saw the typical screen as when previous shutdown wasn’t planned or successful and you have to enter a comment.
I let the server finish booting and then I tried to check disk management and event viewer, both were freezing.
I think I stopped these two processes and then connected LAN cable.
Eventually I was able to run disk management and checked partition table.
Then I thought I better reboot and make sure the server starts as normal.
On this second restart the server was sitting on setting applying  computer settings for about an hour or more and eventually displayed applying user settings.
At around this stage, I tried pinging destination server and got replies – rdp and web access failed.
It stayed on applying user settings settings forever, at one point I decided to walk away – hoping it would finish and sort itself out.
Before leaving, on the source server, I tried to do a windows backup but this failed with error relating to VSS.

This morning I checked to see if I could rdp in to destination server but no go – ping responses but that’s it.

I have a feeling that I am missing some critical aspect relating to IBM EFI in the restore process?

Not sure what to do now?

Do I reconnect the SATA drive?
Will the two servers talk to each other again after all this or was the source server affected by me connecting the destination server with a new boot system with potential issues?
0
 
LVL 22

Assisted Solution

by:chakko
chakko earned 300 total points
ID: 36813009
I think you are right about the EFI.  I don't use StorageCraft so I can't comment about that restore.

Have you checked the event logs for errors?  is there a lot of them?

Is the server any better after a reboot (RDP is working?)

I would disconnect from the LAN.  I would connect to a standalone switch so that the network card has a Link.

If you 'rollback' and reinstall the SATA drive then you may have some AD issues related to replication (my guess).  The AD replication sequence numbers will be out of sync and maybe some type of Replication fixing may be required.  

Another expert may be able to tell you what will happen with the AD. Such as it will replicate OK, or you will need to fix it.  I have fixed AD problems before, but I don't know it well enough to really predict how it will react in your situation.

0
 

Author Comment

by:stevenvel
ID: 36899158
chakko,
I was forced to do a cold boot on the destination server.
Restarted in safe mode ok.
Restarted in normal mode but same problem - sitting on applying settings for a long time.
I decided to restart the source server and I noticed as soon as source server started shutdown, the destination server finished loading.
I checked disk management and noticed I had a drive letter on the system EFI partition - I removed this.
Restarted destination server again.
This time applying settings took about 20min but server loaded normal.
Restarted destination server again, this time it loaded nice and quick.
I think I am back on track to continue with migration wizard!
I take your point about connecting server LAN cable to a standalone switch - I wasn't supposed to disconnect LAN cable altogether.
0
 

Author Comment

by:stevenvel
ID: 36899175
Just summarizing:

Netflo helped me see that its best to continue with migration and not attempt re-install of OS on correct drive because this could get messy.
I felt more comfortable getting the OS on the right drive before proceeding with migration.
Chakko assisted me with moving the OS to the correct drive.
Shadow protect was the product which made this possible.
Thank you both for your comments.
0
 

Author Closing Comment

by:stevenvel
ID: 36899183
Clarifying the need to connect server LAN cable to a standalone switch earlier on in the post would have helped a lot and possibly saved me a lot of time.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

I've often see, or have been asked, the question about the difference between the Exchange 2010 SP1 version, available as part of Small Business Server (SBS) 2011, and the “normal” Exchange 2010 SP1 Standard. The answer to the question is relativ…
If you are a user of the discontinued Microsoft Office Accounting 2008 (MSOA) and have to move to a new computer running Windows 8, you will be unhappy to discover that it won't install.  In particular, Microsoft SQL Server 2005 Express Edition (SSE…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now