Solved

Remote Desktop Problem

Posted on 2011-09-26
18
2,108 Views
Last Modified: 2013-11-21
I am trying to connect to a remote server through the web browser.
The site qbi.reckononline.com.au/RDWeb uses the remote desktop protocol to connect
to the server.

I am running windows xp 32-bit service pack 3
with remote desktop shell and control version 6.1.76 and Remote desktop protocol 7

Upon trying to connect to the server, I receive the error message

"You have specified to use a gateway server, however this feature is not supported by your system configuration"

Relating to the problem, in the remote desktop connection app in the advanced tab, under Connect from anywhere it says

"connections using a gateway server are not supported by your system configuration"
and the settings button underneath is disabled

I have attached a screenshot of the error message and the remote desktop connection options.
Any help would be greatly appreciated as this problem has me completely stumped.

Thanks,
Mat.
QBProblem.PNG
0
Comment
Question by:matyoung89
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
  • 2
  • +3
18 Comments
 
LVL 3

Expert Comment

by:anjos
ID: 36597613
The issue is with Remote Desktop Connection 6.1. Unfortunately I'm not sure you can uninstall it but using RDC 6.0 instead of 6.1 would get rid of the gateway button being greyed out. Which in other words means not installing SP3. But that of course means you cannot use the web access control.
0
 
LVL 2

Expert Comment

by:BigMark
ID: 36597617
G'day Mat

You shouldn't need a Gateway Server to RDP to another machine - if your TCP/IP configuration is set up right and your router(s) are set to port forward TCP port 3389 all should be well.

I'd leave the "RD Gateway Server Settings" option at Automatically detect RD Gateway Server Settings.
0
 

Author Comment

by:matyoung89
ID: 36597886
I tried port forwarding or port "triggering", which is what my router offers but this did not help.
The same thing happens. Thanks for trying though BigMark.

I have google searched the hell out of this problem, with absolutely no luck. I'm curious as to how you know it's a problem with RDC 6.1 anjos. If you could point me in the direction of any information relating to that it may help me out.

Thanks,
Mat.
0
MIM Survival Guide for Service Desk Managers

Major incidents can send mastered service desk processes into disorder. Systems and tools produce the data needed to resolve these incidents, but your challenge is getting that information to the right people fast. Check out the Survival Guide and begin bringing order to chaos.

 
LVL 2

Expert Comment

by:BigMark
ID: 36597894
Hey Mat - did you set the gateway setting back to automatic??

mark
0
 

Author Comment

by:matyoung89
ID: 36597935
I can't seem to find that setting, where exactly should i be looking?

Mat.
0
 
LVL 2

Expert Comment

by:BigMark
ID: 36597948
Hi Mat

Edit the RDP connection - then choose the "Advanced" tab.  You're then looking for the Settings button in the "Connect from anywhere" section.

P.S.  I'm using v6.1 without any problems...... : )

BigMark
0
 

Author Comment

by:matyoung89
ID: 36597976
That's the main problem, the settings button is greyed out. I don't have access to any gateway settings.
Thanks for.trying anyway
0
 
LVL 2

Expert Comment

by:BigMark
ID: 36597983
Now the plot thickens!!!!

Are you an administrator of the PC you're using??  If not is this setting managed by Group Policy (or something similar)?

If you ARE an admin of the PC try creating a new profile - there may be something strange going on with your existing one.
0
 

Author Comment

by:matyoung89
ID: 36597987
Yeah I do have admin privileges and I have tried creating a new account, admin as well, but I get the same problem.

Mat.
0
 
LVL 16

Expert Comment

by:Shaik M. Sajid
ID: 36598456
see the following link


http://technet.microsoft.com/en-us/library/cc756826(WS.10).aspx#BKMK_8

try this

The remote computer disconnected the session because of an error in the licensing protocol. Please try connecting to the remote computer again or contact your server administrator.
Cause:  The terminal server might not be able to locate the license server.

Solution:  Perform the following steps:

Verify that the license server is correctly installed.


Verify that the Terminal Server Licensing service is running on the license server.


Verify that the client, the terminal server, and the license server can communicate by ensuring that Domain Name System (DNS) is configured correctly on each computer. To do this, run the ping command from each computer to each computer using the IP address, FQDN, and the NetBIOS name. If any of the ping commands fail, verify the DNS configuration on the network.


On the terminal server, set a preferred licensing server to connect to. You can do this by using the registry, a Windows Management Instrumentation (WMI) script, or, in Windows Server 2003 with Service Pack 1, you can use Group Policy settings or Terminal Server Configuration.


See also:   Install Terminal Server Licensing; Set preferred Terminal Server license servers; Terminal Server license server roles

Solution:  If the previous solution does not resolve this problem, create a backup of the MSLicensing registry key and its subkeys on the client, and then remove the original key and subkeys by doing the following:

On the client, navigate to the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSLicensing.


Click MSLicensing.


On the Registry menu, click Export Registry File.


In the File name box, type mslicensingbackup, and then click Save.


If you need to restore this registry key in the future, double-click mslicensingbackup.reg.


On the Edit menu, click Delete, and then click Yes to confirm the deletion of the MSLicensing registry subkey.


Close Registry Editor, and then restart the computer.


When the client is restarted, the missing registry key is rebuilt.

To resolve this problem automatically, click the Fix this problem link. Then, click Run in the File Download dialog box.

all the best
0
 
LVL 7

Expert Comment

by:JohnThePro
ID: 36599920
Does this forum post seem at all familiar to you? Is it possible you might have installed the package this fellow did?

http://social.technet.microsoft.com/Forums/en-US/winserverTS/thread/0b25bca6-3630-4a1c-8ff1-dc76b110941c/

In short, it eludes to a pre-release 6.1 client that was installed which wasn't quite fully featured. There's really no reason why, at SP3, with RDP7 client installed, that you shouldn't be able to perform this action.
0
 

Author Comment

by:matyoung89
ID: 36634578
I tried the ms licensing thing but that did not work. And yeah I've seen that technet post many times. I have never been to the site listed but I assume somewhere along the line I must have got the bad version of 6.1 however I can't find any solutions I've uninstalled and reinstall the RDP 7 update many times but that doesn't help.
I guess I'll just end up upgrading if no one knows how to fix it.
Thanks,
Mat.
0
 
LVL 7

Expert Comment

by:JohnThePro
ID: 36892623
Since you started with SP3, you can manually downgrade the RDP client.

Check out this link, and give it a shot. Afterwards, you can try installing the RDP updates again.

http://freecomputerconsultant.com/blog/downgrade-remote-desktop/
0
 

Author Comment

by:matyoung89
ID: 36901765
Thanks I'll give that a shot when I get time, I'm really busy right now, and let u know how it turns out.
Mat.
0
 

Accepted Solution

by:
matyoung89 earned 0 total points
ID: 37055251
Hi sorry for leaving the question unchecked, I have been very busy lately.
As for the problem, I ended up rolling over to windows 7 on the computer in question, which as expected resolved the issue. Because I did not have time to try JohnThePro's suggestion I am going to have this problem closed but not deleted in case it helps someone else (however unlikely).

Thank you everyone for your help.
Mat
0
 
LVL 59

Expert Comment

by:LeeTutor
ID: 37089725
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Step by step guide to Clean and Sort your windows registry! Introduction: Always remember: A Clean registry = Better performance = Save your invaluable time In this article we're going to clear our registry manually! Yes, manually! The e…
Issue: One Windows 2008 R2 64bit server on the network unable to connect to a buffalo Device (Linkstation) with firmware version 1.56. There are a total of four servers on the network this being one of them. Troubleshooting Steps: Connect via h…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question