• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 432
  • Last Modified:

cannot disable power management for network card in windows 7

When I try to disable the option "Allow the computer to turn off this device to save power" for my wired network card in the Power Management tab, it always comes back to enabled by itself if I go back to verify its settings.

Any idea what could be setting it back on automatically, or how to manually force it to off ? I tested the same thing on other pc's and the setting stays disabled, like it should.

Environment: Windows 7 Pro 64 bits, all updates installed, Dell Vostro 430 Desktop.

Thanks.
0
ndidomenico
Asked:
ndidomenico
  • 7
  • 4
  • 3
  • +1
2 Solutions
 
bright12Commented:
Do yo have administrator rights on the PC? If not, you can't disable the option.
0
 
tmwsiyCommented:
Usually stuff like this I have found is a result of the AHCI not being enabled in the BIOS.

You *MIGHT* be able to switch the setting and do a repair from the install disk to fix.

I usually just switch it and re-do the deployment.
0
 
ndidomenicoAuthor Commented:
Yes, I have admin rights. UAC is set to default level. And the option is not greyed out: I am able to remove the tick, but just won't stay that way. Do I have to do some sort of "Run ad administrator" action before going into Device Manager
0
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
ndidomenicoAuthor Commented:
AHCI ?? this should relate only to the SATA controller or disks, not the network card. What would be the link ?
0
 
tmwsiyCommented:
I have found there is a relation between that and weird power management issues
0
 
ndidomenicoAuthor Commented:
What is the impact of switching AHCI to on in the Bios ? You seem to indicate I might need to re-install Windows, or do a repair install ?
0
 
tmwsiyCommented:
I have been able to get a repair to fix it but as far as I know if you change that setting in the bios and restart the OS simply will not start.
0
 
ndidomenicoAuthor Commented:
Is AHCI normally on by default on most systems ? When we received the Dell Vostro 430, we didn't hange anything in the default bios settings. I'll have to check if it's presently on or off. Any way to find out without having to go in the Bios ?
0
 
bright12Commented:
Most of the times it's F2 for DELL. It can also be the DEL key.

0
 
ndidomenicoAuthor Commented:
I meant in Windows, without having to reboot and go in the Bios.
0
 
bright12Commented:
Maybe it help if you update the drivers for your NIC.
0
 
ndidomenicoAuthor Commented:
Did all that: nwk driver update,bios update, all windows updates installed.
0
 
bright12Commented:
And you are sure that you have admin rights. You can try to create another user with admin rights, login to windows with that user and try to disable the option.
0
 
johnb6767Commented:
@tmwsiy - Are you referring to this scenario?

Error message when you start a Windows 7 or Windows Vista-based computer after you change the SATA mode of the boot drive: "STOP 0x0000007B INACCESSABLE_BOOT_DEVICE"
http://support.microsoft.com/kb/922976

Sure we aren't talking about ACPI? This can be checked in the Computer section of the Device Manager......
0
 
ndidomenicoAuthor Commented:
None of the responses actually helped fix the problem. But accepted some answers because of the help provided by those in my issue
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 7
  • 4
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now