Solved

XP pro only using 508mb of 2GB RAM

Posted on 2011-09-26
9
1,097 Views
Last Modified: 2013-11-09
I have a Dell Optiplex 170L with Windows XP Pro SP3 that is only seeing (and using based upon it's slowness) 508mb of the 2GB RAM installed. All 2GB show up in the BIOS, but when you boot into Windows it only shows 508mb in the system properties. So far I have updated the BIOS from AO7 to AO9, ran a CHKDSK /R, did a repair installation of XP Pro SP3, and I am currently doing a memory test using Ultimate Boot CD. I also went to crucial.com and had it scan the PC and Crucial shows that there is 2GB of RAM installed. I am perplexed. Have any of you experienced this? Thanks in advance for your help!
Jon
0
Comment
Question by:NWAtech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +1
9 Comments
 
LVL 3

Expert Comment

by:anjos
ID: 36599975
Perhaps your embedded graphic card is using up the rest?
0
 

Expert Comment

by:ElectricPulse
ID: 36600017
Is the RAM dual sided RAM? I once had a problem with SDRAM in an older machine when it would only detect half the ram since it only sees one side. It's unusual that it would detect 2GB in the BIOS though.
0
 

Expert Comment

by:ElectricPulse
ID: 36600050
I got that backwards. Dual sided RAM is good. Single sided ram will cause it to cut the memory size in half.
0
Secure Your WordPress Site: 5 Essential Approaches

WordPress is the web's most popular CMS, but its dominance also makes it a target for attackers. Our eBook will show you how to:

Prevent costly exploits of core and plugin vulnerabilities
Repel automated attacks
Lock down your dashboard, secure your code, and protect your users

 

Author Comment

by:NWAtech
ID: 36600095
EP, It is dual sided. I have tried other 1GB modules as well.

Anjos, I will try another video card as soon as the memory test is finished and let you know.
0
 
LVL 70

Expert Comment

by:garycase
ID: 36600104
First, the BIOS is "seeing" 2GB, so it's not an issue with single vs. dual-sided RAM (or any other RAM characteristics issue).     It's also NOT due to the embedded graphics [That is using SOME memory -- about 4MB ... that's why you "see" 508 instead of 512MB ... but it certainly isn't the cause of the issue you've asked about]

Most likely, you have the BIOS set to "install mode".     This features (a residual feature from NT days) only lets the OS "see" 512MB of RAM while you install the OS.     Go into the BIOS and change it, and your OS will suddenly "see" all 2GB.

0
 

Author Comment

by:NWAtech
ID: 36600129
Thanks for the input from everyone so far.  I should have mentioned in the initial post that the first thing I checked was the install mode setting.  It is set to off.  Also the machine has been updated to the latest BIOS revision.
0
 
LVL 70

Accepted Solution

by:
garycase earned 500 total points
ID: 36600603
Check your BOOT.INI file  [You'll need to set Explorer so you can see hidden & protected system files]  and see if there's a "/maxmem=xxx" switch.     If so, delete it.     The BOOT.INI file is in the root of C:

There's also a registry key that does the same thing ... I don't remember that offhand, but if it's not a simple /maxmem switch I'll see if I can find it.
0
 
LVL 70

Expert Comment

by:garycase
ID: 36600646
... one other thought:   Not sure which is overriding, but if it's the maxmem switch then you can fix this by simply ADDING a /maxmem=2048 swtich to your BOOT.INI file.

Also, you can easily see and edit the BOOT.INI file by just right-clicking on My Computer; selecting Properties; clicking the Advanced tab; clicking on Startup & Recovery; then clicking on Edit.

As I noted above, if it shows a /maxmem=512 switch, just delete it.    If not, you can try just adding a /maxmem=2048 switch (add this immediately after the OS name) -- so you'd have a line that looks someting like this:

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /maxmem=2048 /noexecute=optin /fastdetect
0
 

Author Closing Comment

by:NWAtech
ID: 36600971
That did it. Thanks.  I would have never thought to look at the boot.ini being an XP workstation.  But yes it had a maxmem switch and removing it shows up 2gb.
0

Featured Post

Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article summaries thoughts and ideas from two years of sustained use. It provides good reasoning to make the jump to Windows 10.
This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question