Solved

Mitel Border Gateway and cisco ASA

Posted on 2011-09-26
4
2,801 Views
Last Modified: 2012-08-13
Hi

I have a MBG in the DMZ of the ASA.

The MBG is nat'd from its external public ip address to the internal DMZ address.

I have opened ports according to mitel spec, the teleworker handsets authenticate and i can dial internal numbers. The problem is i can only receive one way audio i.e. the teleworker can hear the internal LAN phone but the internal LAN phone cannot hear the teleworker audio.

I suspect it is down to a routing issue with ASA but have hit i brick wall as to what the issue can be.
setup as is:

Teleworker DMZ IP 192.168.11.2
Teleworker outside external IP 86.188.xxx.xxx static NAT to 192.168.11.2
MCP IP 192.168.13.2 on voice LAN static NAT to DMZ

Any Help will be appreciated.
0
Comment
Question by:ads500
  • 2
  • 2
4 Comments
 
LVL 33

Expert Comment

by:MikeKane
ID: 36600471
Usually, one way audio indicated an access list issue where packets are being denied in one direction of the traffic flow.  


So, lets start with a post of your sanitized config of the ASA.  

Also, lets have a look at the SHOW LOGGING on the ASA.   If packets are being dropped, it would most likely show up here.

0
 

Author Comment

by:ads500
ID: 36708217
Hi and thanks for the reply,

I have cut out a few things but nothing that you will require,


ASA Version 8.2(2)
!
hostname xxx-PB-ASA
domain-name qed.local
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.13.0 mitel-network
dns-guard
!
interface Ethernet0/0
 speed 100
 duplex full
 nameif outside
 security-level 0
 ip address 86.188.xxx.xxx 255.255.255.240
!
interface Ethernet0/1
 speed 100
 duplex full
 nameif inside
 security-level 100
 ip address 192.168.1.254 255.255.255.0
!
interface Ethernet0/2
 speed 100
 duplex full
 nameif dmz
 security-level 50
 ip address 192.168.11.1 255.255.255.0
!
interface Ethernet0/3
 speed 100
 duplex full
 nameif guest
 security-level 90
 ip address 192.168.17.1 255.255.255.0
!
interface Management0/0
 shutdown
 no nameif
 security-level 100
 no ip address
 management-only
!
ftp mode passive
dns domain-lookup outside
dns domain-lookup inside
dns domain-lookup dmz
dns domain-lookup guest
dns server-group DefaultDNS
 name-server 192.168.10.2
 domain-name
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group service xxx tcp
 description Rules
 port-object eq 993
 port-object eq 75
 port-object range 1024 6500
 port-object eq 3389
access-list outside extended permit tcp any host 86.188.xxx.xxx eq www
access-list outside remark Teleworker access from outside inbound
access-list outside extended permit tcp any host 86.188.xxx.xxx eq ssh
access-list outside extended permit tcp any host 86.188.xxx.xxx eq https
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 6801
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 6802
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 6880
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 3998
access-list outside extended permit tcp any host 86.188.xxx.xxx eq www
access-list outside extended permit udp any host 86.188.xxx.xxx range 20000 23000
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 3300
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 2114
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 2116
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 35000
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 37000
access-list outside extended permit tcp any host 86.188.xxx.xxx eq smtp
access-list outside extended permit ip any host 86.188.xxx.xxx
access-list outside extended permit tcp any host 86.188.xxx.xxx eq https
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 993 inactive
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 75
access-list outside extended permit tcp any host 86.188.xxx.xxx eq www
access-list outside extended permit tcp any host 86.188.xxx.xxx eq ftp
access-list outside extended permit tcp any host 86.188.xxx.xxx range 1024 6500
access-list outside extended permit tcp any host 86.188.xxx.xxx eq 3389
access-list dmz remark Teleworker Access to outside and inside
access-list dmz extended permit tcp host 192.168.11.2 any eq ssh
access-list dmz extended permit udp host 192.168.11.2 any range 1024 65535
access-list dmz extended permit udp host 192.168.11.2 any eq domain
access-list dmz extended permit tcp host 192.168.11.2 any eq 6800
access-list dmz extended permit tcp host 192.168.11.2 any eq 6801
access-list dmz extended permit tcp host 192.168.11.2 any eq 6802
access-list dmz extended permit tcp host 192.168.11.2 any eq 3998
access-list dmz extended permit tcp host 192.168.11.2 any eq 3999
access-list dmz extended permit tcp host 192.168.11.2 any eq 6880
access-list dmz extended permit tcp host 192.168.11.2 any eq www
access-list dmz extended permit tcp host 192.168.11.2 any eq 3300
access-list dmz extended permit tcp host 192.168.11.2 any eq 2114
access-list dmz extended permit tcp host 192.168.11.2 any eq 2116
access-list dmz extended permit tcp host 192.168.11.2 any eq 35000
access-list dmz extended permit tcp host 192.168.11.2 any eq 37000
access-list dmz extended permit tcp host 192.168.11.2 any eq sip
access-list dmz extended permit icmp any any inactive
access-list dmz extended permit tcp host 192.168.11.2 any eq https
access-list dmz extended permit tcp host 192.168.11.10 any eq www
access-list guest extended deny ip any 192.168.0.0 255.255.0.0
access-list guest extended permit ip any any
access-list inside_nat0_outbound remark No NAT for VPN Clients
access-list inside_nat0_outbound extended permit ip 192.168.0.0 255.255.0.0 192.168.255.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip any 192.168.255.0 255.255.255.0
access-list xxx_split standard permit 192.168.0.0 255.255.0.0
access-list nonat-dmz extended permit ip 192.168.11.0 255.255.255.0 192.168.255.0 255.255.255.0
access-list nonat-in extended permit ip 192.168.1.0 255.255.255.0 192.168.255.0 255.255.255.0
pager lines 24
logging enable
logging buffered notifications
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
mtu guest 1500
ip local pool VPN-Client 192.168.255.1-192.168.255.254 mask 255.255.255.0
ip verify reverse-path interface dmz
no failover
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any dmz
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (outside) 2 86.188.xxx.xxx
global (dmz) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
nat (guest) 2 192.168.17.0 255.255.255.0
static (inside,outside) 86.188.xxx.xxx 192.168.10.2 netmask 255.255.255.255
static (inside,outside) 86.188.xxx.xxx 192.168.1.11 netmask 255.255.255.255
static (dmz,outside) 86.188.xxx.xxx 192.168.11.10 netmask 255.255.255.255
static (dmz,outside) 86.188.xxx.xxx 192.168.11.25 netmask 255.255.255.255
static (dmz,outside) 86.188.xxx.xxx 192.168.11.2 netmask 255.255.255.255
static (dmz,outside) 86.188.xxx.xxx 192.168.11.12 netmask 255.255.255.255
static (inside,dmz) 192.168.13.2 192.168.13.2 netmask 255.255.255.255
access-group outside in interface outside
access-group dmz in interface dmz
access-group guest in interface guest
route outside 0.0.0.0 0.0.0.0 86.188.xxx.xxx 1
route inside 192.168.10.0 255.255.255.0 192.168.1.1 1
route inside 192.168.12.0 255.255.255.0 192.168.1.1 1
route inside mitel-network 255.255.255.0 192.168.1.1 1
route inside 192.168.14.0 255.255.255.0 192.168.1.1 1
route inside 192.168.15.0 255.255.255.0 192.168.1.1 1
route inside 192.168.16.0 255.255.255.0 192.168.1.1 1
route inside 192.168.18.0 255.255.255.0 192.168.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authentication enable console LOCAL
aaa authentication telnet console LOCAL
aaa authentication serial console LOCAL
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
service resetinbound
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs group1
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map Management_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map Management_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
console timeout 0
dhcpd address 192.168.17.10-192.168.17.100 guest
dhcpd dns 192.168.10.5 interface guest
dhcpd enable guest
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept

class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns migrated_dns_map_1
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns migrated_dns_map_1
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
  inspect pptp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:e3654315dfe5c18fbc844d35c418017d
: end

When i engage on a call the syslog in the adsm goes crazy with packet drops with this:
5 Sep 26 2011      09:00:22      305013      192.168.13.20      50330  Asymmetric NAT rules matched for forward and reverse flows; Connection for udp src dmz:192.168.11.2/20018 dst inside:192.168.13.20/50330 denied due to NAT reverse path failure


Thanks in advance

Regards

Adam

0
 
LVL 33

Accepted Solution

by:
MikeKane earned 500 total points
ID: 36710151
This should work,  but would change your NAT structure between the DMZ and ASA which is what that ASA is choking on.  

Try a nonat between the DMZ and Inside and control access to the zones with a normal ACL.  

Create a 1 to 1 static for every device on the inside so the DMZ can hit it.  
static (inside,dmz) 192.168.13.0 192.168.13.0 netmask 255.255.255.0

You already have DMZ ACL to allow traffic going inbound to the inside on the right ports.    The ANY in those ACEs will cover traffic flowing to the inside also.  

Try that instead.



0
 

Author Comment

by:ads500
ID: 36710715
Hi MIke,

Thank you for you help. I have tested in the office as we have multiple internet lines, so i am able to replicate a tele worker dialling in from the outside. To my delight i have two-way audio for all calls, internal, external, and transferring calls.

On reflection i guess i had nat'd the icp controller across to the dmz but not the entire network. Go figure as the handsets 192.168.13.x are attempting to communicate with MBG in the dmz. explains the drop packets.

Again thanks for help.

adam
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Suggested Solutions

If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
This article assumes you have at least one Cisco ASA or PIX configured with working internet and a non-dynamic, public, address on the outside interface. If you need instructions on how to enable your device for internet, or basic configuration info…
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now