Solved

Dell Precision 690 XP Install

Posted on 2011-09-26
13
5,228 Views
Last Modified: 2012-05-12
Hi,

I have a dell precision 690
The machine came with two 7200rpm sata drives configured in Raid 0.
I have physically removed the two drives and have added a single 10k rpm sata drive (80GB WD Raptor).
I am trying to install windows xp 32-bit OS onto the new HD without using any raid configuration.

While the system was still up and running (with the raid 0 configuration), I downloaded and ran WS690A08.EXE which is the BIOS flash for this BIOS.  It was the same version I already had and when I rebooted the BIOS looked just as it had previously.

I also downloaded

I went to Dell and downloaded R165652.EXE which is supposedly the HD Controller Driver that I need.  Note that my Dell has an integrated LSI SAS 1068 Adapter.  I extracted those files and placed them on a diskette.

I then booted to the LSI controller BIOS and deleted the array.  If I reboot and enter the controller BIOS now there is no longer a "View existing array" menu item… which seems appropriate.

I then booted to the main system BIOS.   I went to the Drives portion.  Here is what the BIOS used to have in this section:
Drives
      SAS controller = On
      Diskette drive = USB
      Drive 0: SATA-0 = Off
      Drive 1: SATA-1 = Off
      Drive 2: SATA-2 = Off
      Drive 3: PATA-0 = On
Drive 4: PATA-1= On
SATA Operation = AHCI

I assumed that since I was going to be using the integrated controller I needed to leave "SAS controller" to "On" .  I changed Drive 0: SATA-0 to "On" thinking that I would need to do that in order to use the SATA drive in a non-raid configuration.  I left  "SATA Operation" as "AHCI".

I rebooted and again entered the main BIOS.  The system can see the HD – and it shows up in the Boot sequence list.

I then rebooted to CD with my xp pro cd in.  I selected  f6 to specify controller drivers.  I put in the diskette that I created and selected the only driver there – " Dell SAS 5x and SAS 6x Controller Driver (Windows XP 32-Bit)"

I then created a new partition on the drive and formatted it NTFS and windows began to copy install files.  

It next tells you to remove any disks and reboot.  I removed my diskette and rebooted.  But windows fails to load and continue the install.  When it is first rebooting it shows my SAS controller going through POST – it finds my HD.  Next the screen is cleared and I get what looks like a second HD controller POST routine.  It says:
Serial ATA AHCI BIOS
No Device found
AHCI BIOS not installed
Drive 0 Not found

And the system automatically boots to the CD and begins the setup again… rather than booting to the HD.  If you reboot and select boot options it shows the HD.  If you select it you get a msg that reads:  Windows could not start because of a computer disk hardware configuration problem.  Could not read from the selected boot disk…

I went back into the main BIOS and changed " Drive 0: SATA-0" Back to "Off" which is what it showed when the system was using a raid configuration.  

The EXACT same thing happened.  It didn't seem to make any difference at all.  I still got to the windows install first reboot and the exact same thing happened.  I could try setting the main BIOS " SATA Operation" to "SATA" rather than "AHCI" but I think that it is a lesser configuration and so I have not done that.

I am at a loss here…
0
Comment
Question by:santaspores1
  • 11
  • 2
13 Comments
 
LVL 3

Expert Comment

by:anjos
ID: 36600067
Try setting all the sata drives to on and change to ACHI to SATA (it can later be changed through a registry key change) and see if it goes better.
0
 

Author Comment

by:santaspores1
ID: 36600108
I have tried setting all of the SATA drives to ON - that didn't help.  I would rather not change from ACHI to SATA if it can be helped at all... and it seems like something I definitely should not have to do.
0
 

Author Comment

by:santaspores1
ID: 36600137
I went back into the main bios and set "Drive 0: SATA-0" Back to "On".  I redid all of the install steps above, but when prompted to insert my additional drivers diskette I fed it one created from drivers I downloaded directly from LSI (who make the controller) rather than the one created from DELL.  Note that it listed the driver as "LSI PCI Fusion-MPT Driver (XP 32-Bit).  

Same exact thing happened again.  At reboot it tried to boot to the cd and could not boot from the HD.  
0
 

Author Comment

by:santaspores1
ID: 36600209
Windows setup is able to format the HD and copy setup files to it.  So it seems that the F6 driver supplied is working.... but at reboot it is not selecting to use that driver....
0
 

Author Comment

by:santaspores1
ID: 36600252
hmmm... When I go into main BIOS the boot sequence shows my hard drive.  BUT it is listed as:
"#0558 ID00 LUN0 ATA WDC WD8"
That "LUN0" sounds like RAID.
And when I highlight the line that says "Drive 0: SATA-0 = ON"  The area below does not show the drive characteristics as it should.

I am going to try "SAS controller = Off" and see what happens...
0
 

Author Comment

by:santaspores1
ID: 36600300
I am not going to bother trying to do the install.  After setting "SAS controller = Off" I can reboot into the system BIOS and see that when I select SATA-0 it still doesn't show the drive ID and now my boot sequence no longer shows any hard drive at all.
0
What Should I Do With This Threat Intelligence?

Are you wondering if you actually need threat intelligence? The answer is yes. We explain the basics for creating useful threat intelligence.

 
LVL 3

Expert Comment

by:anjos
ID: 36600418
A shot in the dark here but are the SAS and SATA connections separate?
Tried connecting to another sata port?
0
 

Author Comment

by:santaspores1
ID: 36600935
The computer already had two SATA drives connected.  I removed those and added back another SATA drive - to the same location.  Physically this is already working to some degree - otherwise I wouldn't be able to format the HD and copy files during the initial setup.  
0
 

Author Comment

by:santaspores1
ID: 36601182
When I got the machine the two hard drives were connected to HD1 and HD2 on the motherboard rather than HD0 and HD1.  I thought that was odd, and I changed them to HD0 and HD1 back when the system was still configured in a raid.  The system came up just fine.  So I am currently connecting my single SATA drive to HD0 on the motherboard.  I have an integrated controller and no others installed.
0
 

Author Comment

by:santaspores1
ID: 36601254
I entered the main BIOS and set all defaults.  Still didn't seem to help.  But now the boot sequence look different.  Before it had:

1.      Onboard USB or USB CD ROM
2.      USB Device
3.      #0558 ID00 LUN0 ATA WDC WD8

And now it has:

1.      Onboard or USB Floppy drive
2.      Onboard SATA Hard drive (not present)
3.      Onboard PATA Hard drive (not present)
4.      #0558 ID00 LUN0 ATA WDC WD8

Here is what the section under drives looks like now:

Drives
      SAS controller = On
      Diskette drive = Internal
      Drive 0: SATA-0 = Off (even though under that it says the default setting is On!!!)
      Drive 1: SATA-1 = Off (even though under that it says the default setting is On!!!)
      Drive 2: SATA-2 = Off (even though under that it says the default setting is On!!!)
      Drive 3: PATA-0 = On
      Drive 4: PATA-1= On
      SATA Operation = AHCI
0
 

Author Comment

by:santaspores1
ID: 36601258
Note - I also tried to connect the drive to HD1 on the motherboard... no help.
0
 

Accepted Solution

by:
santaspores1 earned 0 total points
ID: 36709902
Well, I got it to work.  I had to reset the bios and start over.  But I didn't make any changes that I thought were really important.  Anyway, in case someone else needs this information, here it goes:

There is one SATA HD connected to HD0 on the motherboard.  In the controller BIOS I deleted the raid array so there is nothing there.  My main bios is as follows:

System
      System Info
            System = Precision Workstation 690
            BIOS version = A08 (04/25/08)
            Service Tag = xxxxxxxx
      Processor Info
            CPU: 0
            Processor Type = Intel Xeon 5310 @ 2GHz
            Processor Clock Speed = 2GHz
            Processor Bus Speed = 1333 MHz
            Processor L2 Cache = 4Mb
            Processor ID = 06F6
            Multiple core capable = Yes (dual)
            Hyperthreading capable = No
            64-bit Technology = Yes (Intel EM64T)
      Memory Info
            Installed memory = 4 Gb
            Memory Speed = 533 MHz
            Memory Channel Mode = Quad
            Memory Technology = FB-DIMM DDR2 SDRAM (ECC)
      PCI Info
            Slot 1: Not populated
            Slot 2: VGA Connected
            Slot 3: Not populated
            Slot 4: Not populated
            Slot 5: Not populated
            Slot 6: Not populated
            Slot 7: Not populated
      Boot Sequence
1.      Onboard or USB CD-Rom drive
2.      #0558 ID00 LUN0 ATA WDC WD8
3.      Onboard or USB Floopy drive (Note present – only because I didn't have it attached)
4.      Onboard SATA Hard drive  (Note present)
5.      Onboard PATA Hard drive  (Note present)
6.      #0558 ID01 LUN0 ATA WDC WD8
Drives
      SAS controller = On
      Diskette drive = USB  (default was internal)
      Drive 0: SATA-0 = Off
      Drive 1: SATA-1 = Off
      Drive 2: SATA-2 = Off
      Drive 3: PATA-0 = On
Drive 4: PATA-1= On
SATA Operation = AHCI

Onboard Devices
      Integrated NIC = on
      Integrated audio = on
      USB controller = on
      Front USB Ports = on
      USB for FlexBay = No boot
      1394 controller = on
      LPT Port Mode = ECP (default was PS/2)
      LPT Port Address = 378h
      LPT Port DMA = Off
      Serial Port #1 = auto
      Serial Port #2 = auto
      PS2 Mouse Port = On

Video
      Primary Video = PEG

Performance
      Virtualization = Off (this is the default but use to be On)
      Limit CPUID = Off
      Snoop Filter= On
      ACL Prefetch = Off (this is the default but use to be On)
      HW Prefetch = On
      FSB Optimization = Off (this is the default but use to be On)

Security
      xxxxx

Power Management
      AC recovery  = Off
      Auto Power off = Off
      Low Power Mode = Off
      Remote Wakeup = Off
      Suspend Mode = S3

Maintenance
      xxxx

Post Behavior
      Fast Boot = On
      Numlock – On
      OS Install = Off
      Post Hot keys
            F2 = Setup
            F12 = Bootmenu
0
 

Author Closing Comment

by:santaspores1
ID: 36898864
It seems that resetting the bios made some change that I didn't think of myself...
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Sometimes people don't understand why download speed shows differently for Windows than Linux.Specially, this article covers and shows the solution for throughput difference for Windows than a Linux machine. For this, I arranged a test scenario.I…
If you don't know how to downgrade, my instructions below should be helpful.
This video discusses moving either the default database or any database to a new volume.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now