Solved

Cisco ASA 5505 site to site vpn tunnel problems.

Posted on 2011-09-26
4
461 Views
Last Modified: 2012-05-12
I'm an extreme novice when it comes to cisco configurations, so please be patient with me.

I configured an ASA for a home user to connect to our VPN here at the office.  He is using Comcast, plugs the comcast box into Port 0 on the ASA.  Plugs his IP phone and laptop into ports 1 and 2, but gets not connectivity to the network and cannot get out to the internet.

However, I am able to SSH to his ASA from our main office.  So something is working, but not the vpn connection.  I have no idea how to debug what is happening, which I'm hoping to get some suggestions.

One thing I should mention is that we do not manage our firewall here, it is managed by our ISP. Which, shockingly, they have been known to make mistakes when adding these tunnels to the equipment.

Here is the configuration:

ASA Version 8.2(1)
!
hostname XXX
enable password VP499FidYERGYyR/ encrypted
passwd Yum1d1V7A/1BMuwH encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.163.0 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address xx.xx.xx.xx 255.255.255.248
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
access-list vpn_range extended permit ip 192.168.163.0 255.255.255.0 10.0.0.0 25
5.0.0.0
access-list nonat extended permit ip 192.168.163.0 255.255.255.0 10.0.0.0 255.0.
0.0
pager lines 24
logging enable
logging timestamp
logging buffer-size 16384
logging buffered informational
logging asdm informational
logging flash-bufferwrap
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 xx.xx.xx.xx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
http 192.168.163.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set strong esp-3des esp-md5-hmac
crypto ipsec transform-set FIX esp-aes esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 10 match address vpn_range
crypto map outside_map 10 set peer xx.xx.xx.xx
crypto map outside_map 10 set transform-set strong
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
telnet timeout 5
ssh xx.xx.xx.xx inside
ssh xx.xx.xx.xx 255.255.255.224 outside
ssh xx.xx.xx.xx 255.255.255.255 outside
ssh xx.xx.xx.xx 255.255.255.255 outside
ssh xx.xx.xx.xx 255.255.255.255 outside
ssh timeout 5
console timeout 0
management-access inside
dhcpd auto_config outside
!
dhcpd address 192.168.163.5-192.168.163.36 inside
dhcpd dns xx.xx.xx.xx 66.155.216.122 interface inside
dhcpd wins xx.xx.xx.xx interface inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ntp server 192.5.41.41
webvpn
username xxxx password Am/WprjddB3lDJoV encrypted privilege 15
username xxxx password cybe2E0oKjivvMC1 encrypted privilege 15
tunnel-group xx.xx.xx.xx type ipsec-l2l
tunnel-group xx.xx.xx.xx ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect icmp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:dc483c31a13e96df3ad737fc471d9949
: end
xxxxxx#

I just really don't even know where to start with debugging commands, to see where the problem could be.

Thank you!
0
Comment
Question by:cas_three
  • 2
4 Comments
 
LVL 18

Expert Comment

by:jmeggers
ID: 36701389
Your VLAN interface address needs to be a host address, not a subnet.  Other than that, I don't see anything obviously wrong, but I'll keep looking.
0
 
LVL 18

Accepted Solution

by:
jmeggers earned 250 total points
ID: 36703248
Don't see anything else.

First thing, I'd say, is the host computer getting an IP address, and can he ping the ASA?  Can the ASA ping Comcast? If traffic isn't flowing, is there a NAT translation being created (show xlate)?  Start with those and we'll move on depending on what you see.
0
 
LVL 18

Assisted Solution

by:fgasimzade
fgasimzade earned 250 total points
ID: 36707656
Have you added sysopt connection permit-ipsec command?
0
 

Author Closing Comment

by:cas_three
ID: 36892161
I do appreciate the suggestions even though they didn't fix my problem.

I was missing one command, dhcpd enable inside.  It wasn't handing out ip addresses.

Thank you
0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

Suggested Solutions

Overview The Cisco PIX 501, PIX 506e, ASA 5505 and ASA 5510 (most if not all of this information will be relevant to the PIX 515e but I do not have a working configuration handy to verify the validity) are primarily used within small to medium busi…
From Cisco ASA version 8.3, the Network Address Translation (NAT) configuration has been completely redesigned and it may be helpful to have the syntax configuration for both at a glance. You may as well want to read official Cisco published AS…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now