Solved

how to remove email domain off exchange 2010 to stop receiving emails from internally

Posted on 2011-09-26
42
511 Views
Last Modified: 2012-05-12
We just unmerged with a company that we merged into our AD and exchange. Now that they have left, we cannot email them (have not deleted their mailboxes - but disabled their accounts) from internally. I have deleted cached information on our outlooks and manually retyped their address.

No error because I believe our server is still accepting the emails.

Removed them from HUB transport rules - accepted domains - address policies.. no luck

We have Exchange 2010 on 2008 server.... any help appreciated.
0
Comment
Question by:Techneut
  • 24
  • 18
42 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36601624
Remove the domain from the Accepted domain list (after removing any Email Address Policies) and then delete all email addresses in user accounts, email-enabled Public Folders and distribution groups etc.

Org Config> Hub Transport> Accepted Domains
0
 
LVL 1

Author Comment

by:Techneut
ID: 36601643
I have removed them from accepted domains, but not yet removed user accounts because there was a day of emails that they still need in those mailboxes.
0
 
LVL 1

Author Comment

by:Techneut
ID: 36601652
Is it possible to have AD accounts w/mailboxes and still send them emails that are no longer on our exchange server?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36601674
You can remove the domain from the accepted domain list and this won't affect your received emails in people's mailboxes.

If you have removed the accepted domain - you won't be able to receive emails to those addresses, although Exchange may still deliver emails sent internally due to cached info.
0
 
LVL 1

Author Comment

by:Techneut
ID: 36601713
So that is where I'm at.

"If you have removed the accepted domain - you won't be able to receive emails to those addresses, although Exchange may still deliver emails sent internally due to cached info."

Is there any reason why, on my server, is still accepting those emails? I manually retype the email address but they still do not receive the emails...?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36601762
Is it accepting the emails from outside, inside, or both?
0
 
LVL 1

Author Comment

by:Techneut
ID: 36601773
The domain was moved to another office, completely separate from our domain and network. They can send and receive externally, and send to our domain. We cannot send to them because the emails are still being routed to our server. It seems that our server is accepting the emails for that domain, even after we removed the domain from accepted domain on our exchange.
0
 
LVL 1

Author Comment

by:Techneut
ID: 36601821
I have verified in our ADSI that the listof accepted domainsis stored in CN=configuration -> CN=Services -> CN = Microsoft Exchange -> CN = "myOrganization" -> CN = Transport Settings -> CN = Accepted Domains

is not listed there as well. Still so confused on what needs to be done.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36601864
Can you run the following please and advise if it is still listed:

Get-AcceptedDomain
0
 
LVL 1

Author Comment

by:Techneut
ID: 36601874
it is not in the list...
0
 
LVL 1

Author Comment

by:Techneut
ID: 36601887
Should I change all of their email accounts in AD to a different email address? For instance:

Joe Smith = jsmith@abc.com would be changed to jsmith@def.com

Willing to try anything at this point... but I'm guessing the email will still go our server since for some reason it thinks we still accept abc.com
0
 
LVL 1

Author Comment

by:Techneut
ID: 36601914
Do I have to reboot the server to have everything "set" into place?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36601941
Good that it's not in the list.

Have you restarted the Exchange Transport Service since removing the domain?  If not - please do and try emailing the domain again.
0
 
LVL 1

Author Comment

by:Techneut
ID: 36601978
no luck...
0
 
LVL 1

Author Comment

by:Techneut
ID: 36601987
What I have noticed is that when the name is finished typed, it gets underlined? As if it knew the email address?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36602005
It will as it will be cached in Outlook.

When you start to type the email address - you should see the rest auto-fill, but before you press enter, highlight the name and press Delete.  Once deleted, start to type the address again and complete the full email address, then send and see what happens.
0
 
LVL 1

Author Comment

by:Techneut
ID: 36602032
Did that a few times. As I type in the email address, I delete the email address. Then retype it in manually, but it underlines the name again and changes the entire email address to just a name.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36602082
Okay - have you also deleted the Offline Address Book or regenerated the Offline address book and then re-downloaded it in Outlook?
0
 
LVL 1

Author Comment

by:Techneut
ID: 36623998
Yes I have just checked and rebooted the server. Removed them from address book on server then redownloaded and still same result.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36709089
Did you rebuild the all the address books?

Update-Addresslist "AddressListName"
Update-globaladdresslist -identity "Global Address List"
Update-offlineaddressbook -identity "OfflineAddressBookName"
Update-FileDistributionService -identity CASSERVERNAME -type "oab"
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710056
Through the GUI, I clicked on Apply on the address list, but I will run the commands you posted to see if it works. Will let you know... about how long does this take?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36710067
It should all be very quick with each command - unless you have zillions of users on your server.
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710080
WARNING: The recipient "abc.com/Microsoft Exchange System Objects/Offline Address Book - First Administrative Group"
is invalid and couldn't be updated.
WARNING: The recipient "abc.com/Microsoft Exchange System Objects/Schedule+ Free Busy Information - First
Administrative Group" is invalid and couldn't be updated.

when I tried to run: Update-globaladdresslist -identity "Default Global Address List"
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36710088
Check the name of your Global Address List and replace it accordingly.

Each name needs to match your environment.
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710097
Everything else ran perfectly except that line, I will retry.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36710104
Ok
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710114
Yeah same issue, replaced the name exactly as it is stated, but the same warning... Everything else ran perfectly.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36710153
I get the same on a Customer's server - works on mine!

Leave that for now.

Any better now?
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710243
No it still went to our server.
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 250 total points
ID: 36710265
Okay - just a reminder - have you removed the email addresses from the user accounts?
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710302
no the user accounts still have email addresses, because I was told to reserve the mailboxes on exchange. If I remove those email addresses, won't I lose their mailboxes?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36710324
No - Changing the email address or removing it is fine.  Do they have a single email address in the account, or multiple?

If they have multiple - delete the old domain address.

If a single address - modify it to make it different to the current one by adding a 1 to the end of the user part or something similar.
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710332
Okay will do, and by the way - thank you for sticking around to see me through this!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36710354
You are welcome - I like getting my teeth into a problem :)
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710382
It did not work and I'm not sure where it went because I don't see it in my queue.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36710430
What didn't work exactly?
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710625
The email didn't go to the recipient. I believe it went to our server?
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36710658
Okay - so it didn't arrive at the recipient - but it won't be delivered internally now and should be sent externally.
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710701
oh... So if I change back the email address on the user account it won't be in the inbox - as if it were to be sitting in a queue somewhere?
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710771
I believe it worked!
0
 
LVL 1

Author Comment

by:Techneut
ID: 36710780
TY VM!
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 36710864
Excellent - we got there in the end :)

Thanks for the points.

Alan
0

Join & Write a Comment

Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
Are you unable to connect or configure Hotmail email account in Microsoft Outlook 2010, 2007? Or Outlook.com emails are not downloading to Outlook? Lets’ see the problem and resolve Outlook Connector error syncing folder hierarchy (0x8004102A).
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now