VOIP Phone Linksys SPA921- Stuck on Initliazing Network

can 2 voip phones in the same network have the same multicast address?
i have a sitatuion when one of the phones doesnt connect to the network, while and identical phone of the same make connects to the network instaneously.

i went through the settings and noticed that they both set on the same multicast address. would that be a problem.

both phones are dhcp enabled. sockets used to connect have healthy intranet.
ive tried factory reset with not luck
phone is stuck on initiliazing network.

what can i do to make this work
phone model is linksys ip phone spa921
Who is Participating?
_-W-_Connect With a Mentor Commented:
Set static IP. Make sure DNS and Gateway are set properly!
Anti-MhzAuthor Commented:
ethernet adapter is damaged on of the phones
Anti-MhzAuthor Commented:
this would work. worked on another phone, same model
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.