Setup auto discover exch 2010

I need to setup auto discover on my exchange server so that users don't have to put in the company domain name when setting up mobile phones. How do I do this?
Do I do this via auto discover?
LVL 1
vmichAsked:
Who is Participating?
 
vmichAuthor Commented:
I got the issue resolved by turning on Intergerated authenication on the microsoft sctive sync in the sys mgr of the 2003 exch server
0
 
Hendrik WieseInformation Security ManagerCommented:
You would use to Configure Exchange ActiveSync Autodiscover Settings:

This example configures the Autodiscover service and sets the ExternalURL property.
Set-ActiveSyncVirtualDirectory -Identity "COMPUTERNAME\Microsoft-Server-ActiveSync (Default Web Site)" -ExternalURL "https://servername.com/"

Open in new window


This example configures the Exchange ActiveSync server property on the Client Access server.
Set-ActiveSyncVirtualDirectory -Identity "COMPUTERNAME\Microsoft-Server-ActiveSync (Default Web Site)" -ActiveSyncServer "https://servername.com/"

Open in new window


Reference: http://technet.microsoft.com/en-us/library/aa998277.aspx
0
 
5g6tdcv4Commented:
If you are not running windows phones it is of no use to you
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
vmichAuthor Commented:
Dont I have to make some change in iis so that the users dont have to type in the domain name?
0
 
vmichAuthor Commented:
I need to set it up so that the users dont have to worry about putting in the domain name on their mobile device, just their id and password.
Where do I need to set this up at?
0
 
5g6tdcv4Commented:
what type of phones are you running?
0
 
vmichAuthor Commented:
Iphones
0
 
5g6tdcv4Commented:
autodiscover is not supported with iphones.
0
 
vmichAuthor Commented:
So there is no way via iis or anything that I can set this up because right now their iphones connected to exchange 2003, the dont have to put in the domain name now and it works but when they try to connect to the exchange 2010 server without the domain name, it does not connect.
0
 
vmichAuthor Commented:
Activesync is support on the iphones. I found this:
The Apple iPhone offers Exchange ActiveSync functionality. Users can configure an Exchange ActiveSync account on their Apple iPhone and synchronize e-mail, calendar, and contact data. When a user uses the Apple iPhone to synchronize e-mail messages, all e-mail messages in their inbox are synchronized to the iPhone. Users can't limit the synchronization to only 3 days of e-mail messages as they can with other phones. The iPhone is compatible with Exchange ActiveSync version 2.5 and doesn't support all the features included with Exchange ActiveSync for Exchange 2010. Specifically, the Apple iPhone supports only the following policies:

Remote wipe

Enforce password on device

Minimum password length

Require alphanumeric password

Require complex password

Inactivity time lockout
0
 
5g6tdcv4Commented:
activesync functionality.
Not autodiscover
0
 
vmichAuthor Commented:
Sorry my fault
0
 
vmichAuthor Commented:
So is there anyway for me to have this setup via iis setting or some other so that the users can connect without out the domain as the do now in exchange 2003 on the exchange 2010 side?
0
 
5g6tdcv4Commented:
well are these users mailboxes still on the 2003 server or the 2010?
0
 
vmichAuthor Commented:
They are now on 2003 but they will be migrated to 2010 eventually. So I need them to be able to connect via the 2010 and then through redirection and legacy url they will get their 2003 email, as happens now via owa.
I have it so that the users login to owa and then if they are a 2003 users they go to the 2003 exch(legacy url) or if they are 2010 then they go to 2010 exch.
0
 
5g6tdcv4Commented:
Ok what Happens if you move a test user from 2003 to 2010 and dont re-setup iPhone, just test connectivity
0
 
vmichAuthor Commented:
They wont connect to the 2010 until the domain name is put in.
0
 
vmichAuthor Commented:
solved
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.