Solved

RAM recognized in bios not Win XP

Posted on 2011-09-26
12
577 Views
Last Modified: 2013-11-09
I am trying to install more RAM on users PC's. I usually go to crucial.com and select brand, model and it tells you what types of RAM to use and the max. I have never had an issue before.

Now I am trying to upgrade a Dell optiplex gcx260 and 270. We bought the ram and the bios reads the new amount but windows xp does not recognize the added memory. It still displays the old amount. Bios is update and windows updates are up to date. Any insight on this?
0
Comment
Question by:IT_Fanatic
  • 5
  • 2
  • 2
  • +3
12 Comments
 
LVL 3

Expert Comment

by:kawamuracd
ID: 36601860
Are you making sure to not go over the 4gb limit on a 32 bit system? I have to ask.
0
 
LVL 16

Expert Comment

by:uescomp
ID: 36601903
32bit xp will see 4gb but show only 3.5gb or so in windows. Check the BIOS and see how much is deticated to video (256, 128, 64) etc.
0
 

Author Comment

by:IT_Fanatic
ID: 36601956
I am installing enough ram to make it 2GB. I know the rules of 32 and 64 bit that is why im a little confused on how the bios sees the ram but not the OS
0
 

Author Comment

by:IT_Fanatic
ID: 36601969
usecomp i dont think it is the video memory. Reason why the user had 512ram and I removed the 512mb and install two 1gb sticks to give him 2gb. The system still showed 512mb. This was on the gx 260 and the same on the gx270
0
 
LVL 10

Expert Comment

by:Mohammed Rahman
ID: 36602277
Make sure that the share RAM (for video memory) is not enabled in BIOS or not large memory is shared for Video.
0
 

Author Comment

by:IT_Fanatic
ID: 36602325
Ohhh ok so what will happen any cons of disabling that option?
0
What Is Threat Intelligence?

Threat intelligence is often discussed, but rarely understood. Starting with a precise definition, along with clear business goals, is essential.

 
LVL 10

Expert Comment

by:Mohammed Rahman
ID: 36602561
If Video Memory sharing is enabled, a portion of RAM (user defined size) will be assigned to the video processing. It will add up to the video memory of existing card. For eg, if the dedicated video memory of video controller is 512MB and you have 2GB of RAM of which you share 512MB with video controller, the total video memory will become 1024. The total RAM in BIOS will show 2GB and total RAM in OS (computer properties) will show 1536MB. (~1.5gb)

Cons: If you use any application that extensively use video memory, the application may not perform little good due to lack of sufficient memory required.
0
 
LVL 70

Expert Comment

by:garycase
ID: 36657396
This is NOT likely to be any of the above.    It's almost certainly either a /maxmem setting in the BOOT.INI, or Install Mode setting in the BIOS.

Check your BOOT.INI file to see if there's a /maxmem setting => if so, just delete this switch and it will use all available memory.     You can easily see and edit the BOOT.INI file by just right-clicking on My Computer; selecting Properties; clicking the Advanced tab; clicking on Startup & Recovery; then clicking on Edit.

This issue could also be an "install mode" in the BIOS ... a holdover from NT days that will limit the amount of RAM exposed to the OS.
0
 

Author Comment

by:IT_Fanatic
ID: 36701884
Ok so once I hit edit on the boot INi just select delete? Also what do I do in the install mode? I don't know where to start as I have never heard of install mode
0
 
LVL 70

Accepted Solution

by:
garycase earned 500 total points
ID: 36706780
In your BOOT.INI (the file you'll see when you hit Edit) there will be a line something like this (it may vary slightly):

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /maxmem=512 /noexecute=optin /fastdetect

Just delete the /maxmem=512 from that line, so it looks like this:

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


The example above assumes you're "seeing" 512MB -- if it's a different amount, the /maxmem parameter will be different ... e.g. if you're seeing 1GB the line probably reads /maxmem=1024

... if there isn't a "maxmem" in BOOT.INI, then boot to the BIOS and look for an "install mode" setting.    Be sure it's turned off.     But I suspect the problem is simply a /maxmem switch in BOOT.INI
0
 
LVL 17

Expert Comment

by:xema
ID: 36720766
Did you hit [F2] at boot time?
I remeber some Dell systems that needed to go into BIOS setup before they pass the changes  to the OS.
0
 

Author Closing Comment

by:IT_Fanatic
ID: 36814631
This fixed it. The boot ini file had the ram set to a certain size. Once I removed the line with the ram info I rebooted the machine and all the ram was recognized by the OS. Thanks for the help.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Like many organizations, your foray into cloud computing may have started with an ancillary or security service, like email spam and virus protection. For some, the first or second step into the cloud was moving email off-premise. For others, a clou…
Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.
The viewer will learn how to successfully download and install the SARDU utility on Windows 7, without downloading adware.

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now