Solved

IBM Bladecenter Cisco Switch VLAN to SonicWALL

Posted on 2011-09-26
6
347 Views
Last Modified: 2012-08-13
Hello,
Need some help with a SonicWALL to Cisco switch module configuration.  The Cisco switch module is a 20-port switch module in an IBM Bladecenter.

Currently, the SonicWALL firewall has WAN X1 connected to the upstream provider.  It's IP address is 64.xx.xx.21.  LAN XO is IP 192.168.6.1 and connected to Cisco switch module port GigabitEthernet0/17.  The configuration of GE0/17 is as follows (it's the default config):

interface GigabitEthernet0/17
description extern1
switchport access vlan 2
switchport trunk native vlan 2

I have a server blade connected to GE0/2, and I would like to have it's traffic separated to a different VLAN.  I do have traffic on VLAN2 however from GE0/1 that is on the 192.168.6.x class and that needs to stay functional.  GE0/2 configuration is here (again, default):

interface GigabitEthernet0/2
description blade2
switchport access vlan 2
switchport trunk native vlan 2
switchport trunk allowed vlan 2-4094
switchport mode trunk
spanning-tree portfast trunk
spanning-tree bpdufilter enable

I can create a VLAN interface on the SonicWALL X0 Port and give it an IP address of 192.168.7.1, tagging packets as VLAN 3, but I cannot get the packets to flow over to GE0/2.  I would like all traffic going to/from GE0/2 to be VLAN 3.  How can I achieve this?
0
Comment
Question by:e2346437
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
6 Comments
 
LVL 33

Expert Comment

by:MikeKane
ID: 36602144
You need a device to route the packets.    Either a Router on a stick scenario, or (if this switch is capable) use the switch itself to route.  

IF you want to use the switch, Create the vlans and assign the switch an IP in each vlan,

interface vlan2
192.168.6.2

interface vlan3
192.168.7.1


and enable IP routing

ip routing



Devices on vlan 3 use 192.168.7.1 as the gateway, devices on vlan 2 use 192.168.6.2 as the gateway.   The switch must have a default route pointing out to the next hop gateway at 192.168.6.1


0
 

Author Comment

by:e2346437
ID: 36602205
The firewall should be capable of routing the packets, shouldn't it?
0
 

Author Comment

by:e2346437
ID: 36602248
"ip routing" is not a valid command on this switch.
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 33

Expert Comment

by:MikeKane
ID: 36710015
Can you send the output of a SHOW VER.  

Oh and 1 thing I forgot.  You'd need to add a static route on the Sonicwall for destination 192.168.7.0/24 to 192.168.6.2.  


0
 

Accepted Solution

by:
e2346437 earned 0 total points
ID: 36906666
Fixed it myself.  Just had to change GE0/17 to switchport mode trunk.

0
 

Author Closing Comment

by:e2346437
ID: 36935304
No one else had the answer.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VLAN Overused monitor 4 59
2960 not recognizing subinterface configuraton of 5510 11 69
How to disable sflow Cisco nexus 9k 3 50
DHCP behind catalyst 3750 POE-48 2 76
The worst thing when starting a new job is when the previous Network Administrator left behind no documentation. How do you get into the devices? If you've been in this situation or just accidently mistyped your password, this article will hopefully…
Network traffic routing plays key role in your network, if you have single site with heavy browsing or multiple sites, replicating important application data from your Primary Default Gateway ,you have to route your other network traffic from your p…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

739 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question