Question on Exchange EWS in Exchange 2010 SP1

I have a user that is having issues with Lync and Exchange 2010 SP1. I don't know the specifics of the error just yet but this prompted a different question as to whether EWS was enabled for this user. Now I would think this would be the default for Exchange. I looked at some mailboxes and using the get-casmailbox command, examined a few mailboxes. I noticed that EWSEnabled is set to blank.I though well this could not be possible because everything is working. Maybe its set Organization wide? Using the get-OrganizationConfig command and piping to FL, I found the EWSEnabled setting but its blank also!! So, my question is why does it not say Enabled at the Org level. Is blank an implied Enable?
osiexchangeAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PradeepCommented:
AFAIK it is not enabled by default.
We should enable using the commands which u have mentioned.

once go through this article :

http://thoughtsofanidlemind.wordpress.com/2010/08/12/controlling-ews-access-in-exchange-2010-sp1/
osiexchangeAuthor Commented:
I already read that article. That is what prompted this post. How can it be that EWS is not enabled when things like Free/Busy, Rules, Out of Office and the laundry list of other services provided by EWS is working?
PradeepCommented:
I dont understand why it was showing null to you.
try set command once and test.
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

PradeepCommented:
Sorry for above post :

EWS will be enabled by default in Exchange 2010 with no changes needed. It can be affected by common changes made to the system after installation. Installing an SSL certificate with a different name than the server's can cause problems.
For example  using mail.company.com instead of exmail01.company.com

Use Set-AutodiscoverVirtualDirectory command  to change the Internal and External URLs used to connect to EWS/Autodiscovery.

osiexchangeAuthor Commented:
I think we are all set with our certificates. We have been running for at least a year. I was careful in ceritficate creation and we use SAN certificates for everything. This all came up because I had someone from our tech support team say EWS is not working for a particular user. I believe the problem is that Conversation History is not being saved in Outlook for this user and apparently this is somehow tied to EWS in Exchange. I started looking around and found Redmonds article and then looked at the mailboxes and Organization. I was surprised to find a Null value here but certainly reluctant to change anything. My other question is why Null?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
osiexchangeAuthor Commented:
I found the solution myself my calling Microsoft
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.