Solved

Ctrix ICA client cannot open IE or Outlook, Local RDP ok

Posted on 2011-09-26
11
1,088 Views
Last Modified: 2012-08-13
Hi,

We've come across a strange problem regarding citrix Metaframe XP and the ICA clients. I am not familiar with Citrix, so I'm hoping some of the Citrix gurus out there can help out.

This is an old system that is running Metaframe XP (Feature Release 3) 1.3.1

ICA client connections to the remote desktop can not open Outlook 2003 or Internet Explorer 6.
These applications open fine if the same user was to perform a straight RDP logon without the ICA client.

Word, Excel, Powerpoint, Firefox, etc all work perfectly fine and are located on the same partition as the broken apps.

Even going straight to the folder where the exe is located and running gives only a brief flash of hourglass then nothing.. nothing shows in task manager (processes), nothing in event logs....

This even happens when logging onto ICA client as an administrator. I've tried installing the ICA client on a fresh PC, and even tried on a Mac.

I cannot even say when this problem started.

Any advice would be greatly appreciated.
0
Comment
Question by:Nanosphere
  • 6
  • 4
11 Comments
 
LVL 25

Expert Comment

by:Tony1044
Comment Utility
Anything in the event logs to indicate any problem?

Does it work ok for administrative users?

From the way you descibe the system, I am assuming it is a published desktop?

I would start by downloading the sysinternals process monitor tool and as an administrative user, launch it on one of the affected servers. Then filter on say outlook.exe and try to fire it up on the same server as an affected user. It might be permissions related.

0
 
LVL 22

Expert Comment

by:rickhobbs
Comment Utility
0
 

Author Comment

by:Nanosphere
Comment Utility
@tony1044

Nothing in the event logs
same problem for citrix and domain admins
the RDP is published, yes.
Process explorer shows the iexplore.exe or the outlook.exe process for a brief second then they terminate. no errors, popups, event log message...


@rickhobbs
The DEP is turned off completely, and the system is running 2003 SP2 which appears to supercede the hotfixes mentioned.


Thanks for the advice so far.
0
 

Author Comment

by:Nanosphere
Comment Utility
I've also disabled the Trend Micro antivirus in case it was the cause..
0
 

Author Comment

by:Nanosphere
Comment Utility
Aha... just found the solution..

Looking through the citrix forums, I found this:

http://forums.citrix.com/thread.jspa?threadID=65096&tstart=0

This tells us to remove the following registry keys:

HKLM\Software\Citrix\CtxHook\AppInit_DLLS\speedscreen\iexplore.exe
HKLM\Software\Citrix\CtxHook\AppInit_DLLS\speedscreen\outlook.exe

I did that, and now they open fine.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 22

Accepted Solution

by:
rickhobbs earned 250 total points
Comment Utility
So it turns out it was a speedscreen error.  Had you applied the hotfix I pointed you to?
0
 

Author Comment

by:Nanosphere
Comment Utility
The Citrix KB pages are a mess. All of the links on that page gave a 404 error.

I did eventually locate the latest rollup pack for Metaframe XP on 2003, which *should* address this issue:
http://support.citrix.com/article/CTX107783.

Unfortunately, I am stuck at this point now as it won't install because it's only SP3 and SP4 is no longer available for download....

The only Citrix Hotfix which appears to be installed is :XE103W2K3024
0
 
LVL 22

Expert Comment

by:rickhobbs
Comment Utility
Unless you can find a friend that has all the old Citrix stuff, you are out of luck because it is EOL with no support.  I have all the Citrix releases and patches, but no way to get the files to you.
0
 

Author Comment

by:Nanosphere
Comment Utility
Unfortunately, nobody we know has dealt with Citrix, let alone keep an archive of updates...

We have an FTP server. Would you be willing to upload a copy of SP4 to it for us?

If not, i'm guessing we have no other option but to hope that the removal of the registry keys is a permanent enough fix to keep the Citrix server going.

Thanks for all your help so far.
0
 
LVL 22

Expert Comment

by:rickhobbs
Comment Utility
I would if it was allowed.  I am pretty sure it isn't.  You would need to provide an FTP login and password and the administrators here would definitely not let that happen.
0
 

Author Comment

by:Nanosphere
Comment Utility
Fair enough... It's anonymous ftp, but I'm not going to push it...

Registry key changes will have to do.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

CITRIX XENAPP 6.5 FARM CUSTOM POLICY - CHANGE MANAGEMENT WINDOW REBOOT SCHEDULE
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now