SSL Certificate Import in SBS 2011

I am doing a migration from SBS 2003 to 2011. I have followed the MS instructions to export my trusted SSL certificate from the old server and copied it to the new one.
If I browse to the Computer Personal Certificate store I can see the certificate in there, however when I run the Add a Trusted Certificate Wizard and browse for certificates it does not appear in the list.
Any ideas?
LVL 12
nealerocksAsked:
Who is Participating?
 
nealerocksConnect With a Mentor Author Commented:
I managed to get around it by installing it directly into exchange rather than the wizard.
0
 
Cliff GaliherCommented:
Exporting and importing is tricky. You have to get the private key, get it in the right store, get the system *exactly* as expected for the wizards. Time consuming and error prone. Skip it. Use the certificate to generate a new CSR (and, by proxy, private key), then use the "rekey" option of your public CA to generate a new certificate. Rekeying is free, as far as SBS is concerned, you used the wizards as intended, and it is almost foolproof for a successful cert. Much better than the export/import game.

-Cliff
0
 
nealerocksAuthor Commented:
Thanks for the suggestion. I will give this a go tomorrow.
0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

 
nealerocksAuthor Commented:
I generated a new CSR request and rekeyed my certificate but it still doesn't appear in my Add a trusted certificate wizard.
0
 
Cliff GaliherCommented:
HOW did you generate the new CSR?
0
 
nealerocksAuthor Commented:
I used the new exchange certificate from the exchange 2010 management console
0
 
Cliff GaliherCommented:
No. Stick to the SBS wizard. Use the add trusted certificate wizard to generate the CSR (the first option in the wizard) then rekey with that CSR, then rerun the wizard to import the cert (the second option in the wizard.) it is designed to be run twice and manages properly pairing public and private keys. By skipping the first run during the CSR phase, you are just confusing the wizard.

-Cliff
0
 
nealerocksAuthor Commented:
Figured it out myself.
Thanks for the suggestions.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.