Solved

Some Computers are not showing in the WSUS Console

Posted on 2011-09-27
9
570 Views
Last Modified: 2012-05-12
Hi Guys,

My WSUS server is running on Windows Server 2008 R2 64-bit OS.

I have a WSUS GPO that is linked to one of the OUs for testing.

However when i went to the WSUS console, i can only see a few computers there. The rest are not visible.

Could anyone advise what is the cause of this? I am puzzled because all these computers are under the same OU.

Looking forward to your advice.

Thanks!
Thomas
0
Comment
Question by:Gapseudo081
  • 3
  • 3
  • 3
9 Comments
 
LVL 39

Assisted Solution

by:Krzysztof Pytko
Krzysztof Pytko earned 125 total points
Comment Utility
Have you verified if those computers got WSUS GPO?

run RSoP.msc and check that

if not run

gpupdate /force
or reboot machine

You shoudl verify if WSUS services are running

restart them to be sure that everything is fine

net stop bits
net stop wuauserv

net start wuauserv
net start bits

wuauclt /detectnow /resetauthorization

Or try to force WSUS agent install. First, download it from
http://go.microsoft.com/fwlink/?LinkID=91237

and in command-line on a workstation run

WindowsUpdateAgent30-x86.exe /wuforce

and check once again

Regards,
Krzysztof
0
 
LVL 37

Accepted Solution

by:
Neil Russell earned 125 total points
Comment Utility
Have these computers been cloned or has the OS been installed from fresh?

You could try doing the following:

in a command prompt do...

net stop bits
net stop wuauserv
cd “%windir%
rmdir /s SoftwareDistribution
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v AccountDomainSid /f
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v PingID /f
REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate" /v SusClientId /f
net start wuauserv
net start bits
wuauclt /resetauthorization /detectnow
0
 

Author Comment

by:Gapseudo081
Comment Utility
Krzysztof i have already done gpupdate /force once i set the WSUS GPO. When i went to the WSUS server and opened up the WSUS console, i can only see 3 computers from the OU. The rest could not be seen.

When you mention to check if the WSUS services are running, do you mean on the end-users machine?

Just a point to note, some users are on Windows XP while some are on Windows 7.

Thanks!
Thomas
0
 
LVL 39

Expert Comment

by:Krzysztof Pytko
Comment Utility
Yes, I meant WSUS service on clients :)

That's not important if there are XP or 7
WSUS client works on both of them and should report to WSUS server without any problem. Please wait (let's say 1-2 day) and check if they appeared. If not, we need to worry a little :) and figure out what is the reason.

Krzysztof
0
Free book by J.Peter Bruzzese, Microsoft MVP

Are you using Office 365? Trying to set up email signatures but you’re struggling with transport rules and connectors? Let renowned Microsoft MVP J.Peter Bruzzese show you how in this exclusive e-book on Office 365 email signatures. Better yet, it’s free!

 
LVL 37

Expert Comment

by:Neil Russell
Comment Utility
You did not answer if the machines are cloned from an image? IF yes then its a know problem with WSUS and the fix I gave above will address this.
0
 

Author Comment

by:Gapseudo081
Comment Utility
Neilsr, yes the machines are cloned from an image.

Do i run the fix line by line in the command prompt of the user's machines?

Thanks!
Thomas
0
 
LVL 37

Expert Comment

by:Neil Russell
Comment Utility
Yes on the users machines. Copy and paste that lot into a script, say   Fixwsus.cmd  and then just run that on each machine thats affected.

WSUS creates a unique SID for talking to the wsus server. IF two or more machines have that same SID, can happen after a clone, then you will only see ONE of those machines in the WSUS console.
0
 

Author Comment

by:Gapseudo081
Comment Utility
Neilsr i have a question though, of all the 15 computers which i should see, i am only seeing 3. And of these 3, 2 of them are cloned machines..how is it that i can see these 2 clone machines and not the others who were cloned from the same image?
0
 
LVL 39

Expert Comment

by:Krzysztof Pytko
Comment Utility
Hi, what is the status of your issue? Can we help somehow in this topic? Thanks for the answer.

Krzysztof
0

Featured Post

Too many email signature changes to deal with?

Are you constantly being asked to update your organization's email signatures? Do they take up too much of your time? Wouldn't you love to be able to manage all signatures from one central location, easily design them and deploy them quickly to users. Well, you can!

Join & Write a Comment

I had a question today where the user wanted to know how to delete an SSL Certificate, so I thought that I would quickly add this How to! Article for your reference. WHY WOULD YOU WANT TO DELETE A CERTIFICATE? 1. If an incorrect certificate was …
Resolve DNS query failed errors for Exchange
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now