Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Outlook 2007 blocks Russian characters

Posted on 2011-09-27
6
1,143 Views
Last Modified: 2012-05-12
I use an English version Outlook 2007 for writing e-mails in English and Russian. When I write e-mails in Russian, I use a Russian / Cyrillic keyboard in Windows XP which produces Russian characters.
I switch the keyboard from English to Russian in the system tray.

Since last week Outlook seems to block Russian characters. In all other Windows applications the Russian keyboard works fine and in Outlook the English keyboard works without problems. But when I switch to the Russian keyboard in the Outlook editor, nothing happens when I press keys on my keyboard.

When I start Outlook in safe mode the Russian keyboard works without problems. But in normal mode nothing happens, so there must be a process that actively blocks Russian characters.
I re-installed Outlook 2007 and I temporarily disabled all the add-ins, but that did not solve the problem.

Has anyone suggestions how to solve this problem ?
0
Comment
Question by:Backboon
  • 3
  • 2
6 Comments
 
LVL 6

Expert Comment

by:rknetwork
ID: 36816396
0
 

Accepted Solution

by:
Backboon earned 0 total points
ID: 37171713
My client was in Russia for a long time so I could not test possible solutions for this problem.
When he returned to the Netherlands I investigated the problem again.

I discovered the following:

1. The Russian keyboard works in all applications, except the Outlook 2007 editor
2. When you start to type in the Outlook editor, Russian letters appear in the e-mail.
3. When you pause a little bit, Russian letters appear to be blocked
4. However, when you press a key that is not  connected with a Russian letter (0/9, Space, Backspace) the block is lifted
5. So you can write Russian, but it's tricky. Once the keyboard is blocked, you have to use Space and then Backspace key to lift the block and continue typing

My conclusion is that the problem is caused by (the timing) of the keyboard driver for the Russian letters, in conjunction with the Outlook editor. I installed newer drivers, but this did not solve the problem.
The client is satisfied with the work around
0
 

Author Closing Comment

by:Backboon
ID: 37194300
There was only one answer and it was not the solution. I want to close this question because my client is satisfied with the work around I discovered.
0
Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

 
LVL 6

Expert Comment

by:rknetwork
ID: 37172095
I don't agree, probably the user just used some similar solution to mine and wants to close question without loosing any points. I request my 250 points please.
0
 

Author Comment

by:Backboon
ID: 37187884
Hi rknework,

I carefully read the solution in link you gave me. It says:

Try this:

Right click the taskbar at the bottom, select Toolbars->Language Bar. Then go into one of the applications where the symbols are correct (Excel, notepad, whatever). Click on the little language button in the language toolbar, and see what language it's set to. Then go into Outlook, and click that button again. It's likely that it will be set to some other language. Change it to the proper language (it's probably currently set to US english, if the spanish layout isn't working, but it could be something else too), and you should be good to go.

While you're at it, right click on the language bar, go to Settings, choose Key Settings under the Preferences group, and get rid of all those default Key Sequences (set them to none). I've had it happen to me occasionally (and I'm sure I've seen a previous AskMeFi question about it) where you hit those key sequences and change your language without realizing it.


I tried this solution, but it did not solve the problem.
The problem is not that the keyboard changes to another language when I go into Outlook 2007, but that keys are blocked. This happens only under certain circumstances:

1.      It only happens in the Outlook 2007 editor
2.      It only happens after a little pause in typing.
3.      It only happens with keys that are connected to Russian symbols (B = ¿, C = ¿, etc)
4.      The block is lifted after pressing a key which is NOT connected to a Russian symbol (space, backspace, 0 – 9)
5.      When I start Outlook 2007 in Safe Mode, it does not happen

So I think there must be some timing problem in the keyboard driver for Russian Typewriter Custom that only surfaces in the Outlook 2007 editor.

I downloaded the keyboard driver from a Dutch University website for Russian Studies
http://hum.leidenuniv.nl/russischestudies/studiemateriaal/digitaal-studiemateriaal.html#computer 

Of course I could test it on another computer with Windows XP SP3 and Outlook 2007, but my client does not want me to spend more time (and money) on this problem because the workarounds are sufficient to write e-mails in Russian.
0
 

Expert Comment

by:dnevnik
ID: 37624479
1. Try to remove 3rd-party add-ins in Outlook
2. Try to uninstall any Outlook-related applications, f.e. SysTools PST Upgrade that is used for .PST files upgrade from ANSI to Unicode
0

Featured Post

What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Outlook Free & Paid Tools
When you have clients or friends from around the world, it becomes a challenge to arrange a meeting or effectively manage your time. This is where Outlook's capability to show 2 time zones in one calendar comes in handy.
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question