Exchange 2010 Mailbox Junk Email Configuration

Hi Guys, i am attempting to disable a users` JunkMail on a mailbox but i am getting the error below.  Any ideas?

I run this PS command:
Set-MailboxJunkEmailConfiguration -Identity USERNAME -TrustedSendersAndDomains @() -Enabled $False

Which gives this result:
Junk e-mail validation error. Value: 'name@site.com'.
    + CategoryInfo          : NotSpecified: (0:Int32) [Set-MailboxJunkEmailConfiguration], JunkEmailValidationExceptio   n
    + FullyQualifiedErrorId : C7534409,Microsoft.Exchange.Management.StoreTasks.SetMailboxJunkEmailConfiguration

It looks as if the ' ' in the email address is the issue as the other email addresses does not have this.

I also get an error when trying to modify it via OWA.
LVL 4
PietMuisAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
PietMuisConnect With a Mentor Author Commented:
Found the solution here
http://www.exchangeinbox.com/article.aspx?i=78&t=3&p=2

10.
If running Outlook 2003, we will typically be able to immediately identify the entry of interest from the subject 'Junk E-mail Rule' as shown below.

However if we don't see any of the rules with this subject (as is the case for OWA users) we can still identify the rule from its properties:
 1.
From the upper pane select the item to inspect. The lower pane will list the properties for the selected item.

 2.
Scroll through the properties looking at the 'Value' column. The Junk E-mail Rule will have one value reading 'JunkEmailRule' without any spaces between words.

 3.
If found, we almost certainly identified the rule. As a further confirmation, look for the property named PR_MESSAGE_CLASS and make sure this is set to the value IPM.ExtendedRule.Message
 
11.
Once identified, make sure the Junk E-mail Rule is selected and from the title menu select Actions | Delete Message.

 12.
This will open the Delete Item dialog. From here change the selection to 'Permanent delete passing DELETE_HARD_DELETE (unrecoverable)' and click OK.
 
13.
The Rule is now deleted. We can close the MAPI Editor.

0
 
gaurav05Commented:
0
 
PietMuisAuthor Commented:
Sorry gaurav05, that does not help me in any way.
0
Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

 
James HIT DirectorCommented:
This is the correct syntax to disable a users JunkMail.

Set-MailboxJunkEmailConfiguration -Identity "UserName" -Enabled $false
0
 
PietMuisAuthor Commented:
Hi Spartan, it returns the same error.
0
 
James HIT DirectorCommented:
Are you typing in email address or alias?
You should be putting in alias.... Set-MailboxJunkEmailConfiguration -Identity support -Enabled $false

I ran this command on my box with a live account and I had no issues applying this.
0
 
PietMuisAuthor Commented:
I can run it on other users but I have 3 users that I have an issue with, the one I posted here has a safe sender in the list of email addresses in the format 'name@site.com' with '' where the other email addresses does not have the ''... hope i am making sense?

0
 
James HIT DirectorCommented:
Have you looked at this link?

http://technet.microsoft.com/en-us/library/dd979780.aspx

Specifically example 2 may be what you are looking for.
0
 
PietMuisAuthor Commented:
Hi Spartan, I would like to remove the 'john@gmail.com' entry...

To get the details of username i run...
get-MailboxJunkEmailConfiguration -Identity username

It returns:
RunspaceId               : cff082f1-931f-49cf-88c9-1e6e6862a93c
Enabled                  : True
TrustedListsOnly         : False
ContactsTrusted          : True
TrustedSendersAndDomains : {'john@gmail.com', abraenco@neemg.com, accounts@gamil.com...}
BlockedSendersAndDomains : {vgreef@mgf.com}
MailboxOwnerId           : ...
Identity                 : ...
IsValid                  : True


Then say i would like to add mary@gmail.com as a trusted sender i run:

Set-MailboxJunkEmailConfiguration -Identity username -TrustedSendersAndDomains "mary@gmail.com"

It then returns:
Junk e-mail validation error. Value: 'john@gmail.com'.
    + CategoryInfo          : NotSpecified: (0:Int32) [Set-MailboxJunkEmailConfiguration], JunkEmailValidationException
    + FullyQualifiedErrorId : C7534409,Microsoft.Exchange.Management.StoreTasks.SetMailboxJunkEmailConfiguration


I some way the 'john@gmail.com' email address in the list of trusted senders have ' ' and the other do not have it. I think that is the issue but no idea how to resolve...
0
 
James HIT DirectorCommented:
This is what I was able to do in this scenario:

Get-MailboxJunkEmailConfiguration -Identity username -TrustedSendersAndDomains <email1>,<email2>,etc... -Enabled $true

Just don't type the gmail address in that statement and it will not appear in the TrustedSendersAndDomains.

0
 
James HIT DirectorCommented:
Sorry... Set not Get

Set-MailboxJunkEmailConfiguration -Identity username -TrustedSendersAndDomains <email1>,<email2>,etc... -Enabled $true
0
 
PietMuisAuthor Commented:
Spartan, it is still giving me the same message - complaining about - 'john@gmail.com'

I am sure the issue is the ' ' around 'john@gmail.com'.
0
 
PietMuisAuthor Commented:
http://answers.microsoft.com/en-us/office/forum/office_2010-outlook/exchange-junk-mail-configuration-not-functioning/485f7dbb-8988-4911-9029-055eecbae3f1

This seems to be what i need to do, but when i login via MFCMAPI i do not see the junkmail rule under the "Associated Contents Table" - any ideas?
0
 
PietMuisAuthor Commented:
Resolved myself
0
All Courses

From novice to tech pro — start learning today.