Exchange 2010 Transaction Log Files filling up


Hi,

I have Exchange 2010 running on Windows 2008 R2.
The issue Im having is that the transaction logs are filling up fast.

it is save to use Enable Circular Logging and How can use
etwalttech2011Asked:
Who is Participating?
 
PradeepConnect With a Mentor Commented:
Circular logging rewrites the logfiles instead of creating new logs once they are commited.
You can find circular logging in storage group properties. Just check the box and restart the information store or dismount and mount the store once..
You also can do that using shell by running this command


Set-StorageGroup -Identity "First Storage Group" -CircularLoggingEnabled $true
0
 
PradeepCommented:
Also its not safe for using in production environment as if circular logging is enabled, you can recover data only up until the last full backup.
0
 
etwalttech2011Author Commented:
Hi,

still I don't have any backup solution and I used windows buckup but nothing  now after I use the above solution sure the Transaction Log Files cleaning and I can turn off when I finish just as a temporary solution

thanks
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
etwalttech2011Author Commented:

I cant take any backup for exchange so I can do it or no?
0
 
etwalttech2011Author Commented:
Navigate to the "Maintenance" tab
Below you’ll find-"Enable Circular Logging"
Go ahead and put a check mark next to it.
Click Apply
Unmount the store
Remount the store
*POOF* Log files are gone!
Noe again open “Maintenance” for same database
Below you’ll find-"Enable Circular Logging"
Go ahead and uncheck next to it.
Click Apply
Unmount the store
Remount the store
0
 
AkhaterCommented:
Do not enable circular loggin it is much neter to just backup using windows backup
0
 
PradeepCommented:
Ok., yes just uncheck the circular logging checkbox and restart information store or dismount and mount the store.
0
 
AkhaterCommented:
once again do not enable cicular logging  follow my article to backup up using the built in tool of windows

http://www.simple-talk.com/sysadmin/exchange/backing-up-exchange-2010-for-free/


if you still want to enable circulat logging run the below it should do all the steps for you

get-mailboxdatabase | set-mailboxdatabase -CircularLoggingEnabled:$true
restart-service msexchangeis
get-mailboxdatabase | set-mailboxdatabase -CircularLoggingEnabled:$false
0
 
etwalttech2011Author Commented:

please check the attached PIC


EX2.PNG
EX3.PNG
EX1.PNG
0
 
etwalttech2011Author Commented:

 I cant take backup I need fast soluotion for today
0
 
PradeepCommented:
then the circular logging is the way
0
 
AkhaterCommented:
you still have 63 gb you have nothing alarming, take a backup just follow my tutorial

if you don't want I gave you the commands to run

get-mailboxdatabase | set-mailboxdatabase -CircularLoggingEnabled:$true
restart-service msexchangeis
get-mailboxdatabase | set-mailboxdatabase -CircularLoggingEnabled:$false
0
 
etwalttech2011Author Commented:

it is save or maybe loss some emails & what your recommendation enabled circular logging and when I finish I disable or keep it enable
0
 
AkhaterCommented:
is it safe ? Not really, but you are safe as long as you don't have any crash

my recommandation is that you take a backup and not enable circular loggin at all, if you insist then run the commands i gave you
0
 
PradeepCommented:
Disable it, it was not recomended for production environments as if circular logging is enabled, you can recover data only up until the last full backup.
0
 
etwalttech2011Author Commented:

yesterday I have 125 GB and today 63 GB
0
 
PradeepCommented:
Enabling it is a temporary solution as said above take backup using windows backup utility ASAP
0
 
AkhaterCommented:
during all this time your backup wld have been runnig, your disk is only 400 gb

anyway, agian and again, it is YOUR decision, just run the commands i gave you
0
 
etwalttech2011Author Commented:

I will do it after 2h " end of day"

0
 
etwalttech2011Author Commented:

it is save to delete logs file by Manual as attached
just select the log and delete
Logs-file.PNG
0
 
AkhaterCommented:
no NEVER touch the files manually
0
 
PradeepCommented:
Yes as said above DONOT touch them.
0
 
etwalttech2011Author Commented:
Hi,

What you think if I install symantic Backup Exec 2010 R3 Trialware as a temporary solution.
0
 
etwalttech2011Author Commented:
Hi,

What you think if I install symantic Backup Exec 2010 R3 Trialware as a temporary solution.
0
 
AkhaterCommented:
why not just use the built-in backup solution ?? I gave you the link just follow it


http://www.simple-talk.com/sysadmin/exchange/backing-up-exchange-2010-for-free/
0
 
etwalttech2011Author Commented:
Hi,

i installed backup ecex 2010 R3 and running the job So, I'm wating the result
0
 
etwalttech2011Author Commented:
Hi,

the best solution is circular logging i reduce my size up to 300 GB

thanks all for support
0
 
AkhaterCommented:
Well the solution you accepted is wrong! There is no storage groups in exchange 2010
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.