Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

SQL Server 2008 R2 cluster can't start in single user mode

Posted on 2011-09-27
10
Medium Priority
?
647 Views
Last Modified: 2012-05-12
Hello,

I try to start SQL Server 2008 R2 cluster can't start in single user mode but I have this error (in the file).
How can I resolve it?
Thanks
bibi
sqlservr.bmp
0
Comment
Question by:bibi92
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
10 Comments
 
LVL 30

Expert Comment

by:Rich Weissler
ID: 36709150
Did you open your command prompt in administrator mode (assuming you are running Windows 2008)?
Did you confirm that SQL is stopped in the Cluster Administrator?
0
 

Author Comment

by:bibi92
ID: 36709318
Yes, thanks
0
 
LVL 5

Expert Comment

by:AlokJain0412
ID: 36709490
using these steps exactly:

1)From Cluster Administrator: stop the cluster service for the failover node
2)From Cluster Administrator: take the SQL Server resource offline
3)From SQL Server Configuration Manager: add the startup parameters -c;-m;-T3608
4)From Cluster Administraror: bring the SQL Server resource online again

completely stop the failover node..

0
What Is Blockchain Technology?

Blockchain is a technology that underpins the success of Bitcoin and other digital currencies, but it has uses far beyond finance. Learn how blockchain works and why it is proving disruptive to other areas of IT.

 
LVL 30

Expert Comment

by:Rich Weissler
ID: 36709523
... and are there any relevant messages in the Windows System, Windows Application, or SQL Errorlogs?
0
 

Author Comment

by:bibi92
ID: 36710560
Ok I have tried these steps :

1)From Cluster Administrator: stop the cluster service for the failover node
2)From Cluster Administrator: take the SQL Server resource offline
3)From SQL Server Configuration Manager: add the startup parameters -c;-m;-T3608
4)From Cluster Administraror: bring the SQL Server resource online again
But when I try to acess with SSMS : I have this error messsage :
Login Failed for user sa. Reason Server is in single user mode.

Thanks
bibi

0
 
LVL 30

Expert Comment

by:Rich Weissler
ID: 36711236
Can you access the server with sqlcmd instead of SSMS?  In the past, I've had additional challenges with SSMS because it attempts to simultaneously open multiple connections to the database server simultaneously.
0
 

Author Comment

by:bibi92
ID: 36712924
No, with SQLCMD, I have the same message.
Thanks
bibi
0
 
LVL 30

Expert Comment

by:Rich Weissler
ID: 36713912
Instead of just -m, change that parameter to -m"sqlcmd" then try to connect with SQLCMD.

And to make certain we are on the same page concerning the nature of the issue, and to confirm assumptions:  I believe the database engine is starting in single user mode.  You are unable to connect to that instance of SQL while in single user mode because another process is connecting to that instance before you can.

If you can't get the -m"sqlcmd" parameter to work, the next option would be to figure out what could be grabbing that connection.  
Are there any other local services on that server which are still running which might be attempting to reestablish a connect to the SQL box?  Can you disable those if there are?  
If the only connections are coming through the network, is disabling network communication to the box an option?  (Either by disabling protocols to SQL via Configuration Manager.)
Are you able to open the ERRORLOG files for this database instance?  (Should be accessible via notepad, and might give a clue what the database engine is doing when it comes up.)
0
 

Author Comment

by:bibi92
ID: 36714616
-m"sqlcmd" doesn't work but I think the problem is clussvc service.

Regards

bibi
0
 
LVL 5

Accepted Solution

by:
AlokJain0412 earned 2000 total points
ID: 36714760
When starting SQL Server in single user mode, and specifying that you will only allow connections over sqlcmd.exe, you must use ALL CAPS.

sqlservr.exe /c /m"SQLCMD"

Please Check It
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Delta outage: 650 cancelled flights, more than 1200 delayed flights, thousands of frustrated customers, tens of millions of dollars in damages – plus untold reputational damage to one of the world’s most trusted airlines. All due to a catastroph…
Ready to get certified? Check out some courses that help you prepare for third-party exams.
Viewers will learn how to use the INSERT statement to insert data into their tables. It will also introduce the NULL statement, to show them what happens when no value is giving for any given column.
Viewers will learn how to use the SELECT statement in SQL to return specific rows and columns, with various degrees of sorting and limits in place.

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question