Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 688
  • Last Modified:

Wordpress Widgets dont move or work ? WordPress 3.2.1.

Hi, I have installed Wordpress locally on a Win7 Pro PC running Xampp/MySql.

It all installed fine but i cannot move any of the widgets ?

I get the cursor turning to a cross when hovering over a widget but cannot move anything.

Also the widget areas dont drop down ? For Example if i click on the down arrow on one of the widget areas it does not do anything. If i click on the text that says widget area it does not drop down ?

I did have a genesis theme installed along with a couple of genesis plugins but i have removed all of the plugins and theme and it now only has the default template/theme.

I have also reinstalled wordpress via the updates link in the back and get a successful message but still can't move widgets.

Thank you for your time.
0
rookeydooks
Asked:
rookeydooks
  • 3
  • 2
2 Solutions
 
rookeydooksAuthor Commented:
UPDATE !

Bizarely now Widgets work ?! I left it for lunch and when i came back they work.

I loaded teh Genesis & Studio Press Theme and Widgets stopped working. I removed them and they work fine.

Looks like there is an issure with WordPress 3.2.1. & Studio Press/Genesis Themes.
0
 
gwkgCommented:
Everytime I've run into that problem it was a javascript/jquery issue.  Check the javascript console in whichever browser you are using for an error.

Im not sure how far you want to dig into the code, but one specific thing I noticed on a couple sites I admin was that if I was unregistering jquery and reregistering it from a different url, I had to make sure that it wasn't done on admin pages.

In other words...

    if ( ! is_admin() ) {

      wp_deregister_script(  'jquery'  );
        wp_register_script(  'jquery', 'https://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.min.js' );
        wp_enqueue_script(  'jquery'  );
       
    }

Are you using one of the older themes from StudioPress?  I think if you are having an issue with a newer theme, it would be all over their message board and a fix would be coming quickly..
0
 
rookeydooksAuthor Commented:
Hi qwkg, many thanks for your reply.

I am not familiar with the javascript console. The Themes i have tried are the Education and Mocha along with Genesis.

As soon as i activate any of the themes the widgets page stops working. I also only have 3 widget areas avaialble on the right hand side.

Header Right
Primary Sidebar
Secondary Sidebar

Where would i fine the Wordpress Javascript Console to unregistering jquery and reregister ? And woudl i just copy, paste and run the code yuo have provided in your previous post ?

Thank you for your time.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
gwkgCommented:
That code would go in your functions.php file wrapped in another function that got called by an action hook.  But adding that won't fix your problem so I won't waste your time explaining it =)

The javascript console is part of your browser.

With the page open in IE9 press F12 then click on the Console tab then reload your page.  See if there is an error message.
0
 
rookeydooksAuthor Commented:
Hi qwkg, sorry for the delay in getting back to you.

I couldn't install IE9 on my Vista 32bit PC, kept saying i didn't have the corect service pack yet when i tried to run a windows update it was telling me no updates available !

Anyway, i have used a new WIn7 PC with IE9 and loaded up the site and pressed F12. Icouldn't find any errors so logged in to admin and the widgets all worked correctly on the WIN7 PC and IE9.

I then went back to my Vista PC and they are now working on that system too.

Could logging in on the WIN7 and IE9 fixed anything ?

Weird but happy its all working now.

Thanks for all your help with this, i really appreciate you taking the time to offer your advice.

Cheers.
0
 
James-WiseCommented:
gwkg,

I am having the same problem but adding this code to the functions.php did not solve it.

this happened after an update to wordpress 3.5
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now