• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4756
  • Last Modified:

Citrix WMI Service Errors

Win2008R2
Citrix Xenapp Fundamentals 6.0
2nd rebuild of the server due to issues with the config and networking. The computer is activated with Microsoft and terminal services worked well untill we installed Xenapp Fund.


We have licenced our citrix server to the hill and back with citrix and terminal services licences.

In the quick start the licences are there. Everything shows as being good but the event viewer shows this

Log Name:      Application
Source:        Citrix WMI Service
Date:          9/27/2011 10:47:40 AM
Event ID:      3
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      CITRIX.domian.local
Description:
The license check for MgmtProv.dll failed, it will therefore not be available until a valid license is provided.

The license check for MgmtEventProv.dll failed, it will therefore not be available until a valid license is provided.

The license check for MetaFrameProv.dll failed, it will therefore not be available until a valid license is provided.

The license check for MetaFrameEvProv.dll failed, it will therefore not be available until a valid license is provided.

The license check for CitrixFarmProv.dll failed, it will therefore not be available until a valid license is provided.

The license check for CitrixEvProv.dll failed, it will therefore not be available until a valid license is provided.

The license check for MgmtProv.dll failed, it will therefore not be available until a valid license is provided.


This machine also closes down the remote desktop service after a while. Causing no users or admins to be able to login. Reboot and the problem is solved but this is no way to run a server.

We have another box running Win2k3 ENT with Citrix XEN App Fund 3.0. Not one issue with the box. Runs like a rock.

Please help.
0
crawfordit
Asked:
crawfordit
  • 9
  • 7
1 Solution
 
Carl WebsterCommented:
Check this Citrix KB out for recommended hotfixes:

http://support.citrix.com/article/CTX129229
0
 
crawforditAuthor Commented:
@CarlWebster

Should I apply all the patches? I was under the impression that you should only apply patches to machines that need it.

Of course I am new to this so I will bow down to anyone with more knowledge then me.
0
 
Carl WebsterCommented:
Look at the list of recommended hotfixes, apply those that are for security issues and only the rest that fix specific issues you have.  I think Citrix support is saying the hotfixes in that article are the minimum they recommend that should be installed.  There are, IIRC, about 90+ hotfixes available for XenApp 6!  I now recommend people use XenApp 6.5 instead of XenApp 6.  I now call XenApp 6, XenApp Vista! :)
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 
crawforditAuthor Commented:
@CarlWebster

When I did the rebuild of this box I looked for 6.5 Xenapp Fundementals but it was just not availble to me for download.

Thanks for the advice I will be trying it shortly.
0
 
Carl WebsterCommented:
You are correct, there is no 6.5 Fundamentals.  I have asked to see if there will be one.  I'll let you know what I hear.
0
 
Carl WebsterCommented:
There are currently no plans to offer Fundamentals 6.5 at this time.  But this is Citrix, plans could change tomorrow! :)
0
 
crawforditAuthor Commented:
One last question. The fixes that are applied for XenApp 6.0 apply to Xenapp Fundamentals 6.0? I would hate to make the leap but I would rather be sure before applying it. Cause the link is for XenApp 6.0 not Fundamentals.

If they are the same great if not I think I will dig deeper then apply patches blindly.
0
 
Carl WebsterCommented:
Some of the hotfixes apply to Fundamentals.  You will have to go to the page for each hotfix, scroll down to the bottom and verify.
0
 
crawforditAuthor Commented:
Crap now the licencing server doesn't want to start. Error 1067.
0
 
crawforditAuthor Commented:
BTW all Fundamentals patches are installed
0
 
Carl WebsterCommented:
There is a hotfix specifically for hotfixes breaking licensing.
0
 
crawforditAuthor Commented:
Its a registry patch and I applied it. It did nothing.
0
 
Carl WebsterCommented:
Then reinstall the licensing component.
0
 
crawforditAuthor Commented:
FYI
Reinstalled the license server from the dvd.
It seemed to double our license count but its functional.

 I still get the WMI errors in the event viewer.

So far today it has been stable but the problems don't start to show till after a few days of being active.

If its a matter of some event viewer errors I am not worried. At this point I am thankful not to have to rebuild it.

On a side note when users with domain admin rights login they get a administrator folder with there published apps. Is there a way I can make that go away or loose the icons that are in this folder?
0
 
crawforditAuthor Commented:
ANOTHER Update ..rebuilt the server from scratch. I then installed all Microsoft updates and put back all applcations. Then installed SEN APP FUND 6.0 Then I installed all patches on the link recommended. The server so far it seems stable. I would run into remote desktop services failing by now.

If this lasts for the week I will consider the matter closed. Guess I can live with some log errors from some complaining DLL's
0
 
crawforditAuthor Commented:
I was already doing patch work it was a matter of finding the right order.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 9
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now