CF data connection error

I am trying to setup my data source on a new computer through CF.  I get the error you see in the image.  I made sure my Java runtime is up to date.  Anybody have any ideas?

Thanks,
John Error
JohnMac328Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
_agx_Connect With a Mentor Commented:
So what setup do you have now?  You deleted all the old dsn's and created a new one with the 32bit odbc tool? Does it even verify through odbc?

      ie C:\Windows\SysWOW64\odbcad32.exe
0
 
erikTsomikSystem Architect, CF programmer Commented:
0
 
JohnMac328Author Commented:
Tried both suggestions - no luck
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
erikTsomikSystem Architect, CF programmer Commented:
did you restart a coldfusion afterwards
0
 
JohnMac328Author Commented:
Yes
0
 
_agx_Commented:
As mentioned, enabling RDS will do the trick. But ... you don't really need to use the applet. Simply enter the path to your file manually.  That works fine.
0
 
_agx_Commented:
   >> As mentioned, enabling RDS will do the trick.

FYI they don't advise doing that on prod servers. My recommendation is enter the path manually.
0
 
JohnMac328Author Commented:
I tried that - I found this which I will try now - seems to be a problem with access 2010 64bit

http://www.cfexecute.com/post/access-dsns-in-64bit-coldfusion/
0
 
_agx_Commented:
Oh, yeah.  Connecting to Access 2010 64bit is a totally different problem.
0
 
JohnMac328Author Commented:
It took the manual setting but still has problems.  I setup the DSN with Access drivers like always - I am not liking 64bit

Error Executing Database Query.  
[Macromedia][SequeLink JDBC Driver][ODBC Socket]internal error: The specified DSN contains an architecture mismatch between the Driver and Application  
0
 
JohnMac328Author Commented:
I guess I better get the IIS working first - it has a problem with asp pages also
0
 
_agx_Commented:
  > I am not liking 64bit

It is a pain at first ... learning all the quirks and tricks.  Unfortunately I've never set up 2010 64bit. So I can't help you there.
0
 
JohnMac328Author Commented:
No problem agx - what is driving me crazy is I have everything at home working fine for over a year - Win 7 - CF9 all 64bit and working fine.  Same thing at work and it's a mess - we just installed new computers yesterday.
0
 
_agx_Commented:
Ugh.  I hate when that happens.  I had something similar all last week. I was about ready to toss the computer in the trash at one point ;-)
0
 
JohnMac328Author Commented:
I hear ya - I found this and was very hopeful but the same thing

http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=13255
0
 
_agx_Commented:
Hm... I didn't realize there's both 32bit and 64bit versions of Access 2010...  Which are you using?
http://www.coldfusionmuse.com/index.cfm/2010/12/31/Access.on.64bit.ColdFusion
0
 
JohnMac328Author Commented:
New server and new computers - too much too fast.  Using the 32bit from your link and setting up the DSN through there gets the manual connection to work through CF - now on to getting asp pages to work through IIS 7 -

Thanks again
0
 
JohnMac328Author Commented:
It is Office 2010 64bit but your link made it work
0
 
_agx_Commented:
Ok. I was thinking it would be backward compatible, but wasn't sure. So thanks for satisfying my curiousity :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.