Solved

IIS7.5 Strange 500 Server Error

Posted on 2011-09-27
4
918 Views
Last Modified: 2012-05-12
Hi,

I'm running IIS7.5 on Windows Server 2008 in Integrated Pipeline Mode, running the app pool as 32 Bit, and .NET 4.

I'm getting a 500 Internal Server Error on this server. What is strange is that on my staging server with the same settings, the site works fine, but I get this 500 error on my production server.

It's also strange that the error is referring to something about ISAPI, but, honestly, I have no idea what that is and I'm almost positive I'm not using whatever this is.

Here's the error info:

Module: IsapiModule
Notification: ExecuteRequestHandler
Handler: AboMapperCustom-65629
Error Code: 0x800700c1

Thanks for your help.
0
Comment
Question by:infotechelg
  • 3
4 Comments
 
LVL 13

Accepted Solution

by:
khairil earned 500 total points
ID: 36711673
Hi,

Try,
Check IIS modules

1. Open IIS Manager.
2. Take server name node on tree pane on the left
3. On the middle pane, double click Modules icon
4. Check from the list is there any suspicious module - especially named as describe in error
5. Delete after taking details on it.

Check the Handler Mappings
1. Open IIS Manager.
2. Take server name node on tree pane on the left
3. On the middle pane, find and double click Handler Mapping
4. Find Handler that specify in error.
5. Take the details and delete.

0
 

Author Comment

by:infotechelg
ID: 36711716
Thanks, khairil.

I tried deleting the IIS Module, IsapiModule (%windir%\System32\inetsrv\isapi.dll) and received a "lock violation" error.

In the handler mappings, there are many ISAPI items listed. Do I try to delete them all?
0
 

Author Comment

by:infotechelg
ID: 36711825
Khairil,

I realized in the handler mappings, there was a specific reference to AboMapperCustom-65629, so I removed that from the list.

Now I'm getting a Default.aspx "has not been pre-compiled, and cannot be requested", which, is not true, because it is.

So, now what do I do? :)
0
 

Author Closing Comment

by:infotechelg
ID: 36711981
khairli, i just re-published the project and re-copied the "bin" files over to production and everything works. Thanks for your help!
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question