Solved

IIS7.5 Strange 500 Server Error

Posted on 2011-09-27
4
917 Views
Last Modified: 2012-05-12
Hi,

I'm running IIS7.5 on Windows Server 2008 in Integrated Pipeline Mode, running the app pool as 32 Bit, and .NET 4.

I'm getting a 500 Internal Server Error on this server. What is strange is that on my staging server with the same settings, the site works fine, but I get this 500 error on my production server.

It's also strange that the error is referring to something about ISAPI, but, honestly, I have no idea what that is and I'm almost positive I'm not using whatever this is.

Here's the error info:

Module: IsapiModule
Notification: ExecuteRequestHandler
Handler: AboMapperCustom-65629
Error Code: 0x800700c1

Thanks for your help.
0
Comment
Question by:infotechelg
  • 3
4 Comments
 
LVL 13

Accepted Solution

by:
khairil earned 500 total points
ID: 36711673
Hi,

Try,
Check IIS modules

1. Open IIS Manager.
2. Take server name node on tree pane on the left
3. On the middle pane, double click Modules icon
4. Check from the list is there any suspicious module - especially named as describe in error
5. Delete after taking details on it.

Check the Handler Mappings
1. Open IIS Manager.
2. Take server name node on tree pane on the left
3. On the middle pane, find and double click Handler Mapping
4. Find Handler that specify in error.
5. Take the details and delete.

0
 

Author Comment

by:infotechelg
ID: 36711716
Thanks, khairil.

I tried deleting the IIS Module, IsapiModule (%windir%\System32\inetsrv\isapi.dll) and received a "lock violation" error.

In the handler mappings, there are many ISAPI items listed. Do I try to delete them all?
0
 

Author Comment

by:infotechelg
ID: 36711825
Khairil,

I realized in the handler mappings, there was a specific reference to AboMapperCustom-65629, so I removed that from the list.

Now I'm getting a Default.aspx "has not been pre-compiled, and cannot be requested", which, is not true, because it is.

So, now what do I do? :)
0
 

Author Closing Comment

by:infotechelg
ID: 36711981
khairli, i just re-published the project and re-copied the "bin" files over to production and everything works. Thanks for your help!
0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Best training I should take for current job? IIS or RSA? 4 27
windows 10 versions 3 36
GPO not showing IE10 in GP Preferences 14 47
Unable to add new user to AD 2 24
Scenario:  You do full backups to a internal hard drive in either product (SBS or Server 2008).  All goes well for a very long time.  One day, backups begin to fail with a message that the disk is full.  Your disk contains many, many more backups th…
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question