Solved

This message has not been downloaded from the server - Exchange 2007

Posted on 2011-09-27
12
1,490 Views
Last Modified: 2012-05-12
Running Exchange 2007 all-in-one box. We've had a database crash and was repaired. Now the iPhone users are not getting full messages on their phones but rather a message: "This message has not been downloaded from the server" in the body of the message.

So far only did iPhone end steps:
turned off mail synch, turned it back on
removed the mailbox completely from the iPhone, same thing: messages before the crash show up OK, messages after are showing the message mentioned above.

Any help is much appreciated.

Marek
0
Comment
Question by:maredzki
  • 6
  • 5
12 Comments
 
LVL 6

Expert Comment

by:E_T_B
ID: 36711506
Does your desktop client remove messages after downloading?  Iphone's only download the header of the message until you open the mail.  If your desktop client has removed the message, the iphone can't download it.
0
 
LVL 12

Expert Comment

by:Deepu Chowdary
ID: 36711508
This issue is not particularly with Iphone.
This will arise with ur email setup.

If you have Outlook on ur desktop which is configured to delete messages from the server after downloading.
What happens is that the iPhone downloads the headers of all messages in the inbox, but only downloads the body of the messages from the server one at a time as you view them.

Meanwhile, if Outlook is open on ur desktop it is automatically downloading all new messages and immediately deleting them from the server.  The iPhone still shows the email headers in the inbox, but when you go to view the message it is unable to retrieve it from the server because it was deleted by Outlook .  So there is no way for the iPhone to get the message body because the message no longer exists on the server.

So to change this go to Tools--> Account settings -->  click your account --> Press REPAIR --> Check MANUALLY CONFIGURE SERVER SETTINGS OR ADDITIONAL SERVER TYPES option and click next.

In Repair E-mail Account screen go to More settings and then go to Advanced tab i.e last tab and in the end you will see a option LEAVE A COPY OF MESSAG ON THE SERVER.
Check it and keep the setting as you require.
Now you will not get that issue.
0
 
LVL 2

Author Comment

by:maredzki
ID: 36711581
Thanks for the replies, here is mine:

The iPhone is very rarely connected to iTunes/Desktop.

All of the emails that display this message are still available when viewing using OWA so there is no deletion happening.

Marek

0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 12

Expert Comment

by:Deepu Chowdary
ID: 36711681
Ok what about the Leave a copy option.. Is that checked..?
0
 
LVL 2

Author Comment

by:maredzki
ID: 36711775
Exchange9, sorry but I do not have that option in the Advanced tab of Outlook 2010.

Marek
0
 
LVL 12

Expert Comment

by:Deepu Chowdary
ID: 36712374
Go to Account Settings, double click on the POP3 account and go to More Settings
0
 
LVL 2

Author Comment

by:maredzki
ID: 36712450
I am not using POP3, it is all Exchange native connectivity with Outlook 2010.
0
 
LVL 12

Expert Comment

by:Deepu Chowdary
ID: 36712512
Ok, just go to file--> Acc settings--> select your account--> More settings --> advanced tab and see that option.
0
 
LVL 2

Author Comment

by:maredzki
ID: 36712544
Nope, here is what i see, img attached. adv settings
0
 
LVL 12

Expert Comment

by:Deepu Chowdary
ID: 36714294
I think you are not going to the actual location as mentioned :

Click file--> Acc settings--> a dropdown will come and again click Acc settings--> select your account--> More settings --> advanced tab and you can see Leave a copy option.
0
 
LVL 2

Accepted Solution

by:
maredzki earned 0 total points
ID: 36948951
This ended up being a corrupt information store database. Once I moved the mailbox to another store the message disappeared and the content is now displaying for new messages.

Thanks,
Marek
0
 
LVL 2

Author Closing Comment

by:maredzki
ID: 36975312
No other expert mentioned about a separate data store and that seemed to fix the problem.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
Read this checklist to learn more about the 15 things you should never include in an email signature.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question