Solved

.NET Framwork - older version needed for Media Center

Posted on 2011-09-27
7
292 Views
Last Modified: 2012-05-12
I was unable to update .Net Framework so I uninstalled, all versions as instructed, and reinstalled (per another EE solution) the version that was corrupt. Now Media Center will not open, saying it needs an older version to run.  Is there any issue in installing version v1.1 as well...I was under the impress that the newer version was sufficient.
0
Comment
Question by:MagsMcKinley14
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 37

Accepted Solution

by:
Neil Russell earned 300 total points
ID: 36712133
You can install all versions that you require, a bit like java.
0
 
LVL 40

Assisted Solution

by:Jacques Bourgeois (James Burger)
Jacques Bourgeois (James Burger) earned 100 total points
ID: 36712316
A newer version is usually sufficient, but not always, specially when you are talking of the first versions (1.0 and 1.1) that had some problems that were corrected later. For instance, the mail sytem classes were completely redesigned in version 2.0. The System.Data.OracleClient will disappear in a future version.

They do not do that much, but when Microsoft decides to remove something in the framework, they leave it in for another version, giving a warning to programmers to stop using it, and they remove it the following version.

So, if Media Center requires a class, method, or whatever that was in version 1.1 and was marked obsolete in version 2.0, versions 3.0 and over do not have that feature built-in anymore.

In such cases, the computer that uses the application needs the older version.
0
 
LVL 20

Assisted Solution

by:marsilies
marsilies earned 100 total points
ID: 36713103
.NET Framework 1.1 is a separate, older version of .NET . You'll need this to run certain older programs.

.NET Framework from 2.0 through 3.5 are cumulative, using the same common language runtime (CLR 2.0), which each version adding new features. You only need .NET 3.5 SP1 in order to run apps that use .NET 2.0 through 3.5 SP1.

.NET Framework 4.0 uses a new CLR (CLR 4), and thus is independent of the previous versions of .NET . You'll need to install this for certain new programs.

You can have the different versions installed on the same PC without issue. The program in question calls for the CLR that it needs.
http://msdn.microsoft.com/en-us/library/bb822049.aspx
http://stackoverflo
w.com/questions/2803434/does-the-net-framework-4-0-installer-include-the-net-framework-3-5
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 
LVL 40
ID: 36713335
@marsilies

Do not mix the CLR and the framework. The CLR is the runtime, it does not include all the classes in the framework. While the CLR remained constant between 2.0 and 3.5SP1, some classes had minor changes, between the versions, so there are a few instances where you also need to install an older version of the framework for some (few) applications to work.
0
 
LVL 20

Expert Comment

by:marsilies
ID: 36713416
@JamesBurger:

As I mentioned before, the subsequent versions of .NET 2.0 through 3.5 SP1 are cumulative. Not only do they share the same CLR, but each subsequent version includes all previous versions within that CLR. So .NET 3.5 SP1 includes .NET 2.0, .NET 2.0 SP1, .NET 3.0, .NET 3.0 SP1, .NET 3.5, .NET 2.0 SP2, .NET 3.0 SP2, and .NET 3.5 SP1.

Here's a Microsoft article detailing what's included in .NET 3.5 SP1:
http://msdn.microsoft.com/en-us/library/bb822049(v=vs.90).aspx

Note this sentence in the article:
There is no need to install any of the previous service packs if you installed the .NET Framework 3.5 or 3.5 SP1 because they are already included.
0
 
LVL 40
ID: 36713543
@marsilies

You are right. I did not see that one pass because all the versions were installed in sequence over the years on my development machines.

But I checked on a computer where only 4.0 was installed, and it has indeed 3 versions of some of the dlls in the GAC.

Thanks a lot. I always like to learn things like those.
0
 

Author Comment

by:MagsMcKinley14
ID: 36714271
Thanks guy...installed and updated .NET Frame v1.1 with no issues and Media Center now works.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

cPanel is a Unix based web hosting control panel that provides a graphical interface and automation tools designed to simplify the process of hosting a web site. cPanel utilizes a 3 tier structure that provides functionality for administrators, rese…
Step by step guide to Clean and Sort your windows registry! Introduction: Always remember: A Clean registry = Better performance = Save your invaluable time In this article we're going to clear our registry manually! Yes, manually! The e…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question