Solved

OWA 2003 and 2010

Posted on 2011-09-27
9
394 Views
Last Modified: 2012-05-12
I have user mailboxes on 2003 and a few on 2010 (testing phase). My mailbox on 2010 can send and receive emails no problem. But when I go to https://webmail.domain.com I get the OWA 2010 login screen but when I try to login nothing happens - just freezes.

When a user who has a mailbox on 2003 goes to the same link and is presented with the 2010 OWAlogon scrren and logs in they are then redirected to their OWA (2003 format).

How can I get it to work with users on 2010?
0
Comment
Question by:tolinrome
  • 6
  • 3
9 Comments
 
LVL 7

Author Comment

by:tolinrome
ID: 36713250
I think the problem may be that the redirection (legacy hostname?) redirects my logon credentials to the 2003 Echange Server and doesn tfind it there since its on 2010.
If this is the problem si there a way to not have it redirect for users who hav emailboxes on 2010?
0
 
LVL 16

Expert Comment

by:The_Kirschi
ID: 36715525
You are right.

It is recommend to create new OWA servername in DNS and on the Ex 2003 IIS that will be used to redirect requests to Ex2003 OWA and to change the IP for the current OWA url in DNS to point to the Ex2010. This way if you go to https://webmail.domain.com you will be connected to 2010 and if a mailbox still resides on 2003 it will be redirected to the 2003 OWA. There are lots of articles about it on the web. Just search for Exchange2003URL. For example this one:

http://www.zerohoursleep.com/2010/01/installing-your-first-exchange-2010-cas-or-the-truth-about-exchange2003url-part-1/

Hope this helps.
0
 
LVL 7

Author Comment

by:tolinrome
ID: 36717847
Did you mean inyour first sentence Ex 2010 instead of 2003?
"It is recommend to create new OWA servername in DNS and on the Ex 2003 IIS"
0
 
LVL 16

Expert Comment

by:The_Kirschi
ID: 36719076
No, i meint 2003. This way you will Be able to use the old webmail URL during Migration and also afterwards. Users will connect to old URL but get to 2010. If Mailbox IS on 2010 they get their owa site. If not, they will Be redirected to the newly created URL which Points to 2003 and get their owa page from there. You just Need the newly created URL set as Exchange2003Url in 2010.
0
Are your end users making ugly email signatures?

Have you left it up to your end users to create their own email signatures? Are they forgetting to add the company logo or using garish font colors? Take control and ensure all users have the same email signature.

 
LVL 7

Author Comment

by:tolinrome
ID: 36771688
I think I've already done all that? I have the legacy domainname URL that redirects clients from 2010 OWA to 2003 OWA when they use the current https://webmail.domain.com -

On 2010 CAS OWA properties I have the external URL as https://webmail.domainname.com - which is the same URL 2003 users use to access OWA.

What specifically do I need to do? I feel that it's a simple thing but I just cant get it.

Thanks for understanding.
0
 
LVL 16

Expert Comment

by:The_Kirschi
ID: 36813488
Exchange2003URL is different from External URL. Have a look at this article:

http://technet.microsoft.com/en-us/library/ee332348.aspx

Especially look at the section "Installing Exchange 2010" and there number 4 and 5. You need to specify the Exchange2003URL through Exchange Management Shell as explained there. You can verify the setting via this command:

Get-OwaVirtualDirectory "<CAS-Servername>\OWA*" | fl Exchange2003Url

If you want to access OWA from outside your company LAN, i. e. Internet, you need to configure your firewall to match the changes. If you need help for this, please let me know.
0
 
LVL 7

Author Comment

by:tolinrome
ID: 36815124
I was reading that exact article, thanks. Ok, I used that command on the 2010 server and the Exchange2003Url is the legacyhostname, its the URL that redirects to the 2003 Exchange server. So redirection seems to be working fine, I remember setting that up a while ago. When 2003 mailbox users log into OWA they are presented with the 2010 OWA login screen and when loggin gin you cnasee the URL as the legacy hostname, so thats working fine.

I noticed on my firewall that I still had the primary mail.domainname.com pointing to the Exchange 2003 server and when I pointed it to the 2010 Exchange server I was able to receive email from RPC\HTTTP, my mailbox is on 2010 - but then when I went to https://webmail.domain.com it didnt work.

So this is the status:

currently mail.domainname.com is pointing to Exchange 2003 Server in firewall
active sync is working for mailboxes on 2003 and 2010
OWA works internally and externally for 2003 mailbox users only
OWA doesnt work at all for 2010 users although they are presented with the 2010 logon screen
Exchange 2010 mailbox users cannot use RPC\HTTP, but when I switch mail.domain.com to the 2010 Exchange server in the firewall then they can (had to switch it back to 2003 Exchange server).

I know it's just a little tweaking and I'll have it, thanks for all your help!!!
0
 
LVL 7

Accepted Solution

by:
tolinrome earned 0 total points
ID: 36943770
this solved the problem.
Set-OwaVirtualDirectory -identity "Owa (Default Web Site)" -LogonAndErrorLanguage 1033
Set-OwaVirtualDirectory -identity "Owa (Default Web Site)" -DefaultClientLanguage 1033
0
 
LVL 7

Author Closing Comment

by:tolinrome
ID: 36972704
I answered my own question.
0

Featured Post

Are end users causing IT problems again?

You’ve taken the time to design and update all your end user’s email signatures, only to find out they’re messing up the HTML, changing the font and ruining the imagery. What can you do to prevent this? Find out how you can save your signatures from end users today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
This video discusses moving either the default database or any database to a new volume.

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now