Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

issues with password protected worksheets that are referenced

Posted on 2011-09-27
5
Medium Priority
?
217 Views
Last Modified: 2012-06-27
We have a user that has been having issues with Excel 2007 on Windows 7. It has been crashing with the sheets she is working with. We gave her a new machine with nothing installed but Office and still have the same issues.

So we have upgraded her to Office 2010, but now have a new issue. When she opens Excel workbook (2003 file type .xls) the referenced cells will not work properly. Instead it says #REF!

In Excel 2007 by default it will not update the workbook links, and gives you the option to update them. In Excel 2010 however even though it still gives you the option to update the links or not, I will still get the #REF! error even if I leave them disabled.

How can I correct this?
0
Comment
Question by:ryan80
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
5 Comments
 
LVL 13

Expert Comment

by:BCipollone
ID: 36712976
Hmmm could be blocked.  In 2010 they added some protection things inside  File>Options>Trust Center>Trust Center Settings>File Block settings

Uncheck everything in there.  You may also want to add some trusted locations.  Usually if there is a problem it is somewhere in those menu's.
0
 
LVL 13

Expert Comment

by:BCipollone
ID: 36712988
Oh also you might want to uncheck this box....  File>Options>Advanced>General>"Ignore other applications that use DDE"
0
 
LVL 12

Author Comment

by:ryan80
ID: 36713034
The issue is, that I dont want to update from the other documents. I want to keep that values currently saved in the worksheet without refering to the other documents. Excel 2007 works fine, 2010 does not.

I have selected to ask before automatically updating workbook links, and hit deny, and have also disabled updating workbook links altogether, but it does not work. I also tried disabling an option under advanced>when calculating this workbook>update link to other documents, but have found that it does not retain this setting, even after saving it and reopening it. Plus having to do this for every document and resave it is not a viable option since there are hundreds if not thousands of Excel sheets just like this.



0
 
LVL 12

Accepted Solution

by:
ryan80 earned 0 total points
ID: 36906014
So i found an answer for this. I called MS and opened a case and they gave me a solution and the reason for the behavior.

Excel will try to autocalculate any files that were made in a previous version. There is a regedit that can be added to stop this action.




Navigate to HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Excel\Options
Add new DWORD value (FullCalcOnLoadOldFile) - no parentheses
Set value to 0
0
 
LVL 12

Author Closing Comment

by:ryan80
ID: 36935292
no solution posted, found answer from other source and posted as reference to others.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When you see single cell contains number and text, and you have to get any date out of it seems like cracking our heads.
How to get Spreadsheet Compare 2016 working with the 64 bit version of Office 2016
This Micro Tutorial will demonstrate how to use longer labels with horizontal bar charts instead of the vertical column chart.
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question