?
Solved

Problem playing an MP4 video from iPad hosted on SharePoint 2007

Posted on 2011-09-27
6
Medium Priority
?
2,151 Views
Last Modified: 2012-05-13
Hello Experts,

I have a mp4 file file that is hosted on SharePoint.
I am having a problem playing it from my iPad. I do not get an error, just an broken play button/video icon.
I know my issue is not codec related as I can play that same exact from my iPad if copy to a differnt webserver. Something about the fact that video is hosted on SharePoint is blocking the iPad from playing the video.
Any Suggestions? Thanks!
0
Comment
Question by:MikeXna
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
6 Comments
 
LVL 4

Expert Comment

by:jschristian44
ID: 36713408
is sharepoint like a wifi spot or something?  try going into the settings in sharepoint and put like allow full use.  i know on networks you have to go in the properties and allow people to read/write so it is probably teh same thing.
0
 

Author Comment

by:MikeXna
ID: 36713795
Thanks for you comment, but I may need a Microsoft SharePoint Guru for this one, or a HTML 5 Code Guru.
I would also like to add that I am just clicking a link to the mp4 using a basic run of the mill A Tag.
In other words, It's just a normal link, I am not using any fancy html 5 video tag here.
Something on SharePoint,(core.js?) is causing some confusion on the iPad.
Anyone have any ideas?
I am tempted to look into a html 5 video tag solution, but I could use some advice for formatting a video tag.  In otherwords, Can someone share a complete sample starting with an IF statement so that the IF Browser is Mobile Safari or IF OS is iOS then process the video tag?
Thanks All for any advice.
0
 
LVL 82

Accepted Solution

by:
David Johnson, CD, MVP earned 2000 total points
ID: 37015698
in your IIS you need to add a mime type
Extension: mp4
MIME type: video/mpeg

now you should have no problems
0
 

Author Comment

by:MikeXna
ID: 37282818
I am sorry for the delay in responding.  Thank you for your comments.  I am only a site collection admin in share point so I asked my IIS admin to add the mp4 mime type.  That makes sense.  He said he did and the servers were restarted but continue to have the same issue playing the video on share point from iPad. Anything else to look for that can explain this?
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Is your phone running out of space to hold pictures?  This article will show you quick tips on how to solve this problem.
Originally, this post was published on Monitis Blog, you can check it here . It goes without saying that technology has transformed society and the very nature of how we live, work, and communicate in ways that would’ve been incomprehensible 5 ye…
This video will give a brief orientation and organization of Logic Pro X, and how to access different work spaces quickly with keyboard shortcuts.
Viewers will learn the basics of using Ableton Live's advanced sampler instrument, Sampler. Load new Sampler into an empty MIDI track: Select a sample and drop it into sample window in Sampler: Adjust pitch if necessary with Root Key setting: …
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question