Solved

Exchange server 2003 to 2010 redirect to wrong url

Posted on 2011-09-27
5
432 Views
Last Modified: 2012-05-12
Hi all

I have an exchange server 2003 on a windows server 2003 box witch has ran without issue for years
I have now installed a new exchange server 2010 on a virtual windows server 2008 using Hyper-V

I have around 100 legacy mailboxes and all users  can access their mail internally by  entering http://server1/exchange or externally by  entering http://my.domain.ie/exchange
I have created 2 mailboxes for testing on the 2010 exchange server and can access their mail internally at https://server2/owa or externally at https://my.domain.ie/owa
then I  moved 2 more users from exchange 2003 to 2010 and can now access their mail internally at https://server2/owa or externally at https://my.domain.ie/owa

now the problem starts

if I put http://server1/exchange (internally) and log into server1 with a 2010 mailbox I get redirected to https://server2/exchange
if I put http://my.domain.ie/exchange (externally) and log into the server1 with a 2010 mailbox I get redirected to https://server2/exchange

I have tried to set this redirect up in IIS manager but this sent  the 2010 user logging  into  the 2003 server into  a redirect loop  

Does anyone know how to configure this redirect correctly so 2010 users logging into the 2003 server gets redirected to https://server2/owa and not  https://server2/exchange
I have searched everything in IIS manager and exchange manager for this redirect but cannot find it anywhere

Thanks for any help with this

Regards
Robert
0
Comment
Question by:IP4IT Staff
  • 2
  • 2
5 Comments
 

Expert Comment

by:MaxKroy
ID: 36713327
Check your C:\Windows\System32\drivers\etc\hosts file in notepad and check to make sure the ip is not hard coded into this file.  It would look like this:

192.168.0.X     'web site name'

Also did you check the (A) hosts in the DNS MMC?

0
 

Author Comment

by:IP4IT Staff
ID: 36713404
Hi MaxKroy

all thats in the hosts file is # Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#      127.0.0.1       localhost
#      ::1             localhost

and the (a) hosts in mmc all seem ok they just have the server names and the correct IP addresses
thanks for your help I really appreciate it  
0
 

Expert Comment

by:MaxKroy
ID: 36713480
Did you change any router settings for port 25 or port 443 that would lead to the redirect?
0
 

Author Comment

by:IP4IT Staff
ID: 36713562
hi MaxKroy

port 80 points to server 1 (http://my.domain.ie/exchange)
port 443 points to server 2 (https://mydomain.ie/owa
port 25 points to server1

as far as I can tell this redirect is enforced by Exchange 2010 to allow 2010 users to log in to the 2003 server, it then looks to AD to see where the mailbox is and then redirects to the correct server
this redirect  is configured during the install of exchange 2010 and I must have put the wrong url at the time of install and now that the install is done I cannot find it to edit it
From some articles I have read on this it looks like this redirect is handled by IIS and cannot be edited using the IIS manager

thanks again
0
 
LVL 7

Accepted Solution

by:
PraveenBalan earned 500 total points
ID: 37551932
Hi Rob,

I think you may be missing some part of Client Access Server configuration,

first of all, all the client access request should land up to the Exchange 2010 CAS server only, whether it is for legacy mailbox or a 2010 mailbox. i.e my.domain.ie should point to you exchange 2010 CAS server from internet.

And if you really want the /exchange to work for internal request, I think you will find answer in below technet blog,
http://blogs.technet.com/b/exchange/archive/2010/02/10/3409322.aspx

also read a small article from technet, that talks about the placement of CAS server in ex 2003 mix enviroment.

http://technet.microsoft.com/en-us/library/ee332348.aspx

I know it is tedious job to read, but no other go .. :)

-Praveen
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

OfficeMate Freezes on login or does not load after login credentials are input.
A safe way to clean winsxs folder from your windows server 2008 R2 editions
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

706 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now