reboot windows 2003 R2 via command line

have a 2003 r2 server that is having probs. with dns of the domain server. When it does not Link up the normal way via domain, have to go in to "local" login. Prob. is that at that point i can't "reboot" the sys. as the only option is to "log off administrator:" att command line, dos prompt, what command is used to "reboot" the server??. I can't remember what if any there is..please advise...
only has serv. pack 1 currently
gstevederbyAsked:
Who is Participating?
 
ScownConnect With a Mentor Commented:
open a command prompt
type: shutdown -i
This will open a gui to add the remote server from another pc or server.
0
 
khairilCommented:

Try this using command line:

Shutdown -r -f -t 0

Open in new window


0
 
giladhechtCommented:
"Shutdown -r" is the basic command,to that i personally add "-t 00" so that the reboot will occur with no delay. (so it will be "shutdown -r -t 00")
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
khairilCommented:
Opps.. use slash:

Shutdown /r /s /t 0 

Open in new window


0
 
khairilCommented:
Ahha.. typo again,

Shutdown /r /f /t 0 

Open in new window


You can try Shutdown /? for more info.
0
 
gstevederbyAuthor Commented:
just tried and it says access denied
0
 
ganesh0307Commented:
are you trying to shutdown remotely....
0
 
gstevederbyAuthor Commented:
yes via logmein
0
 
Radhakrishnan RSenior Technical LeadCommented:
If you are using LogMeIn rescue, you can hold the session and start as system applet service, then you can reboot the server (there is a option for reboot with windows credentials). If you do this after reboot you will get the session back automatically. Or you can directly reboot you will get the connection back.

If you are only looking for command, you can use the command line Shutdown /r /f /t 0  as khairil suggested.
0
 
ganesh0307Commented:
If you want to use remote shutdown command then your ID should have admin previlege on destination computer...
0
 
ChiefITCommented:
Why don't you let us help you troubleshoot and fix the problems on the server. It appears a periodic reboot is not really what you want. I have an idea what your server problems really are.

Please continue on with this thread to reboot, but consider opening up another question to address the problem head on instead of a work around by rebooting. .
0
 
kevinhsiehCommented:
I recommend installing SP2 as a good step forward in getting your system stable. Microsoft stopped supporting SP1 a while ago.
0
 
ChiefITCommented:
@Kevenish and the Author:
I was going to recommend that on another thread. Service Pack 1 has miscoded MTU Settings that causes intermittent DNS connectivity and problems with networking. This is what I was suspect of your problem.

Nevertheless, the author wanted to know how to reboot the system, and I didn't want to interfere with other experts.

About SP1 and the MTU problem:
http://support.microsoft.com/kb/898060
0
 
gstevederbyAuthor Commented:
i Will do service pack 2 as soon as I have a clone of the hd. this weekend. But I did go to the server directly on site and still got the access denied when trying to run the command shutdown / r /t 0 and other combos of same. I do agree that it is a DNS issue to be dealt with but need to be able to reboot when in local mode versus having to "just power off" as that is never good if it can be helped....what else can be done in the interim ...thx

0
 
gstevederbyAuthor Commented:
chiefIt how do i reach you if they decide to have you look at?
0
 
ChiefITCommented:
Regardless of the circumstances, it is advisable not to use SP1. Intermittent communications can result from SP1. I have seen it many times. Most of the time you will see in the event logs Error 5719 within the system event logs of the server that has SP1 on it. What you will see, is the DNS service stopped, or the DHCP service stopped (if the server hosts DHCP). Improperly coded MTU settings will result in intermittent communications as you are explaining.

Now, since this is a terminal server, SP2 also has a gliche. Terminal services can pick an application port other than 3389 (the default terminal service port). However, you can hard code the terminal services port to use port 3389 at all times. So, for this discrepancy, there is a work around. On this discrepancy, all you will see is a problem with terminal services. But, that's better than complete problems with intermittent communications and you can control it with the work around.

Here are known issues with SP2 that you can control:
http://www.lan-2-wan.com/2003-SP2.htm
0
 
gstevederbyAuthor Commented:
not a terminal server. It has a pick o.s. under a windows shell. Running D3 , raining data, software...which complicates things as well....
0
 
ChiefITCommented:
To reach me, log on and post on the forum. Don't leave any contact or Personal Informaiton on a public Forum. I am best reached through your post here on EE.
0
 
gstevederbyAuthor Commented:
ok, i will try scown's suggestion
0
 
gstevederbyAuthor Commented:
looks good for controlling other computers from internal commands..i like it
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.