Crystal reports crosstab chart

In the report example posted on 09/26/11 06:33 PM, ID: 36656043  , I can't figure out how you got the "columngroup" in the cross tab to show the headers. COQ-test-crosstab.rpt
Genius123Asked:
Who is Participating?
 
GJParkerConnect With a Mentor Commented:
Another way of doing this would have been remove @columngroup from the crosstab and on teh customise style screen select 'Show labels' thsi then adds a text label for each summarised field which you can then edit with the necessary column title.

0
 
GJParkerCommented:
If you right mouse click on the @columngroup  field in the crosstab -> format field -> common tab -> display string this contains the headings

"    Frame             Glass            CSI             Total " & chr(13) &
"   Revenue         Revenue     Revenue   Revenue"

Not sure why it's been done this way you could just have this as the formula for @columngroup
0
 
mlmccCommented:
Mainly because I was thinking about the display string and didn't think about just changing the formula

mlmcc
0
Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

 
mlmccCommented:
I tried removing the field and checking the box and the cross tab didn't show anything.  It needs a column to be able to show the data.
You can suppress the column group and it does show the headings.

mlmcc

0
 
GJParkerConnect With a Mentor Commented:
You also need to uncheck 'Suppress row grand totals' on the customise style tab
0
 
mlmccCommented:
Here is a start at usiing GJParker's method

mlmcc
COQ-For-ExpertsRev3.rpt
0
 
GJParkerCommented:
Heres the one without using the columngroup formula

 COQ-For-ExpertsRev3-1-.rpt
0
 
mlmccCommented:
Here is what CR XI does when you remove the columngroup from the columns in the expert
Are you using CR2008 or 2011?

mlmcc
COQ-For-ExpertsRev3a.rpt
0
 
GJParkerCommented:
You must have missed my earlier post #36717891

"You also need to uncheck 'Suppress row grand totals' on the customise style tab "

I'm using CR XI R2 but I've been using this method for many years in previous versions.
0
 
mlmccCommented:
Thanks.  I missed the comment on unchecking the total suppression.  
What is shown is the row totals and not the columns

mlmcc
0
 
mlmccCommented:
Reports I have built never lent themselves to cross tab except to create charts so I never really played with the options and features.

mlmcc
0
 
Genius123Author Commented:
Thank you both for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.