Solved

Exchange Rebuild from crash GAL issues

Posted on 2011-09-27
22
1,775 Views
Last Modified: 2012-05-12
Hi Everyone,

I have been working for 3 weeks on an exchange 2010 rebuild from a server crash with little to no data backup. I have completed a number of steps to get this backup up and running and have completed the users data re-population from OST converted to PSTs. Fortunately my AD server was another system so i have been able to copy some configuration from it but I now have 1 issue I have not been able to resolve regarding the default GAL

Basically in cache mode on outlook 2007 and 2010 clients they see a copy of the old Gal (I believe) as it has a number of users that I did not add to the new rebuilt server (called the server a new name exchserver3) but only in certain areas for example new email shows the list but add-delegates does not

If I turn cache mode off I see a GAL in delegates but is still shows all these old users but with a red circle/line through their icons.

I tried to use the send/receive - download address book and full details but in the pull down option in the bottom the \Global Address Book option is not there

I do have a somewhat retired exchange 2003 server on the domain still (and I used it to create and move user mailboxes to as part of the recovery) so perhaps this has something to do with the strange behavior.

Also, I created a new global address list call "test GAL" and I can see it on the exchange but not on the client or in OWA. (used EMS command to create it)

please let me know your thoughts or if you need any further information

thanks,

TheSonicGod
0
Comment
Question by:TheSonicGod
  • 12
  • 9
22 Comments
 
LVL 20

Expert Comment

by:Hendrik Wiese
ID: 36714979
Try the following: Update-GlobalAddressList - Identity "Global Address List" -DomainController "YourDomainControllerName"

If that does not work, then try this:
1. Go to the EMC > Organization Configuration > Mailbox Node > Offline Address book tab and click update on the Default OAB,
Then  check the “Date modified” attribute of LZX files under …\Exchange Server\ExchangeOAB
2. Restart “ Microsoft Exchange File Distribution” service,
Then check the “Date modified” attribute of LZX files under …\Exchange Server\ClientAccess\OAB
If both “Date modified” attribute is the latest time, it means you have update OAB successfully.
3. Force Outlook updating OAB.
Restart Outlook or press “Send/Receive”àClick “send/Receive Groups”àClick “Download Address Book”

Reference: http://social.technet.microsoft.com/Forums/en-US/exchangesoftwareupdate/thread/3acd502b-56a0-4b52-b304-a977def0549e/
0
 
LVL 20

Expert Comment

by:Hendrik Wiese
ID: 36714985
Sorry the above command had a space between - and Identity please find corrected script below:

Update-GlobalAddressList -Identity "Global Address List" -DomainController "YourDomainControllerName"

Open in new window

0
 
LVL 24

Expert Comment

by:-MAS
ID: 36715016
You can export all the mails to PST by opening outlook as work offline.
No need to convert OST to PST


Furthermore
Do you have your running EDB file which is crashed. Then you can extract all mailbox emails from that EDB file.
check this
http://www.clickzones.net/index.php?option=com_content&view=article&id=47&Itemid=70
0
 

Author Comment

by:TheSonicGod
ID: 36861790
Thanks HendrikWiese - sorry for the delay in my reply

I completed the above steps as you advised this evening but it seems I still have the issue.

However, I do have additional information from these items you had me do:

1) Ran the Update-GlobalAddressList command as specified and entered "Default Global Address List" for identity and DC name for domain controller from within EMS and got a number of errors like this:

The recipient "eei.com/Microsoft Exchange System Objects/Offline Address Book - First Administrative Group" is invalid and couldn't be updated.

I got approx 20 errors each point to different contacts/free busy/public folders/etc (pls see image1 below)

2) Then I ran the update on the Default OAB, and it came back and advised it had completed successfully and the dates on the LZX files were showing today's date

3) Then I restarted Microsoft Exchange File Distribution service and checked the dates on the additional folder's LZX files and there were approx 100 with today's date and about 200 with a date that was 9 days old

4) Then I proceed within outlook and tried to do a download address book and the default global address book is still not an option and still is not show in the delegates area

However, I did notice something that might point us in the right direction. When I went into properties on the server in EMC > Organization Configuration > Mailbox Node > Offline Address book tab and properties on the Default OAB under the address lists tab the option to include the Default GAL is greyed out. (pls see image2 below)

thanks for your help HendrikWiese and if you have any more ideas please let me know.  ems-errors emc-issue
0
 
LVL 20

Expert Comment

by:Hendrik Wiese
ID: 36890002
If you un-check the Include the following address lists, doesn't the Include the default global Address List check box become available?
0
 
LVL 20

Expert Comment

by:Hendrik Wiese
ID: 36890028
In EMC > Server Confgiguration > CAS/HUB Server
1. Is Outlook Anywhere Enabled? If not Enable it by clicking on the Enable Outlook Anywhere in the Actions Pane.
2. If so...Select Offline Address Book Distribution tab at the bottom
3. Double click the "OAB (Default Web Site)" and ensure that your internal and external URL's are correct.
0
 
LVL 20

Expert Comment

by:Hendrik Wiese
ID: 36890128
Also have a look at the following article and ensure that all steps are done:

http://technet.microsoft.com/en-us/library/bb124719.aspx
0
 

Author Comment

by:TheSonicGod
ID: 36901728
Thanks HendrikWiese - sorry again for the delay in my reply - fighting a flu bug for the last week so have not been in the office every day.

1) I un-checked the Include the following address lists, but the default global Address List check box did not become available (see image 3)  image 3
2) I checked the outlook anywhere and it is enabled (see image 4 below) and the internal and external URL's are correct for OWA default website (I checked this via EMC > Server config >Client Access > Outlook Web App > OWA properties - assume this is correct location)
 image 4
3) For the included link to the technet doc I ran through it and I do not seem to have all the options under the tabs it refers to I have included a screen shot of the General and Distribution tab (image 5 & 6 below) and you have the address lists tab already. I do not think this is a permission issue but perhaps you can advise on this.  image 5 image 6
Thanks again for all your help - please let me know if you have any additional suggestions.
0
 
LVL 20

Expert Comment

by:Hendrik Wiese
ID: 36901772
Try to move the Offline Address Book Generation Process to your exchange 2010 Server:

http://technet.microsoft.com/en-us/library/bb125184.aspx
0
 
LVL 20

Expert Comment

by:Hendrik Wiese
ID: 36901776
0
 

Author Comment

by:TheSonicGod
ID: 36901846
Hi HendrikWiese

Says it is already on the 2010 server (please see screen shot of error - image 7) when I tried to move.

Remember that all this was up and running on the 2010 server that we lost so I just reused the 2003 server to setup mailboxes on to get the office up and running since AD still could see the accounts. Then moved the role/mailboxes onto the new server.

hope that helps explain the configuration.

thanks,

TheSonicGod
image7.jpg
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:TheSonicGod
ID: 36911120
HI HendrikWiese,

I discovered something interesting today about the server. It seems that the GAL is working, but is just not showing up in some areas.

I generated 1 room mailbox for resource use today and it was immediately available in the calendar options when you pull down the GAL list.

However, you can not select the GAL list for delegates still so it looks like there is still somehthing wrong. Also still can not select it in EMC or send/receive options.

thought this may help.

thanks again.
0
 
LVL 20

Accepted Solution

by:
Hendrik Wiese earned 500 total points
ID: 36911297
I am starting to think that there is no Default Global Address list on your server.

Try the following to create it and see if the GAL option becomes available in EMC:
New-GlobalAddressList -Name "Default Global Address List" -IncludedRecipients MailboxUsers 

Open in new window

0
 

Author Comment

by:TheSonicGod
ID: 36914889
Hi

Ran the command and got this error: (the XXXXXX's are mine to wipe out the domain name and company name):

[PS] C:\Windows\system32>New-GlobalAddressList -Name "Default Global Address List" -IncludedRecipients MailboxUsers

Active Directory operation failed on sqlserver.XXX.com. The object 'CN=Default Global Address List,CN=All Global Addres
s Lists,CN=Address Lists Container,CN=XXXXXXXX XXXXXXXX,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=eei,
DC=com' already exists.
    + CategoryInfo          : NotSpecified: (0:Int32) [New-GlobalAddressList], ADObjectAlreadyExistsException
    + FullyQualifiedErrorId : 3B2A490D,Microsoft.Exchange.Management.SystemConfigurationTasks.NewGlobalAddressList
0
 
LVL 20

Assisted Solution

by:Hendrik Wiese
Hendrik Wiese earned 500 total points
ID: 36914934
Ok then it is not set as default:

Do the following:

Set-GlobalAddressList "Default Global Address List" -RecipientFilter {(Alias -ne $null -and (ObjectClass -eq 'user' -or ObjectClass -eq 'contact' -or ObjectClass -eq 'msExchSystemMailbox' -or ObjectClass -eq 'msExchDynamicDistributionList' -or ObjectClass -eq 'group' -or ObjectClass -eq 'publicFolder'))}
 
Then, get-globaladdresslist -Identity "Default Global Address List" | format-list   showed that it was not set as default, so I used ADSI edit to set msExchRecipientFilterFlags as value 3, per above article.
 
Now  get-globaladdresslist -Identity "Default Global Address List" | format-list   shows the default global address list as default and EXBPA does not complain about it being missing.

Reference: http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/3d628056-4a9a-4d8d-a5b5-0267330d2d33/
0
 
LVL 20

Assisted Solution

by:Hendrik Wiese
Hendrik Wiese earned 500 total points
ID: 36914955
Sorry the above is a bit messy:

So do the following:

1. Run this script:
Set-GlobalAddressList "Default Global Address List" -RecipientFilter {(Alias -ne $null -and (ObjectClass -eq 'user' -or ObjectClass -eq 'contact' -or ObjectClass -eq 'msExchSystemMailbox' -or ObjectClass -eq 'msExchDynamicDistributionList' -or ObjectClass -eq 'group' -or ObjectClass -eq 'publicFolder'))}

Open in new window


2. Now run the following and look to see if your "Default Global Address List" is set as default:
get-globaladdresslist -Identity "Default Global Address List" | format-list

Open in new window


If it is not set as Default then open ADSI edit and set the msExchRecipientFilterFlags as value 3 for more detail on how to do this click here

3. Now run the following command again and ensure that it is now your default address list:
get-globaladdresslist -Identity "Default Global Address List" | format-list

Open in new window


You should also run ExBPA to ensure that everything is correct.
0
 

Author Comment

by:TheSonicGod
ID: 36915090
Hi HendrikWiese

The directory CN=Default Global Address List in ADSI is completed blank - I tried to add new object and add the msExchRecipientFilterFlags and set the defaultstring to 3 but it did not work - not sure if I added it right as the only string option is AddressBookContainer that i can add
0
 
LVL 20

Assisted Solution

by:Hendrik Wiese
Hendrik Wiese earned 500 total points
ID: 36915165
Let's just check your steps:

1. Open ADSI Edit
2. Now right click and select connect
3. Select Configuration in the "Select a well known Naming Context" drop down and click ok as seen below:
 Select Configurations
4. Expand to the following:
Configuration [<domainController>.contoso.com]
CN=Configuration,DC=contoso,DC=com
CN=Services
CN=Microsoft Exchange
CN=<OrganizationName>
CN=Address Lists Container
CN=All Global Address Lists

5. Now you should see "CN=Default Golbal Address List" in the right pane
6. Right Click on it and click properties
7. Now on the "Attribute Editor" tab locate msExchQueryFilter and then click Edit
8. Type or paste the following query filter into the Value box, and then click OK:
(Alias -ne $null -and (((((ObjectClass -eq 'user' -or ObjectClass -eq 'contact') -or ObjectClass -eq 'msexchsystemmailbox') -or ObjectClass -eq 'msexchdynamicdistributionlist') -or ObjectClass -eq 'group') -or ObjectClass -eq 'publicfolder'))

Open in new window

9. On the Attribute Editor tab, click purportedSearch, and then click Edit.
10. Type or paste the following query filter into the Value box, and then click OK:
(&(mailNickname=*)(|(objectClass=user)(objectClass=contact)(objectClass=msexchsystemmailbox)(objectClass=msexchdynamicdistributionlist)(objectClass=group)(objectClass=publicfolder)))

Open in new window

11. Now locate msExchRecipientFilterFlags and click edit and change value to 3
12. Click OK, and then exit the ADSI Edit tool.

Now open EMS and run the following in shell again:
get-globaladdresslist -Identity "Default Global Address List" | format-list

Open in new window


And Ensure that isDefaultGlobalAddressList is set to true
0
 

Author Comment

by:TheSonicGod
ID: 36915178
Hi HendrikWiese

You are a super genius, please ignore my last post I misread the ADSIedit commands. I change the value to 3 and it took a couple of minutes but it eventually showed as TRUE for the default and now in the OAB properties it is no longer greyed out.

I forced an update of the OAB after selecting to include the GAL and then downloaded the address books in outlook and the all users one is now showing under Delegates.

The only question I have is the GAL did not show as an option in outlook to choose to download via Send/receive - will that eventually show up?
0
 
LVL 20

Assisted Solution

by:Hendrik Wiese
Hendrik Wiese earned 500 total points
ID: 36915212
Haha...Glad I can help!!!

Now follow the initial post and let me know if it updates:

1. Go to the EMC > Organization Configuration > Mailbox Node > Offline Address book tab and click update on the Default OAB,
2. Restart “Microsoft Exchange File Distribution” service,
3. Force Outlook updating OAB.
Restart Outlook or press “Send/Receive” and click “send/Receive Groups” and click “Download Address Book”

Cheers!!!
0
 

Author Comment

by:TheSonicGod
ID: 36915253
Hi HendrikWiese

You are too good to me.

Yep Global Address List is now showing in outlook for download and under Delegates.

Thanks again for all your Help here - I really appreciate it.

I owe you a Cold Canadian Beer!!!!
0
 

Author Closing Comment

by:TheSonicGod
ID: 36915277
HendrikWiese was excellent - covered all the basis and kept with me to the end
0

Featured Post

Want to promote your upcoming event?

Are you going to an event? Are you going to be exhibiting at a tradeshow? Talking at a conference? Using a promotional banner in your email signature ensures that your organization’s most important contacts stay in the know and can potentially spread the word about the event.

Join & Write a Comment

Find out how to use Active Directory data for email signature management in Microsoft Exchange and Office 365.
Not sure what the best email signature size is? Are you worried about email signature image size? Follow this best practice guide.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now