Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1893
  • Last Modified:

Windows Multipoint Server 2011 Droping RDP Users

Multipoint Server 2011

Help me Please. This is an issue for rdp users only. Local users are fine.
Have tried 3 fresh builds on 3 differnt brand new PC's (3 differnt client sites) one of those builds I used a HP ML350 server (just to see if using an actual server would help) with a server grade network card. These servers have been joined to SBS2008 and a SBS2011 Domain. Have tried changing TOE and RSS settings on network card, upgrading drivers Removing Anti Virus Software. Ive tried brand new managed GB switch. One of the Multi Point servers i had to rebuilt with Server 2008 R2 with RDS Role which is working perfectly so i dont think hardware is to blame. This error will also happen with only user connected via RDP so its not like its being over loaded. Have tried changing performance settings to "backround services" as suggested by MS Technet.

In the event logs i see.
The RDP protocol component X.224 detected an error in the protocol stream and has disconnected the client.
and
The Terminal Server security layer detected an error in the protocol stream and has disconnected the client. Client IP 192.168.x.x
0
safemode_nz
Asked:
safemode_nz
1 Solution
 
safemode_nzAuthor Commented:
users can connect they just get disconnected after working for so many minutes or hours. they can then log back on to resume their  RD session.
0
 
David Johnson, CD, MVPOwnerCommented:
what version of rdp are they using? it probably is a client issue
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
safemode_nzAuthor Commented:
It’s not a client issue. The users are using the latest version of rdp 7 and some are using 6. It happens to all users on 3 different client sites. I’m almost ready to write off yet another multi point build and do another build with server 2008 r2 with remote desktop services as I’ve done for one of the failing multipoint sites. Server 2008 R2 builds are working perfectly. What could be so different with Multi Point compared to Server 2008 R2.
0
 
Jaroslav MrazCTOCommented:
Do you using default RPD settings ? Iam using same without problem.
0
 
safemode_nzAuthor Commented:
Yes RDP is default settings and i have nothing differnt to my Server 2008 R2 install which works perfectly on the same hardware.
0
 
safemode_nzAuthor Commented:
SOLVED: Problem was with RDP Shortcuts, Using multipoint console to create the RDP shortcut has solved the problem. Havent had any drop outs since. I’ve noticed using standard mstsc to create the RDP file adds a lot more prams to the RDP file compared to the MP Console. See below.

RDP file from Multipoint Console:

bitmapcachesize:i:
high resolution mouse:i:0
multimediaenableredirection:i:1
redirectclipboard:i:1
redirectposdevices:i:0
redirectprinters:i:0
redirectcomports:i:0
redirectsmartcards:i:0
devicestoredirect:s:
drivestoredirect:s:*
redirectdrives:i:1
session bpp:i:32
prompt for credentials on client:i:1
span monitors:i:1
use multimon:i:1
server port:i:3389
allow font smoothing:i:1
connection type:i:6
disable wallpaper:i:0
allow desktop composition:i:1
disable full window drag:i:0
disable menu anims:i:0
promptcredentialonce:i:1
authentication level:i:2
gatewayusagemethod:i:2
gatewayprofileusagemethod:i:0
gatewaycredentialssource:i:0
full address:s:MPSSRV
gatewayhostname:s:

RDP File using standard MSTSC

screen mode id:i:2
use multimon:i:0
desktopwidth:i:1366
desktopheight:i:768
session bpp:i:32
winposstr:s:0,3,0,0,800,600
compression:i:1
keyboardhook:i:2
audiocapturemode:i:0
videoplaybackmode:i:1
connection type:i:2
displayconnectionbar:i:1
disable wallpaper:i:1
allow font smoothing:i:0
allow desktop composition:i:0
disable full window drag:i:1
disable menu anims:i:1
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:1
full address:s:
audiomode:i:0
redirectprinters:i:1
redirectcomports:i:0
redirectsmartcards:i:1
redirectclipboard:i:1
redirectposdevices:i:0
redirectdirectx:i:1
autoreconnection enabled:i:1
authentication level:i:2
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:4
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:1
use redirection server name:i:0
0
 
safemode_nzAuthor Commented:
Always use microsoft wizards :)
0
 
DudsianCommented:
Finaly got around to investigating my RDP disconnections after giving up on Multipoint Server months ago.

Maybe I am being a little stupid but I cannot find how to create an RDP file from the console.

I could always use yours as a template but I am curious as to where the MS Wizard is.

Cheers in advance.

Stop Press:

Found it.
It's the "save connection settings to file" link on the console.
It could have been a bit more intuitive for us thickies by saying "Create RDP Shortcut" or some such.

Having said that, if only MS had got their finger out and created some decent documentation about remote access to MP then neither of us whould have hit this problem.

Many thanks
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now