• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 512
  • Last Modified:

3800 router needs IOS loaded

I have  a 3825 router.  It does not have a a IOS loaded on it.  I am trying to use putty/hyperterminal to load the IOS.  I have the IOS ready to go with xmodem protocol.

However do I need to use a cat 5 cable to send the IOS?

I have changed my speed to 115200 on the router

I have changed my speed on my emulator (Hyperterminal) to 115200

I am stuck at the stage of sending the IOS over to the router.

Need some help

2 Solutions

You'll need to connect a cisco console cable to the console port to perform the upload in this way.
Captain-JonasAuthor Commented:
Hey It worked and this is what I did

Load IOS on  a router
Change the emulator / router speeds to 115200
There are two ways to get to the rommon:  The following is way 1
      “I have an IOS already loaded”
1.      2620#configure terminal  
2.      Enter configuration commands, one per line.  End with CNTL/Z.
3.      2620(config)#con
4.      2620(config)#conf
5.      2620(config)#config-register 0x0
6.      2620(config)#^Z
7.      2620#reload
8.      System configuration has been modified. Save? [yes/no]: n

The other way is that you don’t have a IOS loaded at all and you have to use the break to get to any kind of prompt (rommon) U can also change the jumpers on the mother board…

a.      You can turn the router on and hit the (break or space bar in the first 60 sec)
b.      Get to rommon
c.      rommon 2 > confreg
d.      change console baud rate? y/n  [n]:  y
e.      change the boot characteristics? y/n  [n]:  y
f.      enter to boot:
g.       0 = ROM Monitor =   0
h.      Open a new hyperterminal with these settings:
i.      Bits per second - 115200
j.      Data bits - 8
k.      Parity - None
l.      Stop bits - 1
Flow control - Hardware
m.      After setting the hyperterminal, you receive a rommon prompt. Enter the xmodem command. Before you enter an xmodem command, there should be a software image residing in your terminal or your local hard drive.
n.      rommon 2 > xmodem -c c3640-i-mz.121-7.bin

Remember to change the baud on both the router / terminal emulator (Putty)

From your terminal emulator Transfer – Send File – Filename. (IOS w/.bin)
For protocol use Xmodem
For more info look at the following

Thanks everyone for your help

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now