No replica's for system folders after migration from Exchange 2003 to 2010

Hi,

We recently upgraded our Exchange 2003 environment to a new Exchange 2010SP1 environment, and replicated all public folders to this new environment.  We decommissioned all Exchange 2003 servers, and everything works well, except that we have some cosmetic sync issues in our Outlook clients in cached mode (=known problem).  In one of the document about these sync issues, someone mentioned checking the EFORMS REGISTRY-public folder.  Now when I check the replica's of the system folders in the new Exchange 2010 environment, the 3 system folders (written in CAPITALS) EFORMS REGISTRY, OFFLINE ADDRESS BOOK and SCHEDULE+ FREE BUSY have no replica's at all.  However, the subfolders in these 3 folders do have replica's on all public folder servers.  If I try to add a replica to one of these 3 capital folders, I get an error message "Modification of the '\NON_IPM_SUBTREE\EFORMS REGISTRY' folder isn't allowed.  Is this something I should be worried about or is this working as designed?

Kind regards,
Bertin
SysUASystems AdministratorAsked:
Who is Participating?
 
gaurav05Commented:
Hi,

have you update exchange 2010 with sp1 ?


also check this blog

http://clintboessen.blogspot.com/2009/06/cannot-add-replicas-to-certain-system.html
0
 
gaurav05Commented:
Hi,

When moving to a new Exchange 2010 environment and still are using Public Folder, this is the fast way of adding a new replica.

Add a replica of all public folders to the new environment:
# .\AddReplicaToPFRecursive.ps1 -TopPublicFolder \ -Server 'SourceServer' -ServerToAdd 'TargetServer'

Note:
In Exchange RTM we needed to change the AddReplicaToPFRecursive.ps1, in SP1 this is fixed.
Add a single quote ‘ around the $TopPublicFolder in the two lines listed. That allows the script to recognise the entire string and not to break it at the first space.

if ($server)
{
$getpfcmd = “get-publicfolder -server $Server -identity ‘$TopPublicFolder’ -Recurse -resultsize unlimited”
}
else
{
$getpfcmd = “get-publicfolder -identity ‘$TopPublicFolder’ -Recurse -resultsize unlimited”
}

Add a replica of all relevant system folders to the new environment:
# .\AddReplicaToPFRecursive.ps1 -TopPublicFolder "\NON_IPM_Subtree\EFORMS REGISTRY" -Server 'SourceServer' -ServerToAdd 'TargetServer'

# .\AddReplicaToPFRecursive.ps1 -TopPublicFolder "\NON_IPM_Subtree\OFFLINE ADDRESS BOOK" -Server 'SourceServer' -ServerToAdd 'TargetServer'

# .\AddReplicaToPFRecursive.ps1 -TopPublicFolder "\NON_IPM_Subtree\SCHEDULE+ FREE BUSY" -Server 'SourceServer' -ServerToAdd 'TargetServer'
0
 
SysUASystems AdministratorAuthor Commented:
Hi,

We synchronized the servers and decommisioned the Exchange 2003 servers before applying SP1.  At this point, we do not have any Exchange 2003 servers anymore, so running the modified powershell script is no option for us, as we have no 'SourceServer' anymore...  I just have to add one (or both) of my 2 Exchange 2010SP1 servers to the replica list of this folders.  At this time, these 3 folders have no replica's at all...

Kind regards,
Bertin
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.