Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 426
  • Last Modified:

Joomla Article link not working

the following link to a published article does not display.

http://www.icepe.eu/index.php?option=com_content&view=article&id=157:rosemary-kilpatrick&catid=35

The ID of th article is 157 but the page not found error says article 154 is not found. Cache has been cleared and yes I deleted the article with ID 154. WHy is Joomla trying to display the wrong article than what is specified in the URL? I shtis a known Joomla bug?? I have this problem with 2 articles currently ...
0
Needy11
Asked:
Needy11
  • 9
  • 7
1 Solution
 
Andrew DerseIT ManagerCommented:
What version of Joomla are you using?

Also, try turning off all of your SEO functions and check to see if this is still happening.

To turn off SEO, please go to:

Control Panel
Global Configuration
Set everything to match this:
 seo
0
 
Needy11Author Commented:
Hi NuKit,

We are using Joomla 1.5.15. I changed the SEO settings as you suggested but still get the same 404 error...

Thanks for the help.
0
 
Andrew DerseIT ManagerCommented:
When I click on the above link it takes me here:

http://www.icepe.ie/rosemary-kilpatrick.html

not

http://www.icepe.eu/index.php?option=com_content&view=article&id=157:rosemary-kilpatrick&catid=35

Do you have any other SEF plugins installed?  Maybe sh404SEF or something like that?  Something is translating your URLS to the top link and your site isn't liking it.

Also, it's worth it to upgrade to Joomla 1.5.23.  It's more secure and stable.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
Andrew DerseIT ManagerCommented:
Also, I cleaned up the link from above to this:

http://www.icepe.eu/index.php?option=com_content&view=article&id=157:rosemary-kilpatrick&catid=35

The & will not resolve in the URL, but & will.  & is the code for &.
0
 
Needy11Author Commented:
I have sh404sef and disabled it, but no change on that front still getting 404 error for wrong article ID. I have included a capture of plugins that might be the cause if you could advise.

Tx
joomlaplugins.PNG
0
 
Andrew DerseIT ManagerCommented:
Needy11,

Are you reverting the site back to the original state after you disable the plugin?  In other words, are you disabling it, then re-enabling it after your tests?

I am trying to test your site, but it's showing that something is still modifying your URLs.

 url
This should not be the case when all SEO settings are set to off and/or disabled...
0
 
Andrew DerseIT ManagerCommented:
Also, there might be more than 1 plugin for sh404SEF...I know there is in J1.6...not sure about J1.5 though...
0
 
Needy11Author Commented:
Yes I have reverted\reenabled the plugin after disabling didn't make a difference. Maybe I should have cleared cache too tho'??
0
 
Andrew DerseIT ManagerCommented:
Correct...you will always need to clear cache and refresh the page fully...(Shift + F5) before those go into place.

Can you disable them, then let me know so I can test a few things?
0
 
Needy11Author Commented:
Ok I have disabled sh404sef, seo, systemsef and left them off. No change though. Must be others involved in processing the URLS(?)
0
 
Needy11Author Commented:
Actually I have noticed with sh404sef disabled the tutors page that contains the  link does not show at all but does not give a 404 error..instead ot just reroutes to the main page

http://www.icepe.ie/index.php?option=com_content&view=article&id=157:rosemary-kilpatrick&catid=35
0
 
Andrew DerseIT ManagerCommented:
Must be...this is very interesting...
0
 
Andrew DerseIT ManagerCommented:
Any chance that I could take a look at the administrative side of your site to see what it might be?  If so, just click on the "Hire Me" button on my profile.
0
 
Needy11Author Commented:
Ok I think probl;em solved. The sh404sef plugin needed an url that matched the one above to allow the redirect to take place.

I have done that and all is working again. Tx for the help.
0
 
Andrew DerseIT ManagerCommented:
Oh, that's awesome.  Good to hear you figured it out.  I knew it had to do something with sh404sef...that thing almost always causes problems with sites.
0
 
Needy11Author Commented:
Thanks for the help.
0

Featured Post

[Webinar On Demand] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.

  • 9
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now